Bug 291782 - Moun crash when begin started
Summary: Moun crash when begin started
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 15:14 UTC by ladoleo
Modified: 2012-01-17 15:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ladoleo 2012-01-17 15:14:34 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I jus update my os...
When i try to start moun see only main window and then crash

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb779e930 (LWP 2457))]

Thread 2 (Thread 0xb549db70 (LWP 2461)):
#0  0x00b8fd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x001ed7d5 in do_gettime (frac=0xb549d020, sec=0xb549d018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002c04b6 in QTimerInfoList::updateCurrentTime (this=0x95eb744) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002c080a in QTimerInfoList::timerWait (this=0x95eb744, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002bf053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb549d12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002bf0ed in timerSourcePrepare (source=0x95eb710, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x03b5788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x03b58637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x03b58c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002bfb37 in QEventDispatcherGlib::processEvents (this=0x9502df0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002901dd in QEventLoop::processEvents (this=0xb549d2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00290421 in QEventLoop::exec (this=0xb549d2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0019390b in QThread::exec (this=0x9531bf8) at thread/qthread.cpp:498
#14 0x00270e2d in QInotifyFileSystemWatcherEngine::run (this=0x9531bf8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x001967b3 in QThreadPrivate::start (arg=0x9531bf8) at thread/qthread_unix.cpp:331
#16 0x00c39d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00d790ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb779e930 (LWP 2457)):
[KCrash Handler]
#7  0x001eae11 in QtPrivate::QStringList_contains (that=0xbff971f4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff971f4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x948e140) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x948e140, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff97414) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00297b7d in metacall (argv=0xbff97414, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x948e140) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x948e140, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff97414) at kernel/qmetaobject.cpp:232
#13 0x002a6a6a in QMetaObject::activate (sender=0x94ee2b8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x94ee2b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x94ee2b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff97558) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00297b7d in metacall (argv=0xbff97558, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x94ee2b8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x94ee2b8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff97558) at kernel/qmetaobject.cpp:232
#18 0x002a6a6a in QMetaObject::activate (sender=0x948e140, m=0x80950c0, local_signal_index=0, argv=0xbff97558) at kernel/qobject.cpp:3278
#19 0x00bff7c5 in MuonMainWindow::backendReady (this=0x948e140, _t1=0x94d07d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bff933 in MuonMainWindow::initObject (this=0x948e140) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x948e140) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x948e140, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff97684) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00297b7d in metacall (argv=0xbff97684, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x948e140) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x948e140, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff97684) at kernel/qmetaobject.cpp:232
#25 0x002a6a6a in QMetaObject::activate (sender=0x95024e0, m=0x3c7238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002ae375 in QSingleShotTimer::timeout (this=0x95024e0) at .moc/release-shared/qtimer.moc:82
#27 0x002ae42c in QSingleShotTimer::timerEvent (this=0x95024e0) at kernel/qtimer.cpp:308
#28 0x002a9994 in QObject::event (this=0x95024e0, e=0xbff97a7c) at kernel/qobject.cpp:1181
#29 0x08752d54 in notify_helper (e=0xbff97a7c, receiver=0x95024e0, this=0x9381570) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9381570, receiver=0x95024e0, e=0xbff97a7c) at kernel/qapplication.cpp:4458
#31 0x08758103 in QApplication::notify (this=0xbff97a7c, receiver=0x95024e0, e=0xbff97a7c) at kernel/qapplication.cpp:3886
#32 0x01181681 in KApplication::notify (this=0xbff97d90, receiver=0x95024e0, event=0xbff97a7c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0029119e in QCoreApplication::notifyInternal (this=0xbff97d90, receiver=0x95024e0, event=0xbff97a7c) at kernel/qcoreapplication.cpp:787
#34 0x002c1c10 in sendEvent (event=0xbff97a7c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x937e034) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002bf122 in timerSourceDispatch (source=0x937e000) at kernel/qeventdispatcher_glib.cpp:184
#37 0x03b5825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03b58990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03b58c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002bfada in QEventDispatcherGlib::processEvents (this=0x935f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0880ae3a in QGuiEventDispatcherGlib::processEvents (this=0x935f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002901dd in QEventLoop::processEvents (this=0xbff97cf4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00290421 in QEventLoop::exec (this=0xbff97cf4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0029519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x087508f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291778, bug 291776, bug 291767, bug 291765, bug 291732.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 15:17:40 UTC

*** This bug has been marked as a duplicate of bug 291262 ***