Bug 291778 - Muon Software Center Crashes Every Time
Summary: Muon Software Center Crashes Every Time
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 14:40 UTC by jgarfolo
Modified: 2012-01-17 14:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jgarfolo 2012-01-17 14:40:45 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
just starting muon software center. can't even update without going through the terminal. the window starts to load but usually in a second or two it crashes. Heard a lot of issues with this exact issue from others. Weird thin is that the Muon Package Manager works just fine from what I can tell.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7721930 (LWP 1787))]

Thread 2 (Thread 0xb5889b70 (LWP 1791)):
#0  0x06b4e0ca in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x06b4e990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x06b4ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0086bb37 in QEventDispatcherGlib::processEvents (this=0x95b04f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x0083c1dd in QEventLoop::processEvents (this=0xb58892b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x0083c421 in QEventLoop::exec (this=0xb58892b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0073f90b in QThread::exec (this=0x955ba88) at thread/qthread.cpp:498
#7  0x0081ce2d in QInotifyFileSystemWatcherEngine::run (this=0x955ba88) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x007427b3 in QThreadPrivate::start (arg=0x955ba88) at thread/qthread_unix.cpp:331
#9  0x08eccd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x005430ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7721930 (LWP 1787)):
[KCrash Handler]
#7  0x00796e11 in QtPrivate::QStringList_contains (that=0xbfe2f1c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe2f1c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x95163d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x95163d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe2f3e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00843b7d in metacall (argv=0xbfe2f3e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x95163d0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x95163d0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe2f3e4) at kernel/qmetaobject.cpp:232
#13 0x00852a6a in QMetaObject::activate (sender=0x957a2e8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x957a2e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x957a2e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe2f528) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00843b7d in metacall (argv=0xbfe2f528, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x957a2e8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x957a2e8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe2f528) at kernel/qmetaobject.cpp:232
#18 0x00852a6a in QMetaObject::activate (sender=0x95163d0, m=0x80950c0, local_signal_index=0, argv=0xbfe2f528) at kernel/qobject.cpp:3278
#19 0x00c7e7c5 in MuonMainWindow::backendReady (this=0x95163d0, _t1=0x9573e10) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00c7e933 in MuonMainWindow::initObject (this=0x95163d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x95163d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x95163d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe2f654) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00843b7d in metacall (argv=0xbfe2f654, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x95163d0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x95163d0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe2f654) at kernel/qmetaobject.cpp:232
#25 0x00852a6a in QMetaObject::activate (sender=0x956d5d8, m=0x973238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0085a375 in QSingleShotTimer::timeout (this=0x956d5d8) at .moc/release-shared/qtimer.moc:82
#27 0x0085a42c in QSingleShotTimer::timerEvent (this=0x956d5d8) at kernel/qtimer.cpp:308
#28 0x00855994 in QObject::event (this=0x956d5d8, e=0xbfe2fa4c) at kernel/qobject.cpp:1181
#29 0x02f5ad54 in notify_helper (e=0xbfe2fa4c, receiver=0x956d5d8, this=0x9425418) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9425418, receiver=0x956d5d8, e=0xbfe2fa4c) at kernel/qapplication.cpp:4458
#31 0x02f60103 in QApplication::notify (this=0xbfe2fa4c, receiver=0x956d5d8, e=0xbfe2fa4c) at kernel/qapplication.cpp:3886
#32 0x0114a681 in KApplication::notify (this=0xbfe2fd60, receiver=0x956d5d8, event=0xbfe2fa4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0083d19e in QCoreApplication::notifyInternal (this=0xbfe2fd60, receiver=0x956d5d8, event=0xbfe2fa4c) at kernel/qcoreapplication.cpp:787
#34 0x0086dc10 in sendEvent (event=0xbfe2fa4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9420fac) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0086b122 in timerSourceDispatch (source=0x9420f78) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06b4e25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06b4e990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06b4ec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0086bada in QEventDispatcherGlib::processEvents (this=0x9403238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03012e3a in QGuiEventDispatcherGlib::processEvents (this=0x9403238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0083c1dd in QEventLoop::processEvents (this=0xbfe2fcc4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0083c421 in QEventLoop::exec (this=0xbfe2fcc4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0084119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02f588f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291605.

Possible duplicates by query: bug 291776, bug 291767, bug 291765, bug 291732, bug 291725.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 14:41:44 UTC

*** This bug has been marked as a duplicate of bug 291262 ***