Bug 291732 - Muon package manager Crash
Summary: Muon package manager Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 04:26 UTC by Stephen
Modified: 2012-01-17 05:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.75 KB, text/plain)
2012-01-17 05:34 UTC, Whaka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen 2012-01-17 04:26:34 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was launching the muon package manager when it crashed. I have tried several times but it keeps crashing.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c4930 (LWP 4675))]

Thread 2 (Thread 0xb5abbb70 (LWP 4676)):
#0  0x00119416 in __kernel_vsyscall ()
#1  0x0073e40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0161134b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01602896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01602c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x002aeb37 in QEventDispatcherGlib::processEvents (this=0x8b15d80, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0027f1dd in QEventLoop::processEvents (this=0xb5abb2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x0027f421 in QEventLoop::exec (this=0xb5abb2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0018290b in QThread::exec (this=0x8c16560) at thread/qthread.cpp:498
#9  0x0025fe2d in QInotifyFileSystemWatcherEngine::run (this=0x8c16560) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x001857b3 in QThreadPrivate::start (arg=0x8c16560) at thread/qthread_unix.cpp:331
#11 0x008d8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x0074d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77c4930 (LWP 4675)):
[KCrash Handler]
#7  0x001d9e11 in QtPrivate::QStringList_contains (that=0xbfbd1bb4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfbd1bb4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8bb7618) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8bb7618, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd1dd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00286b7d in metacall (argv=0xbfbd1dd4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8bb7618) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8bb7618, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfbd1dd4) at kernel/qmetaobject.cpp:232
#13 0x00295a6a in QMetaObject::activate (sender=0x8c0a258, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c0a258) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c0a258, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd1f18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00286b7d in metacall (argv=0xbfbd1f18, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c0a258) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c0a258, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfbd1f18) at kernel/qmetaobject.cpp:232
#18 0x00295a6a in QMetaObject::activate (sender=0x8bb7618, m=0x80950c0, local_signal_index=0, argv=0xbfbd1f18) at kernel/qobject.cpp:3278
#19 0x00f517c5 in MuonMainWindow::backendReady (this=0x8bb7618, _t1=0x8c30d78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00f51933 in MuonMainWindow::initObject (this=0x8bb7618) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8bb7618) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8bb7618, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfbd2044) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00286b7d in metacall (argv=0xbfbd2044, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8bb7618) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8bb7618, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfbd2044) at kernel/qmetaobject.cpp:232
#25 0x00295a6a in QMetaObject::activate (sender=0x8c2e6e0, m=0x3b6238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0029d375 in QSingleShotTimer::timeout (this=0x8c2e6e0) at .moc/release-shared/qtimer.moc:82
#27 0x0029d42c in QSingleShotTimer::timerEvent (this=0x8c2e6e0) at kernel/qtimer.cpp:308
#28 0x00298994 in QObject::event (this=0x8c2e6e0, e=0xbfbd243c) at kernel/qobject.cpp:1181
#29 0x05a83d54 in notify_helper (e=0xbfbd243c, receiver=0x8c2e6e0, this=0x8aadcf8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8aadcf8, receiver=0x8c2e6e0, e=0xbfbd243c) at kernel/qapplication.cpp:4458
#31 0x05a89103 in QApplication::notify (this=0xbfbd243c, receiver=0x8c2e6e0, e=0xbfbd243c) at kernel/qapplication.cpp:3886
#32 0x0116c681 in KApplication::notify (this=0xbfbd2750, receiver=0x8c2e6e0, event=0xbfbd243c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0028019e in QCoreApplication::notifyInternal (this=0xbfbd2750, receiver=0x8c2e6e0, event=0xbfbd243c) at kernel/qcoreapplication.cpp:787
#34 0x002b0c10 in sendEvent (event=0xbfbd243c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ab0b54) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002ae122 in timerSourceDispatch (source=0x8ab0b20) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0160225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01602990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01602c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002aeada in QEventDispatcherGlib::processEvents (this=0x8a90238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05b3be3a in QGuiEventDispatcherGlib::processEvents (this=0x8a90238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0027f1dd in QEventLoop::processEvents (this=0xbfbd26b4, flags=...) at kernel/qeventloop.cpp:149
#43 0x0027f421 in QEventLoop::exec (this=0xbfbd26b4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0028419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05a818f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291725, bug 291724, bug 291723, bug 291699, bug 291692.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 05:28:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Whaka 2012-01-17 05:34:13 UTC
Created attachment 67916 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

just tried to launch it, it crash every time

-- Backtrace (Reduced):
#7  0x00731e11 in QtPrivate::QStringList_contains (that=0xbf9b92b4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9b92b4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9588d98) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9588d98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9b94d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007deb7d in metacall (argv=0xbf9b94d4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9588d98) at kernel/qmetaobject.cpp:237