Bug 291767 - Muon
Summary: Muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 12:43 UTC by Madina
Modified: 2012-01-17 13:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Madina 2012-01-17 12:43:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I am just run Muon application. Muon crashed and closed. Muon not work

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb785b930 (LWP 2319))]

Thread 2 (Thread 0xb53adb70 (LWP 2323)):
#0  0x00110416 in __kernel_vsyscall ()
#1  0x008fa40e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x013f034b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x013e1896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x013e1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x002e7b37 in QEventDispatcherGlib::processEvents (this=0x8f68e58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x002b81dd in QEventLoop::processEvents (this=0xb53ad2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x002b8421 in QEventLoop::exec (this=0xb53ad2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x001bb90b in QThread::exec (this=0x8eb1cc0) at thread/qthread.cpp:498
#9  0x00298e2d in QInotifyFileSystemWatcherEngine::run (this=0x8eb1cc0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x001be7b3 in QThreadPrivate::start (arg=0x8eb1cc0) at thread/qthread_unix.cpp:331
#11 0x00ae5d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x009090ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb785b930 (LWP 2319)):
[KCrash Handler]
#7  0x00212e11 in QtPrivate::QStringList_contains (that=0xbf840684, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf840684) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8e15c08) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8e15c08, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8408a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x002bfb7d in metacall (argv=0xbf8408a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8e15c08) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8e15c08, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8408a4) at kernel/qmetaobject.cpp:232
#13 0x002cea6a in QMetaObject::activate (sender=0x8e1a858, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8e1a858) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8e1a858, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8409e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x002bfb7d in metacall (argv=0xbf8409e8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8e1a858) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8e1a858, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8409e8) at kernel/qmetaobject.cpp:232
#18 0x002cea6a in QMetaObject::activate (sender=0x8e15c08, m=0x80950c0, local_signal_index=0, argv=0xbf8409e8) at kernel/qobject.cpp:3278
#19 0x00aab7c5 in MuonMainWindow::backendReady (this=0x8e15c08, _t1=0x8e6da30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00aab933 in MuonMainWindow::initObject (this=0x8e15c08) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8e15c08) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8e15c08, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf840b14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x002bfb7d in metacall (argv=0xbf840b14, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8e15c08) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8e15c08, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf840b14) at kernel/qmetaobject.cpp:232
#25 0x002cea6a in QMetaObject::activate (sender=0x8e65f28, m=0x3ef238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002d6375 in QSingleShotTimer::timeout (this=0x8e65f28) at .moc/release-shared/qtimer.moc:82
#27 0x002d642c in QSingleShotTimer::timerEvent (this=0x8e65f28) at kernel/qtimer.cpp:308
#28 0x002d1994 in QObject::event (this=0x8e65f28, e=0xbf840f0c) at kernel/qobject.cpp:1181
#29 0x05966d54 in notify_helper (e=0xbf840f0c, receiver=0x8e65f28, this=0x8d0f6c0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d0f6c0, receiver=0x8e65f28, e=0xbf840f0c) at kernel/qapplication.cpp:4458
#31 0x0596c103 in QApplication::notify (this=0xbf840f0c, receiver=0x8e65f28, e=0xbf840f0c) at kernel/qapplication.cpp:3886
#32 0x01016681 in KApplication::notify (this=0xbf841220, receiver=0x8e65f28, event=0xbf840f0c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x002b919e in QCoreApplication::notifyInternal (this=0xbf841220, receiver=0x8e65f28, event=0xbf840f0c) at kernel/qcoreapplication.cpp:787
#34 0x002e9c10 in sendEvent (event=0xbf840f0c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d16e74) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002e7122 in timerSourceDispatch (source=0x8d16e40) at kernel/qeventdispatcher_glib.cpp:184
#37 0x013e125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x013e1990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x013e1c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002e7ada in QEventDispatcherGlib::processEvents (this=0x8cf2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05a1ee3a in QGuiEventDispatcherGlib::processEvents (this=0x8cf2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002b81dd in QEventLoop::processEvents (this=0xbf841184, flags=...) at kernel/qeventloop.cpp:149
#43 0x002b8421 in QEventLoop::exec (this=0xbf841184, flags=...) at kernel/qeventloop.cpp:201
#44 0x002bd19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x059648f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291765, bug 291732, bug 291725, bug 291724, bug 291723.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 13:14:41 UTC

*** This bug has been marked as a duplicate of bug 291262 ***