Bug 291725 - Muon crashed at open
Summary: Muon crashed at open
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 01:30 UTC by Sebastian Ortega
Modified: 2012-01-25 18:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.98 KB, text/plain)
2012-01-25 18:35 UTC, Archaron
Details
New crash information added by DrKonqi (6.98 KB, text/plain)
2012-01-25 18:35 UTC, Archaron
Details
New crash information added by DrKonqi (6.98 KB, text/plain)
2012-01-25 18:35 UTC, Archaron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Ortega 2012-01-17 01:30:26 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I try to open Muon and suddenly the app crash, this happen before and after the first upgrade

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7895930 (LWP 2532))]

Thread 2 (Thread 0xb5a51b70 (LWP 2533)):
#0  0x0071fd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x005227d5 in do_gettime (frac=0xb5a51020, sec=0xb5a51018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x005f54b6 in QTimerInfoList::updateCurrentTime (this=0x8831e2c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x005f580a in QTimerInfoList::timerWait (this=0x8831e2c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x005f4053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5a5112c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005f40ed in timerSourcePrepare (source=0x8831df8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0137088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01371637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01371c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x005f4b37 in QEventDispatcherGlib::processEvents (this=0x86b19c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005c51dd in QEventLoop::processEvents (this=0xb5a512b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x005c5421 in QEventLoop::exec (this=0xb5a512b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x004c890b in QThread::exec (this=0x87b7e48) at thread/qthread.cpp:498
#14 0x005a5e2d in QInotifyFileSystemWatcherEngine::run (this=0x87b7e48) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004cb7b3 in QThreadPrivate::start (arg=0x87b7e48) at thread/qthread_unix.cpp:331
#16 0x00707d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x04d7f0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7895930 (LWP 2532)):
[KCrash Handler]
#7  0x0051fe11 in QtPrivate::QStringList_contains (that=0xbf82f224, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf82f224) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x87afd10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x87afd10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82f444) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005ccb7d in metacall (argv=0xbf82f444, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x87afd10) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x87afd10, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf82f444) at kernel/qmetaobject.cpp:232
#13 0x005dba6a in QMetaObject::activate (sender=0x8833ff8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8833ff8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8833ff8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82f588) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005ccb7d in metacall (argv=0xbf82f588, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8833ff8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8833ff8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf82f588) at kernel/qmetaobject.cpp:232
#18 0x005dba6a in QMetaObject::activate (sender=0x87afd10, m=0x80950c0, local_signal_index=0, argv=0xbf82f588) at kernel/qobject.cpp:3278
#19 0x003f87c5 in MuonMainWindow::backendReady (this=0x87afd10, _t1=0x87ad300) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003f8933 in MuonMainWindow::initObject (this=0x87afd10) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x87afd10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x87afd10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf82f6b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005ccb7d in metacall (argv=0xbf82f6b4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x87afd10) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x87afd10, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf82f6b4) at kernel/qmetaobject.cpp:232
#25 0x005dba6a in QMetaObject::activate (sender=0x880d5c8, m=0x6fc238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x005e3375 in QSingleShotTimer::timeout (this=0x880d5c8) at .moc/release-shared/qtimer.moc:82
#27 0x005e342c in QSingleShotTimer::timerEvent (this=0x880d5c8) at kernel/qtimer.cpp:308
#28 0x005de994 in QObject::event (this=0x880d5c8, e=0xbf82faac) at kernel/qobject.cpp:1181
#29 0x0272cd54 in notify_helper (e=0xbf82faac, receiver=0x880d5c8, this=0x86b7820) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x86b7820, receiver=0x880d5c8, e=0xbf82faac) at kernel/qapplication.cpp:4458
#31 0x02732103 in QApplication::notify (this=0xbf82faac, receiver=0x880d5c8, e=0xbf82faac) at kernel/qapplication.cpp:3886
#32 0x00d95681 in KApplication::notify (this=0xbf82fdc0, receiver=0x880d5c8, event=0xbf82faac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005c619e in QCoreApplication::notifyInternal (this=0xbf82fdc0, receiver=0x880d5c8, event=0xbf82faac) at kernel/qcoreapplication.cpp:787
#34 0x005f6c10 in sendEvent (event=0xbf82faac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x86bf434) at kernel/qeventdispatcher_unix.cpp:603
#36 0x005f4122 in timerSourceDispatch (source=0x86bf400) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0137125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01371990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01371c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x005f4ada in QEventDispatcherGlib::processEvents (this=0x869b238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x027e4e3a in QGuiEventDispatcherGlib::processEvents (this=0x869b238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005c51dd in QEventLoop::processEvents (this=0xbf82fd24, flags=...) at kernel/qeventloop.cpp:149
#43 0x005c5421 in QEventLoop::exec (this=0xbf82fd24, flags=...) at kernel/qeventloop.cpp:201
#44 0x005ca19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0272a8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291724.

Possible duplicates by query: bug 291724, bug 291723, bug 291699, bug 291692, bug 291684.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-17 02:40:17 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Archaron 2012-01-25 18:35:53 UTC
Created attachment 68166 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
I try to open Muon and suddenly the app crash, this happen before and after the first upgrade

- Custom settings of the application:

-- Backtrace (Reduced):
#6  0x00007ffc44b6fa5e in QtPrivate::QStringList_contains (that=0x7fff9105ad50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff9105ad50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1941a50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1941a50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b320) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19a8ca0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b480) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 3 Archaron 2012-01-25 18:35:54 UTC
Created attachment 68167 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
I try to open Muon and suddenly the app crash, this happen before and after the first upgrade

- Custom settings of the application:

-- Backtrace (Reduced):
#6  0x00007ffc44b6fa5e in QtPrivate::QStringList_contains (that=0x7fff9105ad50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff9105ad50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1941a50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1941a50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b320) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19a8ca0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b480) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 4 Archaron 2012-01-25 18:35:54 UTC
Created attachment 68168 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:
I try to open Muon and suddenly the app crash, this happen before and after the first upgrade

- Custom settings of the application:

-- Backtrace (Reduced):
#6  0x00007ffc44b6fa5e in QtPrivate::QStringList_contains (that=0x7fff9105ad50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff9105ad50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1941a50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1941a50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b320) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19a8ca0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9105b480) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109