Bug 291605 - MOUN Software Crashes
Summary: MOUN Software Crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 18:58 UTC by Iqbal Uddin Khan
Modified: 2012-01-15 19:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iqbal Uddin Khan 2012-01-15 18:58:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
when ever i opened it, i was surfing and using LIBRE Office at the time i see this crash

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8ebfc4b780 (LWP 2075))]

Thread 2 (Thread 0x7f8eab062700 (LWP 2076)):
#0  0x00007f8ebc828773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8eb909df68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8eb909e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8ebe9e5f3e in QEventDispatcherGlib::processEvents (this=0xe0eca0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f8ebe9b9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8ebe9b9ef7 in QEventLoop::exec (this=0x7f8eab061dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f8ebe8d127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f8ebe99ccbf in QInotifyFileSystemWatcherEngine::run (this=0xd92eb0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8ebe8d3d05 in QThreadPrivate::start (arg=0xd92eb0) at thread/qthread_unix.cpp:331
#9  0x00007f8eb9b7fefc in start_thread (arg=0x7f8eab062700) at pthread_create.c:304
#10 0x00007f8ebc83489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8ebfc4b780 (LWP 2075)):
[KCrash Handler]
#6  0x00007f8ebe921a5e in QtPrivate::QStringList_contains (that=0x7fff353f0970, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff353f0970) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xd8e310) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xd8e310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff353f0f40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f8ebe9cdeba in QMetaObject::activate (sender=0xe3ad10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xe3ad10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff353f10a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f8ebe9cdeba in QMetaObject::activate (sender=0xd8e310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff353f10a0) at kernel/qobject.cpp:3278
#13 0x00007f8ebf840e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xc9bb30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f8ebf840f8e in MuonMainWindow::initObject (this=0xd8e310) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xd8e310) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xd8e310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff353f1170) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f8ebe9cdeba in QMetaObject::activate (sender=0xe30290, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f8ebe9d5f7f in QSingleShotTimer::timerEvent (this=0xe30290) at kernel/qtimer.cpp:308
#19 0x00007f8ebe9d1789 in QObject::event (this=0xe30290, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f8ebcff5424 in notify_helper (e=0x7fff353f16e0, receiver=0xe30290, this=0xc23860) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xc23860, receiver=0xe30290, e=0x7fff353f16e0) at kernel/qapplication.cpp:4458
#22 0x00007f8ebcffa291 in QApplication::notify (this=0x7fff353f19e0, receiver=0xe30290, e=0x7fff353f16e0) at kernel/qapplication.cpp:4365
#23 0x00007f8ebe1d9126 in KApplication::notify (this=0x7fff353f19e0, receiver=0xe30290, event=0x7fff353f16e0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f8ebe9baafc in QCoreApplication::notifyInternal (this=0x7fff353f19e0, receiver=0xe30290, event=0x7fff353f16e0) at kernel/qcoreapplication.cpp:787
#25 0x00007f8ebe9e7d62 in sendEvent (event=0x7fff353f16e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xc27480) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f8ebe9e5514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f8eb909da5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f8eb909e258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f8eb909e429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f8ebe9e5ed6 in QEventDispatcherGlib::processEvents (this=0xbfb6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f8ebd09d07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f8ebe9b9cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f8ebe9b9ef7 in QEventLoop::exec (this=0x7fff353f1970, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f8ebe9be789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff353f1c58) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291602, bug 291599.

Possible duplicates by query: bug 291602, bug 291599, bug 291592, bug 291590, bug 291588.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 19:02:46 UTC

*** This bug has been marked as a duplicate of bug 291262 ***