Bug 291699 - Muon crashes after update
Summary: Muon crashes after update
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 20:59 UTC by Jurgen
Modified: 2012-01-16 21:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jurgen 2012-01-16 20:59:48 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I just installed the latest Kubuntu updates. After the installation I opened Muon Software Center and it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1c2a666780 (LWP 1868))]

Thread 2 (Thread 0x7f1c15da6700 (LWP 1869)):
#0  0x00007fff8c5ff92c in clock_gettime ()
#1  0x00007f1c23d6107b in __GI_clock_gettime (clock_id=1, tp=0x7f1c15da5b40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007f1c29332074 in do_gettime (frac=0x7f1c15da5b58, sec=0x7f1c15da5b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f1c293f46ed in QTimerInfoList::updateCurrentTime (this=0x25041c0) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007f1c293f4a33 in QTimerInfoList::timerWait (this=0x25041c0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007f1c293f344c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f1c15da5c3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f1c293f34f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f1c23aaaff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f1c23aabdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f1c23aac429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f1c293f3f3e in QEventDispatcherGlib::processEvents (this=0x24fff60, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007f1c293c7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f1c293c7ef7 in QEventLoop::exec (this=0x7f1c15da5dd0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007f1c292df27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007f1c293aacbf in QInotifyFileSystemWatcherEngine::run (this=0x24a4aa0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f1c292e1d05 in QThreadPrivate::start (arg=0x24a4aa0) at thread/qthread_unix.cpp:331
#17 0x00007f1c2458defc in start_thread (arg=0x7f1c15da6700) at pthread_create.c:304
#18 0x00007f1c2724289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1c2a666780 (LWP 1868)):
[KCrash Handler]
#6  0x00007f1c2932fa5e in QtPrivate::QStringList_contains (that=0x7fff8c4d54f0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8c4d54f0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x24887a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x24887a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8c4d5ac0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f1c293dbeba in QMetaObject::activate (sender=0x2567530, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2567530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8c4d5c20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f1c293dbeba in QMetaObject::activate (sender=0x24887a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8c4d5c20) at kernel/qobject.cpp:3278
#13 0x00007f1c2a24ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2498450) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f1c2a24ef8e in MuonMainWindow::initObject (this=0x24887a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x24887a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x24887a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8c4d5cf0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f1c293dbeba in QMetaObject::activate (sender=0x251fe20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f1c293e3f7f in QSingleShotTimer::timerEvent (this=0x251fe20) at kernel/qtimer.cpp:308
#19 0x00007f1c293df789 in QObject::event (this=0x251fe20, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f1c27a03424 in notify_helper (e=0x7fff8c4d6260, receiver=0x251fe20, this=0x23399e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x23399e0, receiver=0x251fe20, e=0x7fff8c4d6260) at kernel/qapplication.cpp:4458
#22 0x00007f1c27a08291 in QApplication::notify (this=0x7fff8c4d6560, receiver=0x251fe20, e=0x7fff8c4d6260) at kernel/qapplication.cpp:4365
#23 0x00007f1c28be7126 in KApplication::notify (this=0x7fff8c4d6560, receiver=0x251fe20, event=0x7fff8c4d6260) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f1c293c8afc in QCoreApplication::notifyInternal (this=0x7fff8c4d6560, receiver=0x251fe20, event=0x7fff8c4d6260) at kernel/qcoreapplication.cpp:787
#25 0x00007f1c293f5d62 in sendEvent (event=0x7fff8c4d6260, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2334d50) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f1c293f3514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f1c23aaba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f1c23aac258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f1c23aac429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f1c293f3ed6 in QEventDispatcherGlib::processEvents (this=0x230f6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f1c27aab07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f1c293c7cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f1c293c7ef7 in QEventLoop::exec (this=0x7fff8c4d64f0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f1c293cc789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff8c4d67d8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291692, bug 291684, bug 291681, bug 291626, bug 291605.

Reported using DrKonqi
Comment 1 Thijs 2012-01-16 21:10:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***