Bug 291724 - Muon crashed unexpectedly
Summary: Muon crashed unexpectedly
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 01:27 UTC by Utkarsh
Modified: 2012-01-17 02:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.64 KB, text/plain)
2012-01-17 01:31 UTC, Utkarsh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Utkarsh 2012-01-17 01:27:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I went BACK in start menu to click on muon s/w center. I was not doing anything substantial which could have caused it. Firefox was open. System settings was open

The crash does not seem to be reproducible.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4928930 (LWP 6406))]

Thread 2 (Thread 0xb255bb70 (LWP 6407)):
#0  0xb78b4424 in __kernel_vsyscall ()
#1  0xb5ee040e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb53cb34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb53bc896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb53bcc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb7422b37 in QEventDispatcherGlib::processEvents (this=0x8e8fd18, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb73f31dd in QEventLoop::processEvents (this=0xb255b2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb73f3421 in QEventLoop::exec (this=0xb255b2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb72f690b in QThread::exec (this=0x8e8b940) at thread/qthread.cpp:498
#9  0xb73d3e2d in QInotifyFileSystemWatcherEngine::run (this=0x8e8b940) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb72f97b3 in QThreadPrivate::start (arg=0x8e8b940) at thread/qthread_unix.cpp:331
#11 0xb54a2d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5eef0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4928930 (LWP 6406)):
[KCrash Handler]
#7  0xb734de11 in QtPrivate::QStringList_contains (that=0xbf9568d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9568d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8e289d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8e289d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf956af4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb73fab7d in metacall (argv=0xbf956af4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8e289d0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8e289d0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf956af4) at kernel/qmetaobject.cpp:232
#13 0xb7409a6a in QMetaObject::activate (sender=0x8ec2f30, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8ec2f30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8ec2f30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf956c38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb73fab7d in metacall (argv=0xbf956c38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8ec2f30) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8ec2f30, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf956c38) at kernel/qmetaobject.cpp:232
#18 0xb7409a6a in QMetaObject::activate (sender=0x8e289d0, m=0x80950c0, local_signal_index=0, argv=0xbf956c38) at kernel/qobject.cpp:3278
#19 0xb78687c5 in MuonMainWindow::backendReady (this=0x8e289d0, _t1=0x8e43a98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7868933 in MuonMainWindow::initObject (this=0x8e289d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8e289d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8e289d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf956d64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb73fab7d in metacall (argv=0xbf956d64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8e289d0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8e289d0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf956d64) at kernel/qmetaobject.cpp:232
#25 0xb7409a6a in QMetaObject::activate (sender=0x8ea43f8, m=0xb752a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7411375 in QSingleShotTimer::timeout (this=0x8ea43f8) at .moc/release-shared/qtimer.moc:82
#27 0xb741142c in QSingleShotTimer::timerEvent (this=0x8ea43f8) at kernel/qtimer.cpp:308
#28 0xb740c994 in QObject::event (this=0x8ea43f8, e=0xbf95715c) at kernel/qobject.cpp:1181
#29 0xb61dbd54 in notify_helper (e=0xbf95715c, receiver=0x8ea43f8, this=0x8d3fe98) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8d3fe98, receiver=0x8ea43f8, e=0xbf95715c) at kernel/qapplication.cpp:4458
#31 0xb61e1103 in QApplication::notify (this=0xbf95715c, receiver=0x8ea43f8, e=0xbf95715c) at kernel/qapplication.cpp:3886
#32 0xb6ffa681 in KApplication::notify (this=0xbf957470, receiver=0x8ea43f8, event=0xbf95715c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb73f419e in QCoreApplication::notifyInternal (this=0xbf957470, receiver=0x8ea43f8, event=0xbf95715c) at kernel/qcoreapplication.cpp:787
#34 0xb7424c10 in sendEvent (event=0xbf95715c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8d3ccbc) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7422122 in timerSourceDispatch (source=0x8d3cc88) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb53bc25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb53bc990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb53bcc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7422ada in QEventDispatcherGlib::processEvents (this=0x8d1e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb6293e3a in QGuiEventDispatcherGlib::processEvents (this=0x8d1e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb73f31dd in QEventLoop::processEvents (this=0xbf9573d4, flags=...) at kernel/qeventloop.cpp:149
#43 0xb73f3421 in QEventLoop::exec (this=0xbf9573d4, flags=...) at kernel/qeventloop.cpp:201
#44 0xb73f819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb61d98f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291699, bug 291692, bug 291684, bug 291681, bug 291626.

Reported using DrKonqi
Comment 1 Utkarsh 2012-01-17 01:31:24 UTC
Created attachment 67912 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

This happens all the time unlike "NEVER" as marked in the Parent Bug ID.

-- Backtrace (Reduced):
#7  0xb7209e11 in QtPrivate::QStringList_contains (that=0xbff1ff94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff1ff94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x88b99d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x88b99d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff201b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72b6b7d in metacall (argv=0xbff201b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x88b99d0) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-01-17 02:36:16 UTC

*** This bug has been marked as a duplicate of bug 291262 ***