Bug 291692 - muon crashed every time after a new install of kubuntu
Summary: muon crashed every time after a new install of kubuntu
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-16 20:07 UTC by jerome
Modified: 2012-01-16 21:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerome 2012-01-16 20:07:28 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed 
I'm sorry, my english is not very good.
it's a new install of kubuntu, on a blank hdd.
after the reboot, it's not possible to launch Muon .
when i boot ond the cd, without install it, Muon work.
i try many and many times, muon crashed already, also after install te new  package for update kubuntu. 
see you soon

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7790930 (LWP 1729))]

Thread 2 (Thread 0xb424eb70 (LWP 1739)):
#0  0x00846d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x005537d5 in do_gettime (frac=0xb424e020, sec=0xb424e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006264b6 in QTimerInfoList::updateCurrentTime (this=0x89785ec) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0062680a in QTimerInfoList::timerWait (this=0x89785ec, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00625053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb424e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006250ed in timerSourcePrepare (source=0x89785b8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x048f488c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x048f5637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x048f5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00625b37 in QEventDispatcherGlib::processEvents (this=0x88b60a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005f61dd in QEventLoop::processEvents (this=0xb424e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x005f6421 in QEventLoop::exec (this=0xb424e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x004f990b in QThread::exec (this=0x8861ad8) at thread/qthread.cpp:498
#14 0x005d6e2d in QInotifyFileSystemWatcherEngine::run (this=0x8861ad8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x004fc7b3 in QThreadPrivate::start (arg=0x8861ad8) at thread/qthread_unix.cpp:331
#16 0x00789d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00da60ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7790930 (LWP 1729)):
[KCrash Handler]
#7  0x00550e11 in QtPrivate::QStringList_contains (that=0xbfe0ded4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe0ded4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8825b18) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8825b18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0e0f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x005fdb7d in metacall (argv=0xbfe0e0f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8825b18) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8825b18, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe0e0f4) at kernel/qmetaobject.cpp:232
#13 0x0060ca6a in QMetaObject::activate (sender=0x88834d0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x88834d0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x88834d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0e238) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x005fdb7d in metacall (argv=0xbfe0e238, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x88834d0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x88834d0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe0e238) at kernel/qmetaobject.cpp:232
#18 0x0060ca6a in QMetaObject::activate (sender=0x8825b18, m=0x80950c0, local_signal_index=0, argv=0xbfe0e238) at kernel/qobject.cpp:3278
#19 0x0045d7c5 in MuonMainWindow::backendReady (this=0x8825b18, _t1=0x872cc00) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0045d933 in MuonMainWindow::initObject (this=0x8825b18) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8825b18) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8825b18, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe0e364) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x005fdb7d in metacall (argv=0xbfe0e364, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8825b18) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8825b18, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe0e364) at kernel/qmetaobject.cpp:232
#25 0x0060ca6a in QMetaObject::activate (sender=0x8873ac0, m=0x72d238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00614375 in QSingleShotTimer::timeout (this=0x8873ac0) at .moc/release-shared/qtimer.moc:82
#27 0x0061442c in QSingleShotTimer::timerEvent (this=0x8873ac0) at kernel/qtimer.cpp:308
#28 0x0060f994 in QObject::event (this=0x8873ac0, e=0xbfe0e75c) at kernel/qobject.cpp:1181
#29 0x06008d54 in notify_helper (e=0xbfe0e75c, receiver=0x8873ac0, this=0x8727060) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8727060, receiver=0x8873ac0, e=0xbfe0e75c) at kernel/qapplication.cpp:4458
#31 0x0600e103 in QApplication::notify (this=0xbfe0e75c, receiver=0x8873ac0, e=0xbfe0e75c) at kernel/qapplication.cpp:3886
#32 0x010b4681 in KApplication::notify (this=0xbfe0ea70, receiver=0x8873ac0, event=0xbfe0e75c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x005f719e in QCoreApplication::notifyInternal (this=0xbfe0ea70, receiver=0x8873ac0, event=0xbfe0e75c) at kernel/qcoreapplication.cpp:787
#34 0x00627c10 in sendEvent (event=0xbfe0e75c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x872a034) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00625122 in timerSourceDispatch (source=0x872a000) at kernel/qeventdispatcher_glib.cpp:184
#37 0x048f525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x048f5990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x048f5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00625ada in QEventDispatcherGlib::processEvents (this=0x8709238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x060c0e3a in QGuiEventDispatcherGlib::processEvents (this=0x8709238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005f61dd in QEventLoop::processEvents (this=0xbfe0e9d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x005f6421 in QEventLoop::exec (this=0xbfe0e9d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x005fb19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x060068f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291684, bug 291681, bug 291626, bug 291605, bug 291602.

Reported using DrKonqi
Comment 1 Thijs 2012-01-16 21:10:30 UTC

*** This bug has been marked as a duplicate of bug 291262 ***