Bug 291588 - Centro de software de muon dañado
Summary: Centro de software de muon dañado
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 15:35 UTC by Doyi
Modified: 2012-01-15 15:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doyi 2012-01-15 15:35:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
El centro de software de moun se daño haciendo imposible abrirlo

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb789f930 (LWP 2123))]

Thread 2 (Thread 0xb56f8b70 (LWP 2127)):
#0  0x007f1d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x001f17d5 in do_gettime (frac=0xb56f8020, sec=0xb56f8018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x002c44b6 in QTimerInfoList::updateCurrentTime (this=0x9c2a75c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x002c480a in QTimerInfoList::timerWait (this=0x9c2a75c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x002c3053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56f812c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x002c30ed in timerSourcePrepare (source=0x9c2a728, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06bbc88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06bbd637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06bbdc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x002c3b37 in QEventDispatcherGlib::processEvents (this=0x9c20bb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x002941dd in QEventLoop::processEvents (this=0xb56f82b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00294421 in QEventLoop::exec (this=0xb56f82b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0019790b in QThread::exec (this=0x9c29390) at thread/qthread.cpp:498
#14 0x00274e2d in QInotifyFileSystemWatcherEngine::run (this=0x9c29390) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0019a7b3 in QThreadPrivate::start (arg=0x9c29390) at thread/qthread_unix.cpp:331
#16 0x007d9d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x006fa0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb789f930 (LWP 2123)):
[KCrash Handler]
#7  0x001eee11 in QtPrivate::QStringList_contains (that=0xbfa45624, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa45624) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9adaf98) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9adaf98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa45844) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0029bb7d in metacall (argv=0xbfa45844, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9adaf98) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9adaf98, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa45844) at kernel/qmetaobject.cpp:232
#13 0x002aaa6a in QMetaObject::activate (sender=0x9b40308, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b40308) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b40308, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa45988) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0029bb7d in metacall (argv=0xbfa45988, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b40308) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b40308, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa45988) at kernel/qmetaobject.cpp:232
#18 0x002aaa6a in QMetaObject::activate (sender=0x9adaf98, m=0x80950c0, local_signal_index=0, argv=0xbfa45988) at kernel/qobject.cpp:3278
#19 0x0084c7c5 in MuonMainWindow::backendReady (this=0x9adaf98, _t1=0x9b14b30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0084c933 in MuonMainWindow::initObject (this=0x9adaf98) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9adaf98) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9adaf98, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa45ab4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0029bb7d in metacall (argv=0xbfa45ab4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9adaf98) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9adaf98, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa45ab4) at kernel/qmetaobject.cpp:232
#25 0x002aaa6a in QMetaObject::activate (sender=0x9b1d388, m=0x3cb238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x002b2375 in QSingleShotTimer::timeout (this=0x9b1d388) at .moc/release-shared/qtimer.moc:82
#27 0x002b242c in QSingleShotTimer::timerEvent (this=0x9b1d388) at kernel/qtimer.cpp:308
#28 0x002ad994 in QObject::event (this=0x9b1d388, e=0xbfa45eac) at kernel/qobject.cpp:1181
#29 0x020e3d54 in notify_helper (e=0xbfa45eac, receiver=0x9b1d388, this=0x99d5770) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x99d5770, receiver=0x9b1d388, e=0xbfa45eac) at kernel/qapplication.cpp:4458
#31 0x020e9103 in QApplication::notify (this=0xbfa45eac, receiver=0x9b1d388, e=0xbfa45eac) at kernel/qapplication.cpp:3886
#32 0x0111a681 in KApplication::notify (this=0xbfa461c0, receiver=0x9b1d388, event=0xbfa45eac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0029519e in QCoreApplication::notifyInternal (this=0xbfa461c0, receiver=0x9b1d388, event=0xbfa45eac) at kernel/qcoreapplication.cpp:787
#34 0x002c5c10 in sendEvent (event=0xbfa45eac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x99d1834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002c3122 in timerSourceDispatch (source=0x99d1800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06bbd25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06bbd990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06bbdc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002c3ada in QEventDispatcherGlib::processEvents (this=0x99b3238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0219be3a in QGuiEventDispatcherGlib::processEvents (this=0x99b3238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002941dd in QEventLoop::processEvents (this=0xbfa46124, flags=...) at kernel/qeventloop.cpp:149
#43 0x00294421 in QEventLoop::exec (this=0xbfa46124, flags=...) at kernel/qeventloop.cpp:201
#44 0x0029919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x020e18f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291581, bug 291580, bug 291572, bug 291571, bug 291559.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 15:42:39 UTC

*** This bug has been marked as a duplicate of bug 291262 ***