Bug 291571 - error when open application
Summary: error when open application
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 11:05 UTC by PaoloGTT
Modified: 2012-01-15 11:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PaoloGTT 2012-01-15 11:05:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: open application. uninstall application, reload application but receive the same error when open application after reload/reinstall the software

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7784930 (LWP 1783))]

Thread 2 (Thread 0xb56e6b70 (LWP 1787)):
#0  0x00454416 in __kernel_vsyscall ()
#1  0x0051840e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x011b734b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x011a8896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x011a8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00c1fb37 in QEventDispatcherGlib::processEvents (this=0x8caa538, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00bf01dd in QEventLoop::processEvents (this=0xb56e62b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00bf0421 in QEventLoop::exec (this=0xb56e62b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00af390b in QThread::exec (this=0x8d619d0) at thread/qthread.cpp:498
#9  0x00bd0e2d in QInotifyFileSystemWatcherEngine::run (this=0x8d619d0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00af67b3 in QThreadPrivate::start (arg=0x8d619d0) at thread/qthread_unix.cpp:331
#11 0x00421d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x005270ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7784930 (LWP 1783)):
[KCrash Handler]
#7  0x00b4ae11 in QtPrivate::QStringList_contains (that=0xbff1b174, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff1b174) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8c03d30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8c03d30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff1b394) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00bf7b7d in metacall (argv=0xbff1b394, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8c03d30) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8c03d30, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff1b394) at kernel/qmetaobject.cpp:232
#13 0x00c06a6a in QMetaObject::activate (sender=0x8c63178, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c63178) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c63178, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff1b4d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00bf7b7d in metacall (argv=0xbff1b4d8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c63178) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c63178, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff1b4d8) at kernel/qmetaobject.cpp:232
#18 0x00c06a6a in QMetaObject::activate (sender=0x8c03d30, m=0x80950c0, local_signal_index=0, argv=0xbff1b4d8) at kernel/qobject.cpp:3278
#19 0x003ae7c5 in MuonMainWindow::backendReady (this=0x8c03d30, _t1=0x8c6b960) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x003ae933 in MuonMainWindow::initObject (this=0x8c03d30) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8c03d30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8c03d30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff1b604) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00bf7b7d in metacall (argv=0xbff1b604, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8c03d30) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8c03d30, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff1b604) at kernel/qmetaobject.cpp:232
#25 0x00c06a6a in QMetaObject::activate (sender=0x8c75768, m=0xd27238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00c0e375 in QSingleShotTimer::timeout (this=0x8c75768) at .moc/release-shared/qtimer.moc:82
#27 0x00c0e42c in QSingleShotTimer::timerEvent (this=0x8c75768) at kernel/qtimer.cpp:308
#28 0x00c09994 in QObject::event (this=0x8c75768, e=0xbff1b9fc) at kernel/qobject.cpp:1181
#29 0x01d24d54 in notify_helper (e=0xbff1b9fc, receiver=0x8c75768, this=0x8b016e8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8b016e8, receiver=0x8c75768, e=0xbff1b9fc) at kernel/qapplication.cpp:4458
#31 0x01d2a103 in QApplication::notify (this=0xbff1b9fc, receiver=0x8c75768, e=0xbff1b9fc) at kernel/qapplication.cpp:3886
#32 0x00f13681 in KApplication::notify (this=0xbff1bd10, receiver=0x8c75768, event=0xbff1b9fc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00bf119e in QCoreApplication::notifyInternal (this=0xbff1bd10, receiver=0x8c75768, event=0xbff1b9fc) at kernel/qcoreapplication.cpp:787
#34 0x00c21c10 in sendEvent (event=0xbff1b9fc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8b03b44) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00c1f155 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x8b03cc0) at kernel/qeventdispatcher_glib.cpp:231
#38 0x011a825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x011a8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x011a8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x00c1fada in QEventDispatcherGlib::processEvents (this=0x8ae3238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x01ddce3a in QGuiEventDispatcherGlib::processEvents (this=0x8ae3238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00bf01dd in QEventLoop::processEvents (this=0xbff1bc74, flags=...) at kernel/qeventloop.cpp:149
#44 0x00bf0421 in QEventLoop::exec (this=0xbff1bc74, flags=...) at kernel/qeventloop.cpp:201
#45 0x00bf519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#46 0x01d228f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#47 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291559, bug 291558, bug 291556, bug 291553, bug 291552.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 11:06:27 UTC

*** This bug has been marked as a duplicate of bug 291262 ***