Bug 291580 - Muon Software Center Crash
Summary: Muon Software Center Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 13:34 UTC by P1310
Modified: 2012-01-15 13:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description P1310 2012-01-15 13:34:16 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Had reloaded  MSC, hoping for a recent fix.
Kubuntu installation: completely updated prior to this crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc759af6780 (LWP 9481))]

Thread 2 (Thread 0x7fc744e5f700 (LWP 9485)):
#0  0x00007fc752f4a06b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fc752f4adfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc752f4b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc758892f3e in QEventDispatcherGlib::processEvents (this=0x1a2b670, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc758866cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc758866ef7 in QEventLoop::exec (this=0x7fc744e5edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc75877e27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc758849cbf in QInotifyFileSystemWatcherEngine::run (this=0x1a2df50) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc758780d05 in QThreadPrivate::start (arg=0x1a2df50) at thread/qthread_unix.cpp:331
#9  0x00007fc753a2cefc in start_thread (arg=0x7fc744e5f700) at pthread_create.c:304
#10 0x00007fc7566e189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc759af6780 (LWP 9481)):
[KCrash Handler]
#6  0x00007fc7587cea5e in QtPrivate::QStringList_contains (that=0x7fffdf7f3780, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffdf7f3780) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19d6740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19d6740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf7f3d50) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fc75887aeba in QMetaObject::activate (sender=0x1992820, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1992820, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf7f3eb0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fc75887aeba in QMetaObject::activate (sender=0x19d6740, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdf7f3eb0) at kernel/qobject.cpp:3278
#13 0x00007fc7596ede7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1a1a280) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fc7596edf8e in MuonMainWindow::initObject (this=0x19d6740) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19d6740) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19d6740, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdf7f3f80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fc75887aeba in QMetaObject::activate (sender=0x1a6df60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fc758882f7f in QSingleShotTimer::timerEvent (this=0x1a6df60) at kernel/qtimer.cpp:308
#19 0x00007fc75887e789 in QObject::event (this=0x1a6df60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fc756ea2424 in notify_helper (e=0x7fffdf7f44f0, receiver=0x1a6df60, this=0x1810700) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1810700, receiver=0x1a6df60, e=0x7fffdf7f44f0) at kernel/qapplication.cpp:4458
#22 0x00007fc756ea7291 in QApplication::notify (this=0x7fffdf7f47f0, receiver=0x1a6df60, e=0x7fffdf7f44f0) at kernel/qapplication.cpp:4365
#23 0x00007fc758086126 in KApplication::notify (this=0x7fffdf7f47f0, receiver=0x1a6df60, event=0x7fffdf7f44f0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fc758867afc in QCoreApplication::notifyInternal (this=0x7fffdf7f47f0, receiver=0x1a6df60, event=0x7fffdf7f44f0) at kernel/qcoreapplication.cpp:787
#25 0x00007fc758894d62 in sendEvent (event=0x7fffdf7f44f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1816c80) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fc758892514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fc752f4aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fc752f4b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fc752f4b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fc758892ed6 in QEventDispatcherGlib::processEvents (this=0x17eb6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fc756f4a07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fc758866cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fc758866ef7 in QEventLoop::exec (this=0x7fffdf7f4780, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fc75886b789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffdf7f4a68) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291572, bug 291571, bug 291559, bug 291558, bug 291556.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 13:38:32 UTC

*** This bug has been marked as a duplicate of bug 291262 ***