Bug 291572 - Muon-crash after update AntiVirus paket
Summary: Muon-crash after update AntiVirus paket
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 11:15 UTC by icey
Modified: 2012-01-15 11:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description icey 2012-01-15 11:15:17 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- Unusual behavior I noticed:

Anti Virus Paket download than no Starting again

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5100afc780 (LWP 3012))]

Thread 2 (Thread 0x7f50ebe2b700 (LWP 3016)):
#0  0x00007f50fd6cb773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f50f9f40f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f50f9f41429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f50ff888f3e in QEventDispatcherGlib::processEvents (this=0x2893b00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f50ff85ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f50ff85cef7 in QEventLoop::exec (this=0x7f50ebe2add0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f50ff77427f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f50ff83fcbf in QInotifyFileSystemWatcherEngine::run (this=0x270e680) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f50ff776d05 in QThreadPrivate::start (arg=0x270e680) at thread/qthread_unix.cpp:331
#9  0x00007f50faa22efc in start_thread (arg=0x7f50ebe2b700) at pthread_create.c:304
#10 0x00007f50fd6d789d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5100afc780 (LWP 3012)):
[KCrash Handler]
#6  0x00007f50ff7c4a5e in QtPrivate::QStringList_contains (that=0x7fff3522ed40, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff3522ed40) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x26b6f30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x26b6f30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3522f310) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f50ff870eba in QMetaObject::activate (sender=0x2525a00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2525a00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3522f470) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f50ff870eba in QMetaObject::activate (sender=0x26b6f30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3522f470) at kernel/qobject.cpp:3278
#13 0x00007f51006e3e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x26d5f70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f51006e3f8e in MuonMainWindow::initObject (this=0x26b6f30) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x26b6f30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x26b6f30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3522f540) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f50ff870eba in QMetaObject::activate (sender=0x274f270, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f50ff878f7f in QSingleShotTimer::timerEvent (this=0x274f270) at kernel/qtimer.cpp:308
#19 0x00007f50ff874789 in QObject::event (this=0x274f270, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f50fde98424 in notify_helper (e=0x7fff3522fab0, receiver=0x274f270, this=0x253c1c0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x253c1c0, receiver=0x274f270, e=0x7fff3522fab0) at kernel/qapplication.cpp:4458
#22 0x00007f50fde9d291 in QApplication::notify (this=0x7fff3522fdb0, receiver=0x274f270, e=0x7fff3522fab0) at kernel/qapplication.cpp:4365
#23 0x00007f50ff07c126 in KApplication::notify (this=0x7fff3522fdb0, receiver=0x274f270, event=0x7fff3522fab0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f50ff85dafc in QCoreApplication::notifyInternal (this=0x7fff3522fdb0, receiver=0x274f270, event=0x7fff3522fab0) at kernel/qcoreapplication.cpp:787
#25 0x00007f50ff88ad62 in sendEvent (event=0x7fff3522fab0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x25358f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f50ff888514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f50f9f40a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f50f9f41258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f50f9f41429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f50ff888ed6 in QEventDispatcherGlib::processEvents (this=0x250f6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f50fdf4007e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f50ff85ccf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f50ff85cef7 in QEventLoop::exec (this=0x7fff3522fd40, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f50ff861789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff35230028) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291571, bug 291559, bug 291558, bug 291556, bug 291553.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 11:33:23 UTC

*** This bug has been marked as a duplicate of bug 291262 ***