Bug 291559 - Muon sfotware center crashed on start
Summary: Muon sfotware center crashed on start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-15 00:11 UTC by rfranr
Modified: 2012-01-15 02:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rfranr 2012-01-15 00:11:25 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I open Muon Software Center, shows the application window and crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc29b390780 (LWP 1898))]

Thread 2 (Thread 0x7fc286ae1700 (LWP 1899)):
#0  0x00007fc297f5f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc2947d4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc2947d5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc29a11cf3e in QEventDispatcherGlib::processEvents (this=0x1dcbed0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc29a0f0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc29a0f0ef7 in QEventLoop::exec (this=0x7fc286ae0dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc29a00827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc29a0d3cbf in QInotifyFileSystemWatcherEngine::run (this=0x1e7b600) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc29a00ad05 in QThreadPrivate::start (arg=0x1e7b600) at thread/qthread_unix.cpp:331
#9  0x00007fc2952b6efc in start_thread (arg=0x7fc286ae1700) at pthread_create.c:304
#10 0x00007fc297f6b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc29b390780 (LWP 1898)):
[KCrash Handler]
#6  0x00007fc29a058a5e in QtPrivate::QStringList_contains (that=0x7fffdb145b00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffdb145b00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1e75d10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1e75d10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdb1460d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fc29a104eba in QMetaObject::activate (sender=0x1f3ec80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1f3ec80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdb146230) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fc29a104eba in QMetaObject::activate (sender=0x1e75d10, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffdb146230) at kernel/qobject.cpp:3278
#13 0x00007fc29af77e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1ed2310) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fc29af77f8e in MuonMainWindow::initObject (this=0x1e75d10) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1e75d10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1e75d10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffdb146300) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fc29a104eba in QMetaObject::activate (sender=0x1f005b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fc29a10cf7f in QSingleShotTimer::timerEvent (this=0x1f005b0) at kernel/qtimer.cpp:308
#19 0x00007fc29a108789 in QObject::event (this=0x1f005b0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fc29872c424 in notify_helper (e=0x7fffdb146870, receiver=0x1f005b0, this=0x1d25910) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1d25910, receiver=0x1f005b0, e=0x7fffdb146870) at kernel/qapplication.cpp:4458
#22 0x00007fc298731291 in QApplication::notify (this=0x7fffdb146b70, receiver=0x1f005b0, e=0x7fffdb146870) at kernel/qapplication.cpp:4365
#23 0x00007fc299910126 in KApplication::notify (this=0x7fffdb146b70, receiver=0x1f005b0, event=0x7fffdb146870) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fc29a0f1afc in QCoreApplication::notifyInternal (this=0x7fffdb146b70, receiver=0x1f005b0, event=0x7fffdb146870) at kernel/qcoreapplication.cpp:787
#25 0x00007fc29a11ed62 in sendEvent (event=0x7fffdb146870, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1d216d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fc29a11c514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fc2947d4a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fc2947d5258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fc2947d5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fc29a11ced6 in QEventDispatcherGlib::processEvents (this=0x1cfd6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fc2987d407e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fc29a0f0cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fc29a0f0ef7 in QEventLoop::exec (this=0x7fffdb146b00, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fc29a0f5789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffdb146de8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291552.

Possible duplicates by query: bug 291556, bug 291554, bug 291553, bug 291552, bug 291551.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:01:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***