Bug 291556 - Muan crashed when first started
Summary: Muan crashed when first started
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 23:52 UTC by Iain
Modified: 2012-01-15 02:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Iain 2012-01-14 23:52:34 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

First attempt to run after a fresh install of 11.10
The system was undergoing it's first SW update
Still does not start after several reboots.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7880930 (LWP 2025))]

Thread 2 (Thread 0xb5be7b70 (LWP 2029)):
#0  0x009d3d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00d787d5 in do_gettime (frac=0xb5be7020, sec=0xb5be7018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00e4b4b6 in QTimerInfoList::updateCurrentTime (this=0x8aa7784) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00e4b80a in QTimerInfoList::timerWait (this=0x8aa7784, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00e4a053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb5be712c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00e4a0ed in timerSourcePrepare (source=0x8aa7750, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x02e8088c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02e81637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x02e81c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00e4ab37 in QEventDispatcherGlib::processEvents (this=0x89b7508, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00e1b1dd in QEventLoop::processEvents (this=0xb5be72b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00e1b421 in QEventLoop::exec (this=0xb5be72b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00d1e90b in QThread::exec (this=0x899a6e0) at thread/qthread.cpp:498
#14 0x00dfbe2d in QInotifyFileSystemWatcherEngine::run (this=0x899a6e0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00d217b3 in QThreadPrivate::start (arg=0x899a6e0) at thread/qthread_unix.cpp:331
#16 0x00c62d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x053540ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7880930 (LWP 2025)):
[KCrash Handler]
#7  0x00d75e11 in QtPrivate::QStringList_contains (that=0xbfa58354, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa58354) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x894b8a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x894b8a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa58574) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e22b7d in metacall (argv=0xbfa58574, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x894b8a0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x894b8a0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa58574) at kernel/qmetaobject.cpp:232
#13 0x00e31a6a in QMetaObject::activate (sender=0x89bde28, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x89bde28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x89bde28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa586b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00e22b7d in metacall (argv=0xbfa586b8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x89bde28) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x89bde28, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa586b8) at kernel/qmetaobject.cpp:232
#18 0x00e31a6a in QMetaObject::activate (sender=0x894b8a0, m=0x80950c0, local_signal_index=0, argv=0xbfa586b8) at kernel/qobject.cpp:3278
#19 0x00bae7c5 in MuonMainWindow::backendReady (this=0x894b8a0, _t1=0x89ade18) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00bae933 in MuonMainWindow::initObject (this=0x894b8a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x894b8a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x894b8a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa587e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00e22b7d in metacall (argv=0xbfa587e4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x894b8a0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x894b8a0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa587e4) at kernel/qmetaobject.cpp:232
#25 0x00e31a6a in QMetaObject::activate (sender=0x89c75e0, m=0xf52238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00e39375 in QSingleShotTimer::timeout (this=0x89c75e0) at .moc/release-shared/qtimer.moc:82
#27 0x00e3942c in QSingleShotTimer::timerEvent (this=0x89c75e0) at kernel/qtimer.cpp:308
#28 0x00e34994 in QObject::event (this=0x89c75e0, e=0xbfa58bdc) at kernel/qobject.cpp:1181
#29 0x03e88d54 in notify_helper (e=0xbfa58bdc, receiver=0x89c75e0, this=0x8865d90) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8865d90, receiver=0x89c75e0, e=0xbfa58bdc) at kernel/qapplication.cpp:4458
#31 0x03e8e103 in QApplication::notify (this=0xbfa58bdc, receiver=0x89c75e0, e=0xbfa58bdc) at kernel/qapplication.cpp:3886
#32 0x00601681 in KApplication::notify (this=0xbfa58ef0, receiver=0x89c75e0, event=0xbfa58bdc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00e1c19e in QCoreApplication::notifyInternal (this=0xbfa58ef0, receiver=0x89c75e0, event=0xbfa58bdc) at kernel/qcoreapplication.cpp:787
#34 0x00e4cc10 in sendEvent (event=0xbfa58bdc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8868f04) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00e4a122 in timerSourceDispatch (source=0x8868ed0) at kernel/qeventdispatcher_glib.cpp:184
#37 0x02e8125f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02e81990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02e81c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00e4aada in QEventDispatcherGlib::processEvents (this=0x8844220, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x03f40e3a in QGuiEventDispatcherGlib::processEvents (this=0x8844220, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00e1b1dd in QEventLoop::processEvents (this=0xbfa58e54, flags=...) at kernel/qeventloop.cpp:149
#43 0x00e1b421 in QEventLoop::exec (this=0xbfa58e54, flags=...) at kernel/qeventloop.cpp:201
#44 0x00e2019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x03e868f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291551.

Possible duplicates by query: bug 291554, bug 291553, bug 291552, bug 291551, bug 291543.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:00:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***