Bug 291551 - muon crashes on start
Summary: muon crashes on start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 22:52 UTC by other.inbox
Modified: 2012-01-15 02:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description other.inbox 2012-01-14 22:52:37 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
muon will not start.   I wasn't haven't any problems and may have gone through a scheduled update.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7881930 (LWP 11198))]

Thread 2 (Thread 0xb58b3b70 (LWP 11202)):
#0  0x007cad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00a127d5 in do_gettime (frac=0xb58b3020, sec=0xb58b3018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00ae54b6 in QTimerInfoList::updateCurrentTime (this=0x9581e34) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00ae580a in QTimerInfoList::timerWait (this=0x9581e34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00ae4053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb58b312c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00ae40ed in timerSourcePrepare (source=0x9581e00, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x053c888c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x053c9637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x053c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00ae4b37 in QEventDispatcherGlib::processEvents (this=0x9583220, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00ab51dd in QEventLoop::processEvents (this=0xb58b32b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00ab5421 in QEventLoop::exec (this=0xb58b32b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x009b890b in QThread::exec (this=0x946bb28) at thread/qthread.cpp:498
#14 0x00a95e2d in QInotifyFileSystemWatcherEngine::run (this=0x946bb28) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x009bb7b3 in QThreadPrivate::start (arg=0x946bb28) at thread/qthread_unix.cpp:331
#16 0x00790d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00cc30ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7881930 (LWP 11198)):
[KCrash Handler]
#7  0x00a0fe11 in QtPrivate::QStringList_contains (that=0xbfe56e94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe56e94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x94211c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x94211c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe570b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00abcb7d in metacall (argv=0xbfe570b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x94211c8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x94211c8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe570b4) at kernel/qmetaobject.cpp:232
#13 0x00acba6a in QMetaObject::activate (sender=0x9472988, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9472988) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9472988, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe571f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00abcb7d in metacall (argv=0xbfe571f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9472988) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9472988, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe571f8) at kernel/qmetaobject.cpp:232
#18 0x00acba6a in QMetaObject::activate (sender=0x94211c8, m=0x80950c0, local_signal_index=0, argv=0xbfe571f8) at kernel/qobject.cpp:3278
#19 0x0067b7c5 in MuonMainWindow::backendReady (this=0x94211c8, _t1=0x9492388) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0067b933 in MuonMainWindow::initObject (this=0x94211c8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x94211c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x94211c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe57324) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00abcb7d in metacall (argv=0xbfe57324, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x94211c8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x94211c8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe57324) at kernel/qmetaobject.cpp:232
#25 0x00acba6a in QMetaObject::activate (sender=0x9491998, m=0xbec238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00ad3375 in QSingleShotTimer::timeout (this=0x9491998) at .moc/release-shared/qtimer.moc:82
#27 0x00ad342c in QSingleShotTimer::timerEvent (this=0x9491998) at kernel/qtimer.cpp:308
#28 0x00ace994 in QObject::event (this=0x9491998, e=0xbfe5771c) at kernel/qobject.cpp:1181
#29 0x0660ed54 in notify_helper (e=0xbfe5771c, receiver=0x9491998, this=0x93208d8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x93208d8, receiver=0x9491998, e=0xbfe5771c) at kernel/qapplication.cpp:4458
#31 0x06614103 in QApplication::notify (this=0xbfe5771c, receiver=0x9491998, e=0xbfe5771c) at kernel/qapplication.cpp:3886
#32 0x010d9681 in KApplication::notify (this=0xbfe57a30, receiver=0x9491998, event=0xbfe5771c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00ab619e in QCoreApplication::notifyInternal (this=0xbfe57a30, receiver=0x9491998, event=0xbfe5771c) at kernel/qcoreapplication.cpp:787
#34 0x00ae6c10 in sendEvent (event=0xbfe5771c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x931d234) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ae4122 in timerSourceDispatch (source=0x931d200) at kernel/qeventdispatcher_glib.cpp:184
#37 0x053c925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x053c9990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x053c9c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ae4ada in QEventDispatcherGlib::processEvents (this=0x92fe238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x066c6e3a in QGuiEventDispatcherGlib::processEvents (this=0x92fe238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00ab51dd in QEventLoop::processEvents (this=0xbfe57994, flags=...) at kernel/qeventloop.cpp:149
#43 0x00ab5421 in QEventLoop::exec (this=0xbfe57994, flags=...) at kernel/qeventloop.cpp:201
#44 0x00aba19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0660c8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 291543, bug 291525, bug 291522, bug 291520, bug 291513.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:00:06 UTC

*** This bug has been marked as a duplicate of bug 291262 ***