Bug 291552 - Muon Crash on Start
Summary: Muon Crash on Start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 23:06 UTC by starzilles
Modified: 2012-01-15 02:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description starzilles 2012-01-14 23:06:40 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Various, including nothing.
Just performed software update, 1/14/2012, 3pm PST.  No change.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff5ffda8780 (LWP 4932))]

Thread 2 (Thread 0x7ff5eb0c3700 (LWP 4936)):
#0  0x00007fff75fff92c in clock_gettime ()
#1  0x00007ff5f94a107b in __GI_clock_gettime (clock_id=1, tp=0x7ff5eb0c2b40) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00007ff5fea72074 in do_gettime (frac=0x7ff5eb0c2b58, sec=0x7ff5eb0c2b50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007ff5feb346ed in QTimerInfoList::updateCurrentTime (this=0x2806950) at kernel/qeventdispatcher_unix.cpp:339
#5  0x00007ff5feb34a33 in QTimerInfoList::timerWait (this=0x2806950, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#6  0x00007ff5feb3344c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7ff5eb0c2c3c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007ff5feb334f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007ff5f91eaff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007ff5f91ebdfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007ff5f91ec429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007ff5feb33f3e in QEventDispatcherGlib::processEvents (this=0x2806e20, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#12 0x00007ff5feb07cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007ff5feb07ef7 in QEventLoop::exec (this=0x7ff5eb0c2dd0, flags=...) at kernel/qeventloop.cpp:201
#14 0x00007ff5fea1f27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#15 0x00007ff5feaeacbf in QInotifyFileSystemWatcherEngine::run (this=0x26819e0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007ff5fea21d05 in QThreadPrivate::start (arg=0x26819e0) at thread/qthread_unix.cpp:331
#17 0x00007ff5f9ccdefc in start_thread (arg=0x7ff5eb0c3700) at pthread_create.c:304
#18 0x00007ff5fc98289d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff5ffda8780 (LWP 4932)):
[KCrash Handler]
#6  0x00007ff5fea6fa5e in QtPrivate::QStringList_contains (that=0x7fff75f42af0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff75f42af0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x2620a60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x2620a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff75f430c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ff5feb1beba in QMetaObject::activate (sender=0x26c1820, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x26c1820, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff75f43220) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ff5feb1beba in QMetaObject::activate (sender=0x2620a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff75f43220) at kernel/qobject.cpp:3278
#13 0x00007ff5ff98ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x2611200) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ff5ff98ef8e in MuonMainWindow::initObject (this=0x2620a60) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x2620a60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x2620a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff75f432f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ff5feb1beba in QMetaObject::activate (sender=0x26d5840, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ff5feb23f7f in QSingleShotTimer::timerEvent (this=0x26d5840) at kernel/qtimer.cpp:308
#19 0x00007ff5feb1f789 in QObject::event (this=0x26d5840, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ff5fd143424 in notify_helper (e=0x7fff75f43860, receiver=0x26d5840, this=0x2504ab0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2504ab0, receiver=0x26d5840, e=0x7fff75f43860) at kernel/qapplication.cpp:4458
#22 0x00007ff5fd148291 in QApplication::notify (this=0x7fff75f43b60, receiver=0x26d5840, e=0x7fff75f43860) at kernel/qapplication.cpp:4365
#23 0x00007ff5fe327126 in KApplication::notify (this=0x7fff75f43b60, receiver=0x26d5840, event=0x7fff75f43860) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ff5feb08afc in QCoreApplication::notifyInternal (this=0x7fff75f43b60, receiver=0x26d5840, event=0x7fff75f43860) at kernel/qcoreapplication.cpp:787
#25 0x00007ff5feb35d62 in sendEvent (event=0x7fff75f43860, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2501640) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ff5feb33514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007ff5f91eba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ff5f91ec258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ff5f91ec429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ff5feb33ed6 in QEventDispatcherGlib::processEvents (this=0x24dc6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ff5fd1eb07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ff5feb07cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ff5feb07ef7 in QEventLoop::exec (this=0x7fff75f43af0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ff5feb0c789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff75f43dd8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291551.

Possible duplicates by query: bug 291551, bug 291543, bug 291525, bug 291522, bug 291520.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:02:57 UTC

*** This bug has been marked as a duplicate of bug 291262 ***