Bug 291554 - Muon Software Center - failure to run
Summary: Muon Software Center - failure to run
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 23:29 UTC by bjeffries79
Modified: 2012-01-15 02:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bjeffries79 2012-01-14 23:29:03 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Fresh install of Kubuntu 11.10, hardware all validated on other distirbutions. Launched Muon to update system after initial install, app crashed and continues to do so; even after removal and reinstallation.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5116630780 (LWP 2592))]

Thread 2 (Thread 0x7f5101d7b700 (LWP 2593)):
#0  0x00007f51131f9773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f510fa6ef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f510fa6f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f51153b6f3e in QEventDispatcherGlib::processEvents (this=0x23e4ea0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f511538acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f511538aef7 in QEventLoop::exec (this=0x7f5101d7add0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f51152a227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f511536dcbf in QInotifyFileSystemWatcherEngine::run (this=0x2465420) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f51152a4d05 in QThreadPrivate::start (arg=0x2465420) at thread/qthread_unix.cpp:331
#9  0x00007f5110550efc in start_thread (arg=0x7f5101d7b700) at pthread_create.c:304
#10 0x00007f511320589d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5116630780 (LWP 2592)):
[KCrash Handler]
#6  0x00007f51152f2a5e in QtPrivate::QStringList_contains (that=0x7fff2eb09280, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff2eb09280) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x243a650) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x243a650, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2eb09850) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f511539eeba in QMetaObject::activate (sender=0x2617150, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2617150, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2eb099b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f511539eeba in QMetaObject::activate (sender=0x243a650, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2eb099b0) at kernel/qobject.cpp:3278
#13 0x00007f5116211e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x243ad30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f5116211f8e in MuonMainWindow::initObject (this=0x243a650) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x243a650) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x243a650, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff2eb09a80) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f511539eeba in QMetaObject::activate (sender=0x24df890, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f51153a6f7f in QSingleShotTimer::timerEvent (this=0x24df890) at kernel/qtimer.cpp:308
#19 0x00007f51153a2789 in QObject::event (this=0x24df890, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f51139c6424 in notify_helper (e=0x7fff2eb09ff0, receiver=0x24df890, this=0x2303c00) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2303c00, receiver=0x24df890, e=0x7fff2eb09ff0) at kernel/qapplication.cpp:4458
#22 0x00007f51139cb291 in QApplication::notify (this=0x7fff2eb0a2f0, receiver=0x24df890, e=0x7fff2eb09ff0) at kernel/qapplication.cpp:4365
#23 0x00007f5114baa126 in KApplication::notify (this=0x7fff2eb0a2f0, receiver=0x24df890, event=0x7fff2eb09ff0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f511538bafc in QCoreApplication::notifyInternal (this=0x7fff2eb0a2f0, receiver=0x24df890, event=0x7fff2eb09ff0) at kernel/qcoreapplication.cpp:787
#25 0x00007f51153b8d62 in sendEvent (event=0x7fff2eb09ff0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x2300a90) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f51153b6514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f510fa6ea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f510fa6f258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f510fa6f429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f51153b6ed6 in QEventDispatcherGlib::processEvents (this=0x22db6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f5113a6e07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f511538acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f511538aef7 in QEventLoop::exec (this=0x7fff2eb0a280, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f511538f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff2eb0a568) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291553, bug 291552, bug 291551, bug 291543, bug 291525.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:04:02 UTC

*** This bug has been marked as a duplicate of bug 291262 ***