Bug 291543 - Процесс: muon-installer PID: 1987 Сигнал завершения: Segmentation fault (11)
Summary: Процесс: muon-installer PID: 1987 Сигнал завершения: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 20:32 UTC by sasha
Modified: 2012-01-15 02:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha 2012-01-14 20:32:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Процесс: muon-installer PID: 1987 Сигнал завершения: Segmentation fault (11)

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f92359bc780 (LWP 1987))]

Thread 2 (Thread 0x7f9220b57700 (LWP 1990)):
#0  0x00007f9232588773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f922edfdf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f922edfe429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9234745f3e in QEventDispatcherGlib::processEvents (this=0x1a65ad0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9234719cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9234719ef7 in QEventLoop::exec (this=0x7f9220b56dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f923463127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f92346fccbf in QInotifyFileSystemWatcherEngine::run (this=0x1a61de0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9234633d05 in QThreadPrivate::start (arg=0x1a61de0) at thread/qthread_unix.cpp:331
#9  0x00007f922f8dfefc in start_thread (arg=0x7f9220b57700) at pthread_create.c:304
#10 0x00007f923259489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f92359bc780 (LWP 1987)):
[KCrash Handler]
#6  0x00007f9234681a5e in QtPrivate::QStringList_contains (that=0x7fff3c311800, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff3c311800) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19bec80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19bec80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c311dd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f923472deba in QMetaObject::activate (sender=0x1a1d5a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1a1d5a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c311f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f923472deba in QMetaObject::activate (sender=0x19bec80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3c311f30) at kernel/qobject.cpp:3278
#13 0x00007f92355a0e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x19c5f30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f92355a0f8e in MuonMainWindow::initObject (this=0x19bec80) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19bec80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19bec80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c312000) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f923472deba in QMetaObject::activate (sender=0x1a74730, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f9234735f7f in QSingleShotTimer::timerEvent (this=0x1a74730) at kernel/qtimer.cpp:308
#19 0x00007f9234731789 in QObject::event (this=0x1a74730, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f9232d55424 in notify_helper (e=0x7fff3c312570, receiver=0x1a74730, this=0x1864200) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1864200, receiver=0x1a74730, e=0x7fff3c312570) at kernel/qapplication.cpp:4458
#22 0x00007f9232d5a291 in QApplication::notify (this=0x7fff3c312870, receiver=0x1a74730, e=0x7fff3c312570) at kernel/qapplication.cpp:4365
#23 0x00007f9233f39126 in KApplication::notify (this=0x7fff3c312870, receiver=0x1a74730, event=0x7fff3c312570) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f923471aafc in QCoreApplication::notifyInternal (this=0x7fff3c312870, receiver=0x1a74730, event=0x7fff3c312570) at kernel/qcoreapplication.cpp:787
#25 0x00007f9234747d62 in sendEvent (event=0x7fff3c312570, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1867c70) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f9234745538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f922edfda5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f922edfe258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f922edfe429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f9234745ed6 in QEventDispatcherGlib::processEvents (this=0x183f6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f9232dfd07e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f9234719cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f9234719ef7 in QEventLoop::exec (this=0x7fff3c312800, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f923471e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fff3c312ae8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291525, bug 291522, bug 291520, bug 291513, bug 291509.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-01-15 02:07:14 UTC

*** This bug has been marked as a duplicate of bug 291262 ***