Bug 291486 - Opening Muon failed
Summary: Opening Muon failed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-14 00:03 UTC by kai.stampe
Modified: 2012-01-14 09:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.30 KB, text/plain)
2012-01-14 04:22 UTC, spotlessalmond
Details
New crash information added by DrKonqi (7.30 KB, text/plain)
2012-01-14 04:22 UTC, spotlessalmond
Details
New crash information added by DrKonqi (7.30 KB, text/plain)
2012-01-14 04:22 UTC, spotlessalmond
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kai.stampe 2012-01-14 00:03:47 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: i opened Muon and the Window opens but get closed in the same Time
Only the Bugreport opens
No custom Settings were set

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f05f65c8a5e in QtPrivate::QStringList_contains (that=0x7fffd9820c50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffd9820c50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1bf7010) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1bf7010, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd9821220) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f05f6674eba in QMetaObject::activate (sender=0x1c220a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1c220a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd9821380) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f05f6674eba in QMetaObject::activate (sender=0x1bf7010, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffd9821380) at kernel/qobject.cpp:3278
#13 0x00007f05f74e7e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1c6c4a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f05f74e7f8e in MuonMainWindow::initObject (this=0x1bf7010) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1bf7010) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1bf7010, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffd9821450) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f05f6674eba in QMetaObject::activate (sender=0x1c82390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f05f667cf7f in QSingleShotTimer::timerEvent (this=0x1c82390) at kernel/qtimer.cpp:308
#19 0x00007f05f6678789 in QObject::event (this=0x1c82390, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f05f4c9c424 in notify_helper (e=0x7fffd98219c0, receiver=0x1c82390, this=0x1a617e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1a617e0, receiver=0x1c82390, e=0x7fffd98219c0) at kernel/qapplication.cpp:4458
#22 0x00007f05f4ca1291 in QApplication::notify (this=0x7fffd9821cc0, receiver=0x1c82390, e=0x7fffd98219c0) at kernel/qapplication.cpp:4365
#23 0x00007f05f5e80126 in KApplication::notify (this=0x7fffd9821cc0, receiver=0x1c82390, event=0x7fffd98219c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f05f6661afc in QCoreApplication::notifyInternal (this=0x7fffd9821cc0, receiver=0x1c82390, event=0x7fffd98219c0) at kernel/qcoreapplication.cpp:787
#25 0x00007f05f668ed62 in sendEvent (event=0x7fffd98219c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1a68a90) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f05f668c538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f05f0d44a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f05f0d45258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f05f0d45429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f05f668ced6 in QEventDispatcherGlib::processEvents (this=0x1a3c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f05f4d4407e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f05f6660cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f05f6660ef7 in QEventLoop::exec (this=0x7fffd9821c50, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f05f6665789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=1, argv=0x7fffd9821f38) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291485, bug 291482, bug 291477, bug 291473, bug 291472.

Reported using DrKonqi
Comment 1 spotlessalmond 2012-01-14 04:22:01 UTC
Created attachment 67802 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: skype was idle while chromium streamed video. Application closed on every attempt to open it.

-- Backtrace (Reduced):
#7  0xb72ebe11 in QtPrivate::QStringList_contains (that=0xbffec154, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffec154) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x84fd0e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x84fd0e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffec374) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7398b7d in metacall (argv=0xbffec374, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x84fd0e0) at kernel/qmetaobject.cpp:237
Comment 2 spotlessalmond 2012-01-14 04:22:01 UTC
Created attachment 67803 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: skype was idle while chromium streamed video. Application closed on every attempt to open it.

-- Backtrace (Reduced):
#7  0xb72ebe11 in QtPrivate::QStringList_contains (that=0xbffec154, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffec154) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x84fd0e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x84fd0e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffec374) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7398b7d in metacall (argv=0xbffec374, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x84fd0e0) at kernel/qmetaobject.cpp:237
Comment 3 spotlessalmond 2012-01-14 04:22:01 UTC
Created attachment 67804 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed: skype was idle while chromium streamed video. Application closed on every attempt to open it.

-- Backtrace (Reduced):
#7  0xb72ebe11 in QtPrivate::QStringList_contains (that=0xbffec154, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbffec154) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x84fd0e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x84fd0e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffec374) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7398b7d in metacall (argv=0xbffec374, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x84fd0e0) at kernel/qmetaobject.cpp:237
Comment 4 Thijs 2012-01-14 09:01:15 UTC

*** This bug has been marked as a duplicate of bug 291262 ***