Bug 291485 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 23:23 UTC by martin scully
Modified: 2012-01-14 09:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin scully 2012-01-13 23:23:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I was  Launching Muon software center, I have just done a clean install of Kubuntu. 1st time to launch Muon. Can download S/W using aptitude.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4864930 (LWP 1908))]

Thread 2 (Thread 0xb254bb70 (LWP 1909)):
#0  0xb53b1d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb728c7d5 in do_gettime (frac=0xb254b020, sec=0xb254b018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb735f4b6 in QTimerInfoList::updateCurrentTime (this=0x8c05b34) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb735f80a in QTimerInfoList::timerWait (this=0x8c05b34, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb735e053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb254b12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb735e0ed in timerSourcePrepare (source=0x8c05b00, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb52f788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb52f8637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb52f8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb735eb37 in QEventDispatcherGlib::processEvents (this=0x8bc12f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb732f1dd in QEventLoop::processEvents (this=0xb254b2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb732f421 in QEventLoop::exec (this=0xb254b2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb723290b in QThread::exec (this=0x8b6d6f0) at thread/qthread.cpp:498
#14 0xb730fe2d in QInotifyFileSystemWatcherEngine::run (this=0x8b6d6f0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb72357b3 in QThreadPrivate::start (arg=0x8b6d6f0) at thread/qthread_unix.cpp:331
#16 0xb53ded31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5e2b0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4864930 (LWP 1908)):
[KCrash Handler]
#7  0xb7289e11 in QtPrivate::QStringList_contains (that=0xbfd73b24, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd73b24) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8b69238) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8b69238, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd73d44) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7336b7d in metacall (argv=0xbfd73d44, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8b69238) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8b69238, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd73d44) at kernel/qmetaobject.cpp:232
#13 0xb7345a6a in QMetaObject::activate (sender=0x8c071e0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8c071e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8c071e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd73e88) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7336b7d in metacall (argv=0xbfd73e88, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8c071e0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8c071e0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd73e88) at kernel/qmetaobject.cpp:232
#18 0xb7345a6a in QMetaObject::activate (sender=0x8b69238, m=0x80950c0, local_signal_index=0, argv=0xbfd73e88) at kernel/qobject.cpp:3278
#19 0xb77a47c5 in MuonMainWindow::backendReady (this=0x8b69238, _t1=0x8b86c90) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb77a4933 in MuonMainWindow::initObject (this=0x8b69238) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8b69238) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8b69238, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd73fb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7336b7d in metacall (argv=0xbfd73fb4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8b69238) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8b69238, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd73fb4) at kernel/qmetaobject.cpp:232
#25 0xb7345a6a in QMetaObject::activate (sender=0x8bd2d88, m=0xb7466238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb734d375 in QSingleShotTimer::timeout (this=0x8bd2d88) at .moc/release-shared/qtimer.moc:82
#27 0xb734d42c in QSingleShotTimer::timerEvent (this=0x8bd2d88) at kernel/qtimer.cpp:308
#28 0xb7348994 in QObject::event (this=0x8bd2d88, e=0xbfd743ac) at kernel/qobject.cpp:1181
#29 0xb6117d54 in notify_helper (e=0xbfd743ac, receiver=0x8bd2d88, this=0x8a839a0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8a839a0, receiver=0x8bd2d88, e=0xbfd743ac) at kernel/qapplication.cpp:4458
#31 0xb611d103 in QApplication::notify (this=0xbfd743ac, receiver=0x8bd2d88, e=0xbfd743ac) at kernel/qapplication.cpp:3886
#32 0xb6f36681 in KApplication::notify (this=0xbfd746c0, receiver=0x8bd2d88, event=0xbfd743ac) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb733019e in QCoreApplication::notifyInternal (this=0xbfd746c0, receiver=0x8bd2d88, event=0xbfd743ac) at kernel/qcoreapplication.cpp:787
#34 0xb7360c10 in sendEvent (event=0xbfd743ac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8a7ff34) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb735e122 in timerSourceDispatch (source=0x8a7ff00) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb52f825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb52f8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52f8c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb735eada in QEventDispatcherGlib::processEvents (this=0x8a61238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb61cfe3a in QGuiEventDispatcherGlib::processEvents (this=0x8a61238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb732f1dd in QEventLoop::processEvents (this=0xbfd74624, flags=...) at kernel/qeventloop.cpp:149
#43 0xb732f421 in QEventLoop::exec (this=0xbfd74624, flags=...) at kernel/qeventloop.cpp:201
#44 0xb733419d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb61158f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291482, bug 291477, bug 291473, bug 291472, bug 291467.

Reported using DrKonqi
Comment 1 Thijs 2012-01-14 09:00:22 UTC

*** This bug has been marked as a duplicate of bug 291262 ***