Bug 291482 - fallo al abrir centro de software muon
Summary: fallo al abrir centro de software muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 22:30 UTC by carlota
Modified: 2012-01-14 08:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.05 KB, text/plain)
2012-01-14 03:31 UTC, alex_esquivelg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description carlota 2012-01-13 22:30:58 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Lo lamentamos, centro de software de muon sse cerro inesperadamente.
Detalles:
Ejecutable: muon-installer PID:4126 señal:segmentation fault (11)

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb781c930 (LWP 2183))]

Thread 2 (Thread 0xb55a8b70 (LWP 2184)):
#0  0x05eebf54 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x01b0887f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x01b09637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01b09c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00548b37 in QEventDispatcherGlib::processEvents (this=0xa0faca8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x005191dd in QEventLoop::processEvents (this=0xb55a82b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00519421 in QEventLoop::exec (this=0xb55a82b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0041c90b in QThread::exec (this=0xa0ee578) at thread/qthread.cpp:498
#8  0x004f9e2d in QInotifyFileSystemWatcherEngine::run (this=0xa0ee578) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0041f7b3 in QThreadPrivate::start (arg=0xa0ee578) at thread/qthread_unix.cpp:331
#10 0x00d78d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x05ede0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb781c930 (LWP 2183)):
[KCrash Handler]
#7  0x00473e11 in QtPrivate::QStringList_contains (that=0xbf80a784, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf80a784) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa0b01b8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa0b01b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf80a9a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00520b7d in metacall (argv=0xbf80a9a4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa0b01b8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa0b01b8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf80a9a4) at kernel/qmetaobject.cpp:232
#13 0x0052fa6a in QMetaObject::activate (sender=0xa100a50, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa100a50) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa100a50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf80aae8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00520b7d in metacall (argv=0xbf80aae8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa100a50) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa100a50, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf80aae8) at kernel/qmetaobject.cpp:232
#18 0x0052fa6a in QMetaObject::activate (sender=0xa0b01b8, m=0x80950c0, local_signal_index=0, argv=0xbf80aae8) at kernel/qobject.cpp:3278
#19 0x00e637c5 in MuonMainWindow::backendReady (this=0xa0b01b8, _t1=0xa132f98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00e63933 in MuonMainWindow::initObject (this=0xa0b01b8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa0b01b8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa0b01b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf80ac14) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00520b7d in metacall (argv=0xbf80ac14, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa0b01b8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa0b01b8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf80ac14) at kernel/qmetaobject.cpp:232
#25 0x0052fa6a in QMetaObject::activate (sender=0xa10d1e0, m=0x650238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00537375 in QSingleShotTimer::timeout (this=0xa10d1e0) at .moc/release-shared/qtimer.moc:82
#27 0x0053742c in QSingleShotTimer::timerEvent (this=0xa10d1e0) at kernel/qtimer.cpp:308
#28 0x00532994 in QObject::event (this=0xa10d1e0, e=0xbf80b00c) at kernel/qobject.cpp:1181
#29 0x01157d54 in notify_helper (e=0xbf80b00c, receiver=0xa10d1e0, this=0x9fd6ea0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9fd6ea0, receiver=0xa10d1e0, e=0xbf80b00c) at kernel/qapplication.cpp:4458
#31 0x0115d103 in QApplication::notify (this=0xbf80b00c, receiver=0xa10d1e0, e=0xbf80b00c) at kernel/qapplication.cpp:3886
#32 0x06cb3681 in KApplication::notify (this=0xbf80b320, receiver=0xa10d1e0, event=0xbf80b00c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0051a19e in QCoreApplication::notifyInternal (this=0xbf80b320, receiver=0xa10d1e0, event=0xbf80b00c) at kernel/qcoreapplication.cpp:787
#34 0x0054ac10 in sendEvent (event=0xbf80b00c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9fd9b44) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00548122 in timerSourceDispatch (source=0x9fd9b10) at kernel/qeventdispatcher_glib.cpp:184
#37 0x01b0925f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01b09990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01b09c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00548ada in QEventDispatcherGlib::processEvents (this=0x9fb5238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0120fe3a in QGuiEventDispatcherGlib::processEvents (this=0x9fb5238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005191dd in QEventLoop::processEvents (this=0xbf80b284, flags=...) at kernel/qeventloop.cpp:149
#43 0x00519421 in QEventLoop::exec (this=0xbf80b284, flags=...) at kernel/qeventloop.cpp:201
#44 0x0051e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x011558f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291477, bug 291473, bug 291472, bug 291467, bug 291464.

Reported using DrKonqi
Comment 1 alex_esquivelg 2012-01-14 03:31:01 UTC
Created attachment 67801 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:
I was just opening Muon Software Center when it crashed

-- Backtrace (Reduced):
#6  0x00007f932d237a5e in QtPrivate::QStringList_contains (that=0x7fffb62f4e00, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffb62f4e00) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x12b5e30) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x12b5e30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb62f53d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1479c80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffb62f5530) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Thijs 2012-01-14 08:59:59 UTC

*** This bug has been marked as a duplicate of bug 291262 ***