Bug 291477 - Muon crashed at start
Summary: Muon crashed at start
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 20:01 UTC by christian.meister1
Modified: 2012-01-13 21:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian.meister1 2012-01-13 20:01:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: nothing, the Muon crashed after a new start, no other programm was startet

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a5930 (LWP 2247))]

Thread 2 (Thread 0xb5267b70 (LWP 2248)):
#0  0x014dfd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x004b67d5 in do_gettime (frac=0xb5267020, sec=0xb5267018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x005894b6 in QTimerInfoList::updateCurrentTime (this=0x937c34c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0058980a in QTimerInfoList::timerWait (this=0x937c34c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00588053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb526712c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x005880ed in timerSourcePrepare (source=0x937c318, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0344988c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x0344a637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x0344ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00588b37 in QEventDispatcherGlib::processEvents (this=0x9391450, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x005591dd in QEventLoop::processEvents (this=0xb52672b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00559421 in QEventLoop::exec (this=0xb52672b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0045c90b in QThread::exec (this=0x937c940) at thread/qthread.cpp:498
#14 0x00539e2d in QInotifyFileSystemWatcherEngine::run (this=0x937c940) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0045f7b3 in QThreadPrivate::start (arg=0x937c940) at thread/qthread_unix.cpp:331
#16 0x00e9ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0706a0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a5930 (LWP 2247)):
[KCrash Handler]
#7  0x004b3e11 in QtPrivate::QStringList_contains (that=0xbf8dacc4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8dacc4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x933ecd0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x933ecd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8daee4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00560b7d in metacall (argv=0xbf8daee4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x933ecd0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x933ecd0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8daee4) at kernel/qmetaobject.cpp:232
#13 0x0056fa6a in QMetaObject::activate (sender=0x9380328, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9380328) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9380328, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8db028) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00560b7d in metacall (argv=0xbf8db028, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9380328) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9380328, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8db028) at kernel/qmetaobject.cpp:232
#18 0x0056fa6a in QMetaObject::activate (sender=0x933ecd0, m=0x80950c0, local_signal_index=0, argv=0xbf8db028) at kernel/qobject.cpp:3278
#19 0x003547c5 in MuonMainWindow::backendReady (this=0x933ecd0, _t1=0x93235b8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00354933 in MuonMainWindow::initObject (this=0x933ecd0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x933ecd0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x933ecd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8db154) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00560b7d in metacall (argv=0xbf8db154, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x933ecd0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x933ecd0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8db154) at kernel/qmetaobject.cpp:232
#25 0x0056fa6a in QMetaObject::activate (sender=0x93924f8, m=0x690238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00577375 in QSingleShotTimer::timeout (this=0x93924f8) at .moc/release-shared/qtimer.moc:82
#27 0x0057742c in QSingleShotTimer::timerEvent (this=0x93924f8) at kernel/qtimer.cpp:308
#28 0x00572994 in QObject::event (this=0x93924f8, e=0xbf8db54c) at kernel/qobject.cpp:1181
#29 0x05cc0d54 in notify_helper (e=0xbf8db54c, receiver=0x93924f8, this=0x9245838) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9245838, receiver=0x93924f8, e=0xbf8db54c) at kernel/qapplication.cpp:4458
#31 0x05cc6103 in QApplication::notify (this=0xbf8db54c, receiver=0x93924f8, e=0xbf8db54c) at kernel/qapplication.cpp:3886
#32 0x010d4681 in KApplication::notify (this=0xbf8db860, receiver=0x93924f8, event=0xbf8db54c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0055a19e in QCoreApplication::notifyInternal (this=0xbf8db860, receiver=0x93924f8, event=0xbf8db54c) at kernel/qcoreapplication.cpp:787
#34 0x0058ac10 in sendEvent (event=0xbf8db54c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9241834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00588122 in timerSourceDispatch (source=0x9241800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0344a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0344a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0344ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00588ada in QEventDispatcherGlib::processEvents (this=0x9223238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x05d78e3a in QGuiEventDispatcherGlib::processEvents (this=0x9223238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x005591dd in QEventLoop::processEvents (this=0xbf8db7c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00559421 in QEventLoop::exec (this=0xbf8db7c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0055e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x05cbe8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291473, bug 291472, bug 291467, bug 291464, bug 291462.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 21:18:45 UTC

*** This bug has been marked as a duplicate of bug 291262 ***