Bug 291473 - muon crashes on start up
Summary: muon crashes on start up
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 19:19 UTC by Tony Levene
Modified: 2012-01-13 21:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Levene 2012-01-13 19:19:01 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7708930 (LWP 4990))]

Thread 2 (Thread 0xb56aeb70 (LWP 4991)):
#0  0x007b6d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0089d7d5 in do_gettime (frac=0xb56ae020, sec=0xb56ae018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009704b6 in QTimerInfoList::updateCurrentTime (this=0x9ae2344) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0097080a in QTimerInfoList::timerWait (this=0x9ae2344, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0096f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56ae12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0096f0ed in timerSourcePrepare (source=0x9ae2310, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06b8b88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06b8c637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06b8cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0096fb37 in QEventDispatcherGlib::processEvents (this=0x9aa2b58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009401dd in QEventLoop::processEvents (this=0xb56ae2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00940421 in QEventLoop::exec (this=0xb56ae2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0084390b in QThread::exec (this=0x9a5d108) at thread/qthread.cpp:498
#14 0x00920e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a5d108) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008467b3 in QThreadPrivate::start (arg=0x9a5d108) at thread/qthread_unix.cpp:331
#16 0x00db4d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x006780ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7708930 (LWP 4990)):
[KCrash Handler]
#7  0x0089ae11 in QtPrivate::QStringList_contains (that=0xbfd35464, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd35464) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a6c6e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd35684) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00947b7d in metacall (argv=0xbfd35684, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a6c6e8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9a6c6e8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd35684) at kernel/qmetaobject.cpp:232
#13 0x00956a6a in QMetaObject::activate (sender=0x9b9cc20, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b9cc20) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b9cc20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd357c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00947b7d in metacall (argv=0xbfd357c8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b9cc20) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b9cc20, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd357c8) at kernel/qmetaobject.cpp:232
#18 0x00956a6a in QMetaObject::activate (sender=0x9a6c6e8, m=0x80950c0, local_signal_index=0, argv=0xbfd357c8) at kernel/qobject.cpp:3278
#19 0x00e787c5 in MuonMainWindow::backendReady (this=0x9a6c6e8, _t1=0x9a54018) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00e78933 in MuonMainWindow::initObject (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9a6c6e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd358f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00947b7d in metacall (argv=0xbfd358f4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9a6c6e8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9a6c6e8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd358f4) at kernel/qmetaobject.cpp:232
#25 0x00956a6a in QMetaObject::activate (sender=0x9ab7708, m=0xa77238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0095e375 in QSingleShotTimer::timeout (this=0x9ab7708) at .moc/release-shared/qtimer.moc:82
#27 0x0095e42c in QSingleShotTimer::timerEvent (this=0x9ab7708) at kernel/qtimer.cpp:308
#28 0x00959994 in QObject::event (this=0x9ab7708, e=0xbfd35cec) at kernel/qobject.cpp:1181
#29 0x05510d54 in notify_helper (e=0xbfd35cec, receiver=0x9ab7708, this=0x9971940) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9971940, receiver=0x9ab7708, e=0xbfd35cec) at kernel/qapplication.cpp:4458
#31 0x05516103 in QApplication::notify (this=0xbfd35cec, receiver=0x9ab7708, e=0xbfd35cec) at kernel/qapplication.cpp:3886
#32 0x01093681 in KApplication::notify (this=0xbfd36000, receiver=0x9ab7708, event=0xbfd35cec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0094119e in QCoreApplication::notifyInternal (this=0xbfd36000, receiver=0x9ab7708, event=0xbfd35cec) at kernel/qcoreapplication.cpp:787
#34 0x00971c10 in sendEvent (event=0xbfd35cec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x996db34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0096f122 in timerSourceDispatch (source=0x996db00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06b8c25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06b8c990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06b8cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0096fada in QEventDispatcherGlib::processEvents (this=0x994f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x055c8e3a in QGuiEventDispatcherGlib::processEvents (this=0x994f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009401dd in QEventLoop::processEvents (this=0xbfd35f64, flags=...) at kernel/qeventloop.cpp:149
#43 0x00940421 in QEventLoop::exec (this=0xbfd35f64, flags=...) at kernel/qeventloop.cpp:201
#44 0x0094519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0550e8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7708930 (LWP 4990))]

Thread 2 (Thread 0xb56aeb70 (LWP 4991)):
#0  0x007b6d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0089d7d5 in do_gettime (frac=0xb56ae020, sec=0xb56ae018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x009704b6 in QTimerInfoList::updateCurrentTime (this=0x9ae2344) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0097080a in QTimerInfoList::timerWait (this=0x9ae2344, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0096f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb56ae12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0096f0ed in timerSourcePrepare (source=0x9ae2310, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x06b8b88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x06b8c637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x06b8cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0096fb37 in QEventDispatcherGlib::processEvents (this=0x9aa2b58, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x009401dd in QEventLoop::processEvents (this=0xb56ae2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00940421 in QEventLoop::exec (this=0xb56ae2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0084390b in QThread::exec (this=0x9a5d108) at thread/qthread.cpp:498
#14 0x00920e2d in QInotifyFileSystemWatcherEngine::run (this=0x9a5d108) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x008467b3 in QThreadPrivate::start (arg=0x9a5d108) at thread/qthread_unix.cpp:331
#16 0x00db4d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x006780ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7708930 (LWP 4990)):
[KCrash Handler]
#7  0x0089ae11 in QtPrivate::QStringList_contains (that=0xbfd35464, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd35464) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9a6c6e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd35684) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00947b7d in metacall (argv=0xbfd35684, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9a6c6e8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9a6c6e8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd35684) at kernel/qmetaobject.cpp:232
#13 0x00956a6a in QMetaObject::activate (sender=0x9b9cc20, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9b9cc20) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9b9cc20, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd357c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00947b7d in metacall (argv=0xbfd357c8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9b9cc20) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9b9cc20, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd357c8) at kernel/qmetaobject.cpp:232
#18 0x00956a6a in QMetaObject::activate (sender=0x9a6c6e8, m=0x80950c0, local_signal_index=0, argv=0xbfd357c8) at kernel/qobject.cpp:3278
#19 0x00e787c5 in MuonMainWindow::backendReady (this=0x9a6c6e8, _t1=0x9a54018) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00e78933 in MuonMainWindow::initObject (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9a6c6e8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9a6c6e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd358f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00947b7d in metacall (argv=0xbfd358f4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9a6c6e8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9a6c6e8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd358f4) at kernel/qmetaobject.cpp:232
#25 0x00956a6a in QMetaObject::activate (sender=0x9ab7708, m=0xa77238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0095e375 in QSingleShotTimer::timeout (this=0x9ab7708) at .moc/release-shared/qtimer.moc:82
#27 0x0095e42c in QSingleShotTimer::timerEvent (this=0x9ab7708) at kernel/qtimer.cpp:308
#28 0x00959994 in QObject::event (this=0x9ab7708, e=0xbfd35cec) at kernel/qobject.cpp:1181
#29 0x05510d54 in notify_helper (e=0xbfd35cec, receiver=0x9ab7708, this=0x9971940) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9971940, receiver=0x9ab7708, e=0xbfd35cec) at kernel/qapplication.cpp:4458
#31 0x05516103 in QApplication::notify (this=0xbfd35cec, receiver=0x9ab7708, e=0xbfd35cec) at kernel/qapplication.cpp:3886
#32 0x01093681 in KApplication::notify (this=0xbfd36000, receiver=0x9ab7708, event=0xbfd35cec) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0094119e in QCoreApplication::notifyInternal (this=0xbfd36000, receiver=0x9ab7708, event=0xbfd35cec) at kernel/qcoreapplication.cpp:787
#34 0x00971c10 in sendEvent (event=0xbfd35cec, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x996db34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0096f122 in timerSourceDispatch (source=0x996db00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x06b8c25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x06b8c990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x06b8cc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0096fada in QEventDispatcherGlib::processEvents (this=0x994f238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x055c8e3a in QGuiEventDispatcherGlib::processEvents (this=0x994f238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x009401dd in QEventLoop::processEvents (this=0xbfd35f64, flags=...) at kernel/qeventloop.cpp:149
#43 0x00940421 in QEventLoop::exec (this=0xbfd35f64, flags=...) at kernel/qeventloop.cpp:201
#44 0x0094519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0550e8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291472, bug 291467, bug 291464, bug 291462, bug 291453.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 21:17:47 UTC

*** This bug has been marked as a duplicate of bug 291262 ***