Bug 291467 - muon-installer crashed
Summary: muon-installer crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 17:39 UTC by webmaster
Modified: 2012-01-13 18:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description webmaster 2012-01-13 17:39:34 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

- Unusual behavior I noticed:

i just wanted to start, but the application crashed after opening the window in kde.
the "sudo apt-get  remove muon-installer"  and  later "sudo apt-get install muon-installer" did not solve the problem

The crash can be reproduced some of the time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7802930 (LWP 1958))]

Thread 2 (Thread 0xb57b6b70 (LWP 1962)):
#0  0x03217c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0096cb37 in QEventDispatcherGlib::processEvents (this=0x9037200, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#2  0x0093d1dd in QEventLoop::processEvents (this=0xb57b62b0, flags=...) at kernel/qeventloop.cpp:149
#3  0x0093d421 in QEventLoop::exec (this=0xb57b62b0, flags=...) at kernel/qeventloop.cpp:201
#4  0x0084090b in QThread::exec (this=0x904e3e8) at thread/qthread.cpp:498
#5  0x0091de2d in QInotifyFileSystemWatcherEngine::run (this=0x904e3e8) at io/qfilesystemwatcher_inotify.cpp:248
#6  0x008437b3 in QThreadPrivate::start (arg=0x904e3e8) at thread/qthread_unix.cpp:331
#7  0x00c7dd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x0038d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7802930 (LWP 1958)):
[KCrash Handler]
#7  0x00897e11 in QtPrivate::QStringList_contains (that=0xbfe03114, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe03114) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8fd7560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8fd7560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe03334) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00944b7d in metacall (argv=0xbfe03334, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8fd7560) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8fd7560, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe03334) at kernel/qmetaobject.cpp:232
#13 0x00953a6a in QMetaObject::activate (sender=0x90193d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90193d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90193d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe03478) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00944b7d in metacall (argv=0xbfe03478, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90193d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90193d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe03478) at kernel/qmetaobject.cpp:232
#18 0x00953a6a in QMetaObject::activate (sender=0x8fd7560, m=0x80950c0, local_signal_index=0, argv=0xbfe03478) at kernel/qobject.cpp:3278
#19 0x00b3e7c5 in MuonMainWindow::backendReady (this=0x8fd7560, _t1=0x9020890) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00b3e933 in MuonMainWindow::initObject (this=0x8fd7560) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8fd7560) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8fd7560, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe035a4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00944b7d in metacall (argv=0xbfe035a4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8fd7560) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8fd7560, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe035a4) at kernel/qmetaobject.cpp:232
#25 0x00953a6a in QMetaObject::activate (sender=0x90370c0, m=0xa74238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0095b375 in QSingleShotTimer::timeout (this=0x90370c0) at .moc/release-shared/qtimer.moc:82
#27 0x0095b42c in QSingleShotTimer::timerEvent (this=0x90370c0) at kernel/qtimer.cpp:308
#28 0x00956994 in QObject::event (this=0x90370c0, e=0xbfe0399c) at kernel/qobject.cpp:1181
#29 0x067abd54 in notify_helper (e=0xbfe0399c, receiver=0x90370c0, this=0x8ec8e50) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8ec8e50, receiver=0x90370c0, e=0xbfe0399c) at kernel/qapplication.cpp:4458
#31 0x067b1103 in QApplication::notify (this=0xbfe0399c, receiver=0x90370c0, e=0xbfe0399c) at kernel/qapplication.cpp:3886
#32 0x01045681 in KApplication::notify (this=0xbfe03cb0, receiver=0x90370c0, event=0xbfe0399c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0093e19e in QCoreApplication::notifyInternal (this=0xbfe03cb0, receiver=0x90370c0, event=0xbfe0399c) at kernel/qcoreapplication.cpp:787
#34 0x0096ec10 in sendEvent (event=0xbfe0399c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ec5a7c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0096c122 in timerSourceDispatch (source=0x8ec5a48) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0321725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x03217990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03217c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0096cada in QEventDispatcherGlib::processEvents (this=0x8ea7238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x06863e3a in QGuiEventDispatcherGlib::processEvents (this=0x8ea7238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0093d1dd in QEventLoop::processEvents (this=0xbfe03c14, flags=...) at kernel/qeventloop.cpp:149
#43 0x0093d421 in QEventLoop::exec (this=0xbfe03c14, flags=...) at kernel/qeventloop.cpp:201
#44 0x0094219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x067a98f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291464, bug 291462, bug 291453, bug 291411, bug 291394.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 18:21:15 UTC

*** This bug has been marked as a duplicate of bug 291262 ***