Bug 291464 - Muon Paketverwaltung (muon-installer)
Summary: Muon Paketverwaltung (muon-installer)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-13 17:04 UTC by Hans Rößler
Modified: 2012-01-13 17:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Rößler 2012-01-13 17:04:25 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I did the autoupdates. These freezed, so i restarted my Computer. After the Restart the muon-installer crashed every time i try to start it. I also tried to uninstall and reinstall it but it also didn't solved the problem. (The system is quite new I set it up a few hours ago)

- Unusual behavior I noticed:
Before the muon-installer didn't worked anymore, the updates for everything on the system freezed

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7708930 (LWP 1698))]

Thread 2 (Thread 0xb5537b70 (LWP 1702)):
#0  0x00646d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x009a87d5 in do_gettime (frac=0xb5537020, sec=0xb5537018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00a7b4b6 in QTimerInfoList::updateCurrentTime (this=0x93a549c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00a7b80a in QTimerInfoList::timerWait (this=0x93a549c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00a7a053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb553712c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00a7a0ed in timerSourcePrepare (source=0x93a5468, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x062c488c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x062c5637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x062c5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00a7ab37 in QEventDispatcherGlib::processEvents (this=0x9252840, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00a4b1dd in QEventLoop::processEvents (this=0xb55372b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00a4b421 in QEventLoop::exec (this=0xb55372b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0094e90b in QThread::exec (this=0x928e600) at thread/qthread.cpp:498
#14 0x00a2be2d in QInotifyFileSystemWatcherEngine::run (this=0x928e600) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x009517b3 in QThreadPrivate::start (arg=0x928e600) at thread/qthread_unix.cpp:331
#16 0x0088bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0073d0ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7708930 (LWP 1698)):
[KCrash Handler]
#7  0x009a5e11 in QtPrivate::QStringList_contains (that=0xbfba5c94, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfba5c94) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9253568) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9253568, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba5eb4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a52b7d in metacall (argv=0xbfba5eb4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9253568) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9253568, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfba5eb4) at kernel/qmetaobject.cpp:232
#13 0x00a61a6a in QMetaObject::activate (sender=0x92035e8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x92035e8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x92035e8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba5ff8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a52b7d in metacall (argv=0xbfba5ff8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x92035e8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x92035e8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfba5ff8) at kernel/qmetaobject.cpp:232
#18 0x00a61a6a in QMetaObject::activate (sender=0x9253568, m=0x80950c0, local_signal_index=0, argv=0xbfba5ff8) at kernel/qobject.cpp:3278
#19 0x002f67c5 in MuonMainWindow::backendReady (this=0x9253568, _t1=0x92bd910) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x002f6933 in MuonMainWindow::initObject (this=0x9253568) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9253568) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9253568, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfba6124) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a52b7d in metacall (argv=0xbfba6124, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9253568) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9253568, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfba6124) at kernel/qmetaobject.cpp:232
#25 0x00a61a6a in QMetaObject::activate (sender=0x92a0ca8, m=0xb82238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a69375 in QSingleShotTimer::timeout (this=0x92a0ca8) at .moc/release-shared/qtimer.moc:82
#27 0x00a6942c in QSingleShotTimer::timerEvent (this=0x92a0ca8) at kernel/qtimer.cpp:308
#28 0x00a64994 in QObject::event (this=0x92a0ca8, e=0xbfba651c) at kernel/qobject.cpp:1181
#29 0x041ded54 in notify_helper (e=0xbfba651c, receiver=0x92a0ca8, this=0x91537e8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x91537e8, receiver=0x92a0ca8, e=0xbfba651c) at kernel/qapplication.cpp:4458
#31 0x041e4103 in QApplication::notify (this=0xbfba651c, receiver=0x92a0ca8, e=0xbfba651c) at kernel/qapplication.cpp:3886
#32 0x00f11681 in KApplication::notify (this=0xbfba6830, receiver=0x92a0ca8, event=0xbfba651c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a4c19e in QCoreApplication::notifyInternal (this=0xbfba6830, receiver=0x92a0ca8, event=0xbfba651c) at kernel/qcoreapplication.cpp:787
#34 0x00a7cc10 in sendEvent (event=0xbfba651c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x915483c) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a7a122 in timerSourceDispatch (source=0x9154808) at kernel/qeventdispatcher_glib.cpp:184
#37 0x062c525f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x062c5990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x062c5c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a7aada in QEventDispatcherGlib::processEvents (this=0x9136238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04296e3a in QGuiEventDispatcherGlib::processEvents (this=0x9136238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a4b1dd in QEventLoop::processEvents (this=0xbfba6794, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a4b421 in QEventLoop::exec (this=0xbfba6794, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a5019d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x041dc8f4 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291462, bug 291453, bug 291411, bug 291394, bug 291393.

Reported using DrKonqi
Comment 1 Thijs 2012-01-13 17:07:34 UTC

*** This bug has been marked as a duplicate of bug 291262 ***