Bug 288423 - Crash when displaying HTML view (with images) of an email
Summary: Crash when displaying HTML view (with images) of an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-07 17:06 UTC by Arnaud Mombrial
Modified: 2011-12-07 17:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Mombrial 2011-12-07 17:06:22 UTC
Application: kontact (4.7.3)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.8.0
Operating System: Linux 3.1.4-1.fc16.i686.PAE i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
Click on the leftsidebar of an email to view HTML presentation.
Click on link to view images too
Right Click (Wanted to print message but kmail crash here)

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb783b780 (LWP 1998))]

Thread 5 (Thread 0xb6b31b40 (LWP 2000)):
#0  0x00e72424 in __kernel_vsyscall ()
#1  0x4782984c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4d2a42b3 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x4d9f7c40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#3  0x4d2a43d0 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x4d9f7c40) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#4  0x47825cd3 in start_thread (arg=0xb6b31b40) at pthread_create.c:309
#5  0x4775c51e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 4 (Thread 0xb6208b40 (LWP 2007)):
#0  0x4788c001 in __GI_clock_gettime (clock_id=1, tp=0xb6207ff8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x4847d056 in do_gettime (frac=0xb6207ff0, sec=0xb6207fe8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x48565aa7 in QTimerInfoList::updateCurrentTime (this=0xb5901abc) at kernel/qeventdispatcher_unix.cpp:343
#4  0x485656fe in timerSourceCheckHelper (src=0xb5901a88) at kernel/qeventdispatcher_glib.cpp:150
#5  timerSourceCheckHelper (src=0xb5901a88) at kernel/qeventdispatcher_glib.cpp:144
#6  0x4791127c in g_main_context_check (context=0xb59004e0, max_priority=2147483647, fds=0xb5900de8, n_fds=1) at gmain.c:2943
#7  0x47911c60 in g_main_context_iterate (context=0xb59004e0, block=1200752544, dispatch=1, self=0xb5900d70) at gmain.c:3070
#8  0x47911faf in g_main_context_iteration (context=0xb59004e0, may_block=1) at gmain.c:3136
#9  0x485651c7 in QEventDispatcherGlib::processEvents (this=0xb5900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0x485313ae in QEventLoop::processEvents (this=0xb6208230, flags=...) at kernel/qeventloop.cpp:149
#11 0x48531659 in QEventLoop::exec (this=0xb6208230, flags=...) at kernel/qeventloop.cpp:204
#12 0x4841b03c in QThread::exec (this=0x832f1f0) at thread/qthread.cpp:501
#13 0x4841b12c in QThread::run (this=0x832f1f0) at thread/qthread.cpp:568
#14 0x4841e5c1 in QThreadPrivate::start (arg=0x832f1f0) at thread/qthread_unix.cpp:298
#15 0x47825cd3 in start_thread (arg=0xb6208b40) at pthread_create.c:309
#16 0x4775c51e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xa9ac5b40 (LWP 3605)):
#0  0x00e72424 in __kernel_vsyscall ()
#1  0x4782984c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4841eb48 in wait (time=4294967295, this=0xcc69b48) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0xcc69514, mutex=0xcc69510, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0x46c33b73 in QFileInfoGatherer::run (this=0xcc69508) at dialogs/qfileinfogatherer.cpp:214
#5  0x4841e5c1 in QThreadPrivate::start (arg=0xcc69508) at thread/qthread_unix.cpp:298
#6  0x47825cd3 in start_thread (arg=0xa9ac5b40) at pthread_create.c:309
#7  0x4775c51e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xa8ac3b40 (LWP 3606)):
#0  0x4788c001 in __GI_clock_gettime (clock_id=1, tp=0xa8ac2f68) at ../sysdeps/unix/clock_gettime.c:116
#1  0x4847d056 in do_gettime (frac=0xa8ac2f60, sec=0xa8ac2f58) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x48565aa7 in QTimerInfoList::updateCurrentTime (this=0xb4803074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x48565e0b in QTimerInfoList::timerWait (this=0xb4803074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x48564653 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa8ac306c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x485646ed in timerSourcePrepare (source=0xb4803040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x47910bdc in g_main_context_prepare (context=0xb4807658, priority=0xa8ac30c8) at gmain.c:2746
#8  0x47911998 in g_main_context_iterate (context=0xb4807658, block=1, dispatch=1, self=0xb4803000) at gmain.c:3053
#9  0x47911faf in g_main_context_iteration (context=0xb4807658, may_block=1) at gmain.c:3136
#10 0x485651c7 in QEventDispatcherGlib::processEvents (this=0xb4802200, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x485313ae in QEventLoop::processEvents (this=0xa8ac3200, flags=...) at kernel/qeventloop.cpp:149
#12 0x48531659 in QEventLoop::exec (this=0xa8ac3200, flags=...) at kernel/qeventloop.cpp:204
#13 0x4841b03c in QThread::exec (this=0xc84b558) at thread/qthread.cpp:501
#14 0x4850e33e in QInotifyFileSystemWatcherEngine::run (this=0xc84b558) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x4841e5c1 in QThreadPrivate::start (arg=0xc84b558) at thread/qthread_unix.cpp:298
#16 0x47825cd3 in start_thread (arg=0xa8ac3b40) at pthread_create.c:309
#17 0x4775c51e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb783b780 (LWP 1998)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0x48786ae9 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xc8252a8, hm=..., sc=-1074219144, rp=..., pu=false, db=..., contentLength=-3078493220) at access/qnetworkaccesshttpbackend.cpp:827
#9  0x48817d1d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xc8252a8, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xc9ff550) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#10 0x48544612 in QMetaCallEvent::placeMetaCall (this=0xc9ff6b0, object=0xc8252a8) at kernel/qobject.cpp:524
#11 0x4854d2db in QObject::event (this=0xc8252a8, e=0xc9ff6b0) at kernel/qobject.cpp:1194
#12 0x466a3a34 in notify_helper (e=0xc9ff6b0, receiver=0xc8252a8, this=0x82155a0) at kernel/qapplication.cpp:4518
#13 QApplicationPrivate::notify_helper (this=0x82155a0, receiver=0xc8252a8, e=0xc9ff6b0) at kernel/qapplication.cpp:4490
#14 0x466a8ed3 in QApplication::notify (this=0xc9ff6b0, receiver=0xc8252a8, e=0xc9ff6b0) at kernel/qapplication.cpp:4247
#15 0x4729afa2 in KApplication::notify (this=0xbff8cec4, receiver=0xc8252a8, event=0xc9ff6b0) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#16 0x485324be in QCoreApplication::notifyInternal (this=0xbff8cec4, receiver=0xc8252a8, event=0xc9ff6b0) at kernel/qcoreapplication.cpp:876
#17 0x48536418 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x81edc90) at kernel/qcoreapplication.cpp:1500
#19 0x4853674d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#20 0x48564d65 in sendPostedEvents () at kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x8219438) at kernel/qeventdispatcher_glib.cpp:279
#22 0x479115bf in g_main_dispatch (context=0x8218cf8) at gmain.c:2425
#23 g_main_context_dispatch (context=0x8218cf8) at gmain.c:2995
#24 0x47911d00 in g_main_context_iterate (context=0x8218cf8, block=1200752544, dispatch=1, self=0x8215770) at gmain.c:3073
#25 0x47911faf in g_main_context_iteration (context=0x8218cf8, may_block=1) at gmain.c:3136
#26 0x48565168 in QEventDispatcherGlib::processEvents (this=0x81ee7f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x4675838b in QGuiEventDispatcherGlib::processEvents (this=0x81ee7f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#28 0x485313ae in QEventLoop::processEvents (this=0xbff8bf60, flags=...) at kernel/qeventloop.cpp:149
#29 0x48531659 in QEventLoop::exec (this=0xbff8bf60, flags=...) at kernel/qeventloop.cpp:204
#30 0x46bf3eaa in QDialog::exec (this=0xca40280) at dialogs/qdialog.cpp:552
#31 0x46bd6e6c in QPrintDialog::exec (this=0xca40280) at dialogs/qprintdialog_unix.cpp:646
#32 0x019adcf4 in ?? () from /usr/lib/libmessageviewer.so.4
#33 0x019c3c1d in ?? () from /usr/lib/libmessageviewer.so.4
#34 0x48547d61 in QMetaObject::activate (sender=0xcb67860, m=0x1a0b8a0, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3546
#35 0x019c66d6 in ?? () from /usr/lib/libmessageviewer.so.4
#36 0x019c695d in ?? () from /usr/lib/libmessageviewer.so.4
#37 0x019c5c07 in ?? () from /usr/lib/libmessageviewer.so.4
#38 0x019bf8a2 in ?? () from /usr/lib/libmessageviewer.so.4
#39 0x019c0070 in ?? () from /usr/lib/libmessageviewer.so.4
#40 0x019c2ee5 in ?? () from /usr/lib/libmessageviewer.so.4
#41 0x019c33c3 in ?? () from /usr/lib/libmessageviewer.so.4
#42 0x019a8967 in MessageViewer::Viewer::printMessage(Akonadi::Item const&) () from /usr/lib/libmessageviewer.so.4
#43 0x4b883045 in KMPrintCommand::execute() () from /usr/lib/libkmailprivate.so.4
#44 0x4b8851f0 in KMCommand::slotPostTransfer(KMCommand::Result) () from /usr/lib/libkmailprivate.so.4
#45 0x4b88d099 in ?? () from /usr/lib/libkmailprivate.so.4
#46 0x48547d61 in QMetaObject::activate (sender=0xbbc1548, m=0x4b9a21d0, local_signal_index=0, argv=0xbff8c518) at kernel/qobject.cpp:3546
#47 0x4b884f86 in KMCommand::messagesTransfered(KMCommand::Result) () from /usr/lib/libkmailprivate.so.4
#48 0x4b88c202 in KMCommand::slotJobFinished() () from /usr/lib/libkmailprivate.so.4
#49 0x4b88d068 in ?? () from /usr/lib/libkmailprivate.so.4
#50 0x48547d61 in QMetaObject::activate (sender=0xbe82320, m=0x48b88e2c, local_signal_index=3, argv=0xbff8c678) at kernel/qobject.cpp:3546
#51 0x489d9db6 in KJob::result (this=0xbe82320, _t1=0xbe82320) at /usr/src/debug/kdelibs-4.7.3/i686-redhat-linux-gnu/kdecore/kjob.moc:208
#52 0x489d9e09 in KJob::emitResult (this=0xbe82320) at /usr/src/debug/kdelibs-4.7.3/kdecore/jobs/kjob.cpp:312
#53 0x49494d3f in Akonadi::JobPrivate::delayedEmitResult (this=0xc74b958) at /usr/src/debug/kdepimlibs-4.7.3/akonadi/job.cpp:144
#54 0x48544612 in QMetaCallEvent::placeMetaCall (this=0xc8d2f80, object=0xbe82320) at kernel/qobject.cpp:524
#55 0x4854d2db in QObject::event (this=0xbe82320, e=0xc8d2f80) at kernel/qobject.cpp:1194
#56 0x466a3a34 in notify_helper (e=0xc8d2f80, receiver=0xbe82320, this=0x82155a0) at kernel/qapplication.cpp:4518
#57 QApplicationPrivate::notify_helper (this=0x82155a0, receiver=0xbe82320, e=0xc8d2f80) at kernel/qapplication.cpp:4490
#58 0x466a8ed3 in QApplication::notify (this=0xc8d2f80, receiver=0xbe82320, e=0xc8d2f80) at kernel/qapplication.cpp:4247
#59 0x4729afa2 in KApplication::notify (this=0xbff8cec4, receiver=0xbe82320, event=0xc8d2f80) at /usr/src/debug/kdelibs-4.7.3/kdeui/kernel/kapplication.cpp:311
#60 0x485324be in QCoreApplication::notifyInternal (this=0xbff8cec4, receiver=0xbe82320, event=0xc8d2f80) at kernel/qcoreapplication.cpp:876
#61 0x48536418 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#62 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x81edc90) at kernel/qcoreapplication.cpp:1500
#63 0x4853674d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#64 0x48564d65 in sendPostedEvents () at kernel/qcoreapplication.h:236
#65 postEventSourceDispatch (s=0x8219438) at kernel/qeventdispatcher_glib.cpp:279
#66 0x479115bf in g_main_dispatch (context=0x8218cf8) at gmain.c:2425
#67 g_main_context_dispatch (context=0x8218cf8) at gmain.c:2995
#68 0x47911d00 in g_main_context_iterate (context=0x8218cf8, block=1200752544, dispatch=1, self=0x8215770) at gmain.c:3073
#69 0x47911faf in g_main_context_iteration (context=0x8218cf8, may_block=1) at gmain.c:3136
#70 0x48565168 in QEventDispatcherGlib::processEvents (this=0x81ee7f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#71 0x4675838b in QGuiEventDispatcherGlib::processEvents (this=0x81ee7f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#72 0x485313ae in QEventLoop::processEvents (this=0xbff8ce24, flags=...) at kernel/qeventloop.cpp:149
#73 0x48531659 in QEventLoop::exec (this=0xbff8ce24, flags=...) at kernel/qeventloop.cpp:204
#74 0x485367fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#75 0x466a1835 in QApplication::exec () at kernel/qapplication.cpp:3779
#76 0x0804ae53 in ?? ()
#77 0x476836b3 in __libc_start_main (main=0x804a360, argc=3, ubp_av=0xbff8d0e4, init=0x804bc60 <__libc_csu_init>, fini=0x804bcd0 <__libc_csu_fini>, rtld_fini=0x476552c0 <_dl_fini>, stack_end=0xbff8d0dc) at libc-start.c:226
#78 0x0804b385 in _start ()

Possible duplicates by query: bug 288362, bug 288324, bug 288070, bug 288015, bug 287929.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2011-12-07 17:08:58 UTC

*** This bug has been marked as a duplicate of bug 286307 ***