Bug 288190 - kde crash when I log in
Summary: kde crash when I log in
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-04 12:41 UTC by istvanscheuring
Modified: 2011-12-04 17:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description istvanscheuring 2011-12-04 12:41:58 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-13-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
 It says segmentation fault when I want to log in. prevously there was not any problem with kde plasma, it works properly.  I could log in if I start with a safe mode as a root and then use startx.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1837f997a0 (LWP 1634))]

Thread 3 (Thread 0x7f1817b48700 (LWP 1636)):
#0  0x00007f1837878771 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f182be03f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f182be04429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1834a6af3e in QEventDispatcherGlib::processEvents (this=0x1d70880, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1834a3ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1834a3eef7 in QEventLoop::exec (this=0x7f1817b47db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f183495627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f1834a21cbf in QInotifyFileSystemWatcherEngine::run (this=0x1d6f090) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1834958d05 in QThreadPrivate::start (arg=0x1d6f090) at thread/qthread_unix.cpp:331
#9  0x00007f182c910efc in start_thread (arg=0x7f1817b48700) at pthread_create.c:304
#10 0x00007f183788489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f180e7f4700 (LWP 1637)):
#0  0x00007f1837878773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f182be03f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f182be04429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1834a6af3e in QEventDispatcherGlib::processEvents (this=0x221e9e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1834a3ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1834a3eef7 in QEventLoop::exec (this=0x7f180e7f3db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f183495627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f1834a21cbf in QInotifyFileSystemWatcherEngine::run (this=0x158c6c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1834958d05 in QThreadPrivate::start (arg=0x158c6c0) at thread/qthread_unix.cpp:331
#9  0x00007f182c910efc in start_thread (arg=0x7f180e7f4700) at pthread_create.c:304
#10 0x00007f183788489d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1837f997a0 (LWP 1634)):
[KCrash Handler]
#6  0x00007f1833fe2c09 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e61e40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f1833fe2c89 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1e61e40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f1833ffc26e in QWidgetBackingStore::~QWidgetBackingStore (this=0x1e64480, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f1833e39a29 in QWidgetBackingStoreTracker::destroy (this=0x1e643d0) at kernel/qwidget.cpp:210
#10 0x00007f1833e39b7e in QWidgetPrivate::deleteExtra (this=0x1a43690) at kernel/qwidget.cpp:1796
#11 0x00007f1833e39dac in QWidgetPrivate::~QWidgetPrivate (this=0x1a43690, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f1833e3a0b9 in QWidgetPrivate::~QWidgetPrivate (this=0x1a43690, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f1834a5739b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x1a65908, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x1a65900, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f1833e3c162 in QWidget::~QWidget (this=0x1a65900, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f1833e3c379 in QWidget::~QWidget (this=0x1a65900, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#18 0x00007f18343a6c55 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=<optimized out>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1825
#19 0x00007f18377de821 in __run_exit_handlers (status=0, listp=0x7f1837b3b5a8, run_list_atexit=true) at exit.c:78
#20 0x00007f18377de8a5 in __GI_exit (status=<optimized out>) at exit.c:100
#21 0x00007f18377c4314 in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff34538c98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff34538c88) at libc-start.c:258
#22 0x0000000000400671 in _start ()

Possible duplicates by query: bug 287750, bug 284669, bug 282666, bug 277044, bug 269671.

Reported using DrKonqi
Comment 1 Anne-Marie Mahfouf 2011-12-04 17:18:58 UTC

*** This bug has been marked as a duplicate of bug 261539 ***