Bug 282666 - Plasma crash while fiddling with XBar
Summary: Plasma crash while fiddling with XBar
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-24 10:37 UTC by Hrvoje Senjan
Modified: 2011-11-24 08:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hrvoje Senjan 2011-09-24 10:37:12 UTC
Application: plasma-windowed (0.1)
KDE Platform Version: 4.7.1 (4.7.1)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-11-generic x86_64
Distribution: Ubuntu oneiric (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

As the title says ... DrKonqi suggest kde4-window-decorator crashes but i'm using KWin. 
(XBar whas started in plasma-windowed mode)

-- Backtrace:
Application: Ljuska za Plasma widgete (plasma-windowed), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7b41d4a7a0 (LWP 32658))]

Thread 2 (Thread 0x7f7b27dec700 (LWP 32663)):
#0  0x00007f7b416a7773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7b3800e058 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7b3800e519 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7b40294f3e in QEventDispatcherGlib::processEvents (this=0xaf1070, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7b40268cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7b40268ef7 in QEventLoop::exec (this=0x7f7b27debdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7b4018027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f7b4024bcbf in QInotifyFileSystemWatcherEngine::run (this=0xadca00) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7b40182d05 in QThreadPrivate::start (arg=0xadca00) at thread/qthread_unix.cpp:331
#9  0x00007f7b38adbedc in start_thread (arg=0x7f7b27dec700) at pthread_create.c:304
#10 0x00007f7b416b389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7b41d4a7a0 (LWP 32658)):
[KCrash Handler]
#6  0x00007f7b3f80c749 in QRasterWindowSurface::~QRasterWindowSurface (this=0xb1e300, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f7b3f80c7c9 in QRasterWindowSurface::~QRasterWindowSurface (this=0xb1e300, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f7b3f825dae in QWidgetBackingStore::~QWidgetBackingStore (this=0xb9b030, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f7b3f6639d9 in QWidgetBackingStoreTracker::destroy (this=0xba94a0) at kernel/qwidget.cpp:210
#10 0x00007f7b3f663b2e in QWidgetPrivate::deleteExtra (this=0xa55ee0) at kernel/qwidget.cpp:1796
#11 0x00007f7b3f663d5c in QWidgetPrivate::~QWidgetPrivate (this=0xa55ee0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f7b3f664069 in QWidgetPrivate::~QWidgetPrivate (this=0xa55ee0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f7b4028139b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0xa55b58, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0xa55b50, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f7b3f666112 in QWidget::~QWidget (this=0xa55b50, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f7b41217dcf in ~EffectWatcher (this=0xa55b50, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#18 Plasma::EffectWatcher::~EffectWatcher (this=0xa55b50, __in_chrg=<optimized out>) at ../../plasma/private/effectwatcher_p.h:30
#19 0x00007f7b4127caaf in ~ThemePrivate (this=0xa531d0, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:119
#20 Plasma::Theme::~Theme (this=0xa5fe60, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:482
#21 0x00007f7b4127cfc7 in ~ThemeSingleton (this=0xa5fe60, __in_chrg=<optimized out>) at ../../plasma/theme.cpp:421
#22 destroy () at ../../plasma/theme.cpp:437
#23 0x00007f7b4160d821 in __run_exit_handlers (status=0, listp=0x7f7b4196a5a8, run_list_atexit=true) at exit.c:78
#24 0x00007f7b4160d8a5 in __GI_exit (status=<optimized out>) at exit.c:100
#25 0x00007f7b415f3314 in __libc_start_main (main=0x400650 <main(int, char**)>, argc=2, ubp_av=0x7fff2f77fcd8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2f77fcc8) at libc-start.c:258
#26 0x0000000000400681 in _start ()

Possible duplicates by query: bug 277044, bug 269671, bug 255081.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-11-24 08:17:33 UTC

*** This bug has been marked as a duplicate of bug 261539 ***