Bug 284669 - Plasma Crash when attempting to kquitapp
Summary: Plasma Crash when attempting to kquitapp
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-22 07:19 UTC by Shantanu Tushar
Modified: 2011-11-24 08:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shantanu Tushar 2011-10-22 07:19:47 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.41 (4.7.41 (KDE 4.8 >= 20110807) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
kquitapp plasma-desktop

and BOOM!

This happens everytime I do that, and very rarely, when shutting down.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5523710 (LWP 14251))]

Thread 8 (Thread 0xaadb2b70 (LWP 14252)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb5d2240e in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb56fd34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb56ee896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb56eec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6cbb926 in QEventDispatcherGlib::processEvents (this=0x8a712a8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6c854c5 in QEventLoop::processEvents (this=0xaadb2298, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6c85605 in QEventLoop::exec (this=0xaadb2298, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6b7b5db in QThread::exec (this=0x8a6f980) at thread/qthread.cpp:498
#9  0xb6c66f42 in QInotifyFileSystemWatcherEngine::run (this=0x8a6f980) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6b7dcf4 in QThreadPrivate::start (arg=0x8a6f980) at thread/qthread_unix.cpp:331
#11 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 7 (Thread 0xa5fddb70 (LWP 31638)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb6b7f07f in QWaitConditionPrivate::wait (this=0x8aba730, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  0xb6b7ee85 in QWaitCondition::wait (this=0x8ad0e90, mutex=0x8aafe60, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb4d3e180 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ad0e78, th=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb4d42078 in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8aafe50, th=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0xb4d3e0ff in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ad0e78, th=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0xb4d4201e in ThreadWeaver::WorkingHardState::applyForWork (this=0x8aafe50, th=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0xb4d3e0d8 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ad0e78, th=0xa767fc8, previous=0xb1b2820) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0xb4d3fc33 in ThreadWeaver::ThreadRunHelper::run (this=0xa5fdd2f4, parent=0x8ad0e78, th=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#10 0xb4d3fee9 in ThreadWeaver::Thread::run (this=0xa767fc8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#11 0xb6b7dcf4 in QThreadPrivate::start (arg=0xa767fc8) at thread/qthread_unix.cpp:331
#12 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 6 (Thread 0xa4ccfb70 (LWP 31639)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb6b7f07f in QWaitConditionPrivate::wait (this=0x8aba730, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  0xb6b7ee85 in QWaitCondition::wait (this=0x8ad0e90, mutex=0x8aafe60, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb4d3e180 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ad0e78, th=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb4d42078 in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8aafe50, th=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0xb4d3e0ff in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ad0e78, th=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0xb4d4201e in ThreadWeaver::WorkingHardState::applyForWork (this=0x8aafe50, th=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0xb4d3e0d8 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ad0e78, th=0x972c6e0, previous=0xb1d6740) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0xb4d3fc33 in ThreadWeaver::ThreadRunHelper::run (this=0xa4ccf2f4, parent=0x8ad0e78, th=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#10 0xb4d3fee9 in ThreadWeaver::Thread::run (this=0x972c6e0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#11 0xb6b7dcf4 in QThreadPrivate::start (arg=0x972c6e0) at thread/qthread_unix.cpp:331
#12 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xa8f59b70 (LWP 31640)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb6b7f07f in QWaitConditionPrivate::wait (this=0x8aba730, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  0xb6b7ee85 in QWaitCondition::wait (this=0x8ad0e90, mutex=0x8aafe60, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb4d3e180 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ad0e78, th=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb4d42078 in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8aafe50, th=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0xb4d3e0ff in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ad0e78, th=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0xb4d4201e in ThreadWeaver::WorkingHardState::applyForWork (this=0x8aafe50, th=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0xb4d3e0d8 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ad0e78, th=0x94983d8, previous=0x987f9c8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0xb4d3fc33 in ThreadWeaver::ThreadRunHelper::run (this=0xa8f592f4, parent=0x8ad0e78, th=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#10 0xb4d3fee9 in ThreadWeaver::Thread::run (this=0x94983d8) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#11 0xb6b7dcf4 in QThreadPrivate::start (arg=0x94983d8) at thread/qthread_unix.cpp:331
#12 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xa70a9b70 (LWP 31641)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb6b7f07f in QWaitConditionPrivate::wait (this=0x8aba730, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  0xb6b7ee85 in QWaitCondition::wait (this=0x8ad0e90, mutex=0x8aafe60, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb4d3e180 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ad0e78, th=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb4d42078 in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8aafe50, th=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0xb4d3e0ff in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ad0e78, th=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0xb4d4201e in ThreadWeaver::WorkingHardState::applyForWork (this=0x8aafe50, th=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0xb4d3e0d8 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ad0e78, th=0x8e84fe0, previous=0x0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0xb4d3fc33 in ThreadWeaver::ThreadRunHelper::run (this=0xa70a92f4, parent=0x8ad0e78, th=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#10 0xb4d3fee9 in ThreadWeaver::Thread::run (this=0x8e84fe0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#11 0xb6b7dcf4 in QThreadPrivate::start (arg=0x8e84fe0) at thread/qthread_unix.cpp:331
#12 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xa68a8b70 (LWP 31642)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb6b7f07f in QWaitConditionPrivate::wait (this=0x8aba730, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  0xb6b7ee85 in QWaitCondition::wait (this=0x8ad0e90, mutex=0x8aafe60, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb4d3e180 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ad0e78, th=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb4d42078 in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8aafe50, th=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0xb4d3e0ff in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ad0e78, th=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0xb4d4201e in ThreadWeaver::WorkingHardState::applyForWork (this=0x8aafe50, th=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0xb4d3e0d8 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ad0e78, th=0xaa4074d0, previous=0x0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0xb4d3fc33 in ThreadWeaver::ThreadRunHelper::run (this=0xa68a82f4, parent=0x8ad0e78, th=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:87
#10 0xb4d3fee9 in ThreadWeaver::Thread::run (this=0xaa4074d0) at /home/shaan/kde/src/kdelibs/threadweaver/Weaver/Thread.cpp:142
#11 0xb6b7dcf4 in QThreadPrivate::start (arg=0xaa4074d0) at thread/qthread_unix.cpp:331
#12 0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xa3ac3b70 (LWP 24210)):
#0  0xb7712424 in __kernel_vsyscall ()
#1  0xb6af4a5c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb2f8553e in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb30f5d60) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb2f84c89 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb30f5d60) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb6af0d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0xb5d310ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb5523710 (LWP 14251)):
[KCrash Handler]
#7  0xb6294d2c in QRasterWindowSurface::~QRasterWindowSurface (this=0x9101750, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:104
#8  0xb6294df7 in QRasterWindowSurface::~QRasterWindowSurface (this=0x9101750, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:108
#9  0xb62b34ac in QWidgetBackingStore::~QWidgetBackingStore (this=0x9101d40, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#10 0xb609d712 in QWidgetBackingStoreTracker::destroy (this=0x9101cc8) at kernel/qwidget.cpp:210
#11 0xb60a09ca in QWidgetPrivate::deleteExtra (this=0x87d77b8) at kernel/qwidget.cpp:1800
#12 0xb609de47 in QWidgetPrivate::~QWidgetPrivate (this=0x87d77b8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:345
#13 0xb609e07b in QWidgetPrivate::~QWidgetPrivate (this=0x87d77b8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:350
#14 0xb6c53d6f in QScopedPointerDeleter<QObjectData>::cleanup (pointer=0x87d77b8) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 0xb6ca432f in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::~QScopedPointer (this=0x87dbbf4, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 0xb6c9dad2 in QObject::~QObject (this=0x87dbbf0, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#17 0xb60a036e in QWidget::~QWidget (this=0x87dbbf0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1532
#18 0xb60a04a5 in QWidget::~QWidget (this=0x87dbbf0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1675
#19 0xb66f05f5 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0xb6ae909c, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1823
#20 0xb5c91981 in ?? () from /lib/i386-linux-gnu/libc.so.6
#21 0xb5c91a0d in exit () from /lib/i386-linux-gnu/libc.so.6
#22 0x0804d709 in launch (argc=1, _name=0x822a734 "/home/shaan/kde/bin/plasma-desktop", args=0x822a757 "", cwd=0x0, envc=0, envs=0x822a75b "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8053081 "0") at /home/shaan/kde/src/kdelibs/kinit/kinit.cpp:734
#23 0x0804e7cf in handle_launcher_request (sock=8, who=0x805331c "launcher") at /home/shaan/kde/src/kdelibs/kinit/kinit.cpp:1226
#24 0x0804efcb in handle_requests (waitForPid=0) at /home/shaan/kde/src/kdelibs/kinit/kinit.cpp:1419
#25 0x080508ff in main (argc=4, argv=0xbf991f14, envp=0xbf991f28) at /home/shaan/kde/src/kdelibs/kinit/kinit.cpp:1907

Possible duplicates by query: bug 282666, bug 277044, bug 269671, bug 261539, bug 255081.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-10-25 09:57:40 UTC
Are you using the Bespin widget style?
Comment 2 Shantanu Tushar 2011-10-25 10:10:28 UTC
Nope, default oxygen widget style.
Comment 3 Beat Wolf 2011-11-24 08:17:36 UTC

*** This bug has been marked as a duplicate of bug 261539 ***