Bug 287750 - Plasma crashes on exit
Summary: Plasma crashes on exit
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-28 14:02 UTC by a.pronobis
Modified: 2011-11-28 14:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a.pronobis 2011-11-28 14:02:28 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.2.0-1-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Every time I restart KDE, plasma crashes with the attached backtrace.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f374fcb47a0 (LWP 1726))]

Thread 4 (Thread 0x7f372604a700 (LWP 1730)):
#0  0x00007f374f5a0773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3743b2af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3743b2b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f374c791f3e in QEventDispatcherGlib::processEvents (this=0x104e9e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f374c765cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f374c765ef7 in QEventLoop::exec (this=0x7f3726049db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f374c67d27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f374c748cbf in QInotifyFileSystemWatcherEngine::run (this=0x104b2c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f374c67fd05 in QThreadPrivate::start (arg=0x104b2c0) at thread/qthread_unix.cpp:331
#9  0x00007f3744637efc in start_thread (arg=0x7f372604a700) at pthread_create.c:304
#10 0x00007f374f5ac89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3723e37700 (LWP 1731)):
#0  0x00007f374f5a0773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3743b2af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3743b2b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f374c791f3e in QEventDispatcherGlib::processEvents (this=0x7f372c001150, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f374c765cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f374c765ef7 in QEventLoop::exec (this=0x7f3723e36db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f374c67d27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f374c748cbf in QInotifyFileSystemWatcherEngine::run (this=0x12548c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f374c67fd05 in QThreadPrivate::start (arg=0x12548c0) at thread/qthread_unix.cpp:331
#9  0x00007f3744637efc in start_thread (arg=0x7f3723e37700) at pthread_create.c:304
#10 0x00007f374f5ac89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f371b94b700 (LWP 1795)):
#0  0x00007f374f5a0773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3743b2af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3743b2b792 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f371c429516 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f3743b502b6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3744637efc in start_thread (arg=0x7f371b94b700) at pthread_create.c:304
#6  0x00007f374f5ac89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f374fcb47a0 (LWP 1726)):
[KCrash Handler]
#6  0x00007f374bd09c09 in QRasterWindowSurface::~QRasterWindowSurface (this=0x100e6f0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:110
#7  0x00007f374bd09c89 in QRasterWindowSurface::~QRasterWindowSurface (this=0x100e6f0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:114
#8  0x00007f374bd2326e in QWidgetBackingStore::~QWidgetBackingStore (this=0x100ffe0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f374bb60a29 in QWidgetBackingStoreTracker::destroy (this=0x100ff30) at kernel/qwidget.cpp:210
#10 0x00007f374bb60b7e in QWidgetPrivate::deleteExtra (this=0xd05460) at kernel/qwidget.cpp:1796
#11 0x00007f374bb60dac in QWidgetPrivate::~QWidgetPrivate (this=0xd05460, __in_chrg=<optimized out>) at kernel/qwidget.cpp:341
#12 0x00007f374bb610b9 in QWidgetPrivate::~QWidgetPrivate (this=0xd05460, __in_chrg=<optimized out>) at kernel/qwidget.cpp:346
#13 0x00007f374c77e39b in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0xdbeec8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0xdbeec0, __in_chrg=<optimized out>) at kernel/qobject.cpp:818
#16 0x00007f374bb63162 in QWidget::~QWidget (this=0xdbeec0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1528
#17 0x00007f374bb63379 in QWidget::~QWidget (this=0xdbeec0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1671
#18 0x00007f374c0cdc55 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=<optimized out>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1825
#19 0x00007f374f506821 in __run_exit_handlers (status=0, listp=0x7f374f8635a8, run_list_atexit=true) at exit.c:78
#20 0x00007f374f5068a5 in __GI_exit (status=<optimized out>) at exit.c:100
#21 0x00007f374f4ec314 in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff11a44508, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff11a444f8) at libc-start.c:258
#22 0x0000000000400671 in _start ()

Possible duplicates by query: bug 284669, bug 282666, bug 277044, bug 269671, bug 261539.

Reported using DrKonqi
Comment 1 Beat Wolf 2011-11-28 14:36:54 UTC

*** This bug has been marked as a duplicate of bug 261539 ***