Bug 253674 - akonadi crashes if kmail is started while akonadi hasn't been running before
Summary: akonadi crashes if kmail is started while akonadi hasn't been running before
Status: RESOLVED UNMAINTAINED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.9
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 253675 269912 288621 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-09 16:14 UTC by Davide Bettio
Modified: 2017-01-07 21:59 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (2.02 KB, text/plain)
2011-08-16 15:44 UTC, forsuspicioussenders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Bettio 2010-10-09 16:14:56 UTC
Application: akonadi_maildispatcher_agent (0.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Trying to start kmail while akonadi wasn't running (for example when kmail is started when there isn't any KDE application running)
kmail probably crashes too (kmail main window has been closed but I didn't see any crash report)

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Agent (akonadi_maildispatcher_agent), signal: Aborted
[KCrash Handler]
#6  0x00007f5a4352ca75 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f5a435305c0 in *__GI_abort () at abort.c:92
#8  0x00007f5a450af8e4 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2259
#9  0x00007f5a45774f61 in ~QDebug (this=0x15b12e0) at /usr/include/qt4/QtCore/qdebug.h:85
#10 Akonadi::AgentBasePrivate::delayedInit (this=0x15b12e0) at ../../akonadi/agentbase.cpp:250
#11 0x00007f5a45772393 in Akonadi::AgentBase::qt_metacall (this=0x15b3560, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x15ba4a0) at ./agentbase.moc:115
#12 0x0000000000409cd0 in MailDispatcherAgent::qt_metacall (this=0x1519, _c=5401, _id=6, _a=0xffffffffffffffff) at ./maildispatcheragent.moc:84
#13 0x00007f5a451bce7e in QObject::event (this=0x15b3560, e=0x1519) at kernel/qobject.cpp:1219
#14 0x00007f5a41ae36ec in QApplicationPrivate::notify_helper (this=0x14ae4f0, receiver=0x15b3560, e=0x15b8eb0) at kernel/qapplication.cpp:4396
#15 0x00007f5a41ae91dd in QApplication::notify (this=0x7fff7f814420, receiver=0x15b3560, e=0x15b8eb0) at kernel/qapplication.cpp:4277
#16 0x00007f5a43fdb536 in KApplication::notify (this=0x7fff7f814420, receiver=0x15b3560, event=0x15b8eb0) at ../../kdeui/kernel/kapplication.cpp:310
#17 0x00007f5a451ab0ac in QCoreApplication::notifyInternal (this=0x7fff7f814420, receiver=0x15b3560, event=0x15b8eb0) at kernel/qcoreapplication.cpp:732
#18 0x00007f5a451adfd2 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1495c90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1495c90) at kernel/qcoreapplication.cpp:1373
#20 0x00007f5a451d7643 in QCoreApplication::sendPostedEvents (s=0x14b1f10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x14b1f10) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f5a40c348c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f5a40c38748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f5a40c388fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f5a451d7183 in QEventDispatcherGlib::processEvents (this=0x14953e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#26 0x00007f5a41b9597e in QGuiEventDispatcherGlib::processEvents (this=0x1519, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f5a451a9dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f5a451aa1bc in QEventLoop::exec (this=0x7fff7f8143a0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f5a451ae26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#30 0x00007f5a45771fc6 in Akonadi::AgentBase::init (r=0x15b3560) at ../../akonadi/agentbase.cpp:501
#31 0x0000000000408d45 in Akonadi::AgentBase::init<MailDispatcherAgent> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/KDE/Akonadi/../../akonadi/agentbase.h:317
#32 main (argc=<value optimized out>, argv=<value optimized out>) at ../../../agents/maildispatcher/maildispatcheragent.cpp:289

Possible duplicates by query: bug 223761.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-07-13 22:31:51 UTC
*** Bug 253675 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Marin 2011-07-13 22:32:15 UTC
*** Bug 269912 has been marked as a duplicate of this bug. ***
Comment 3 forsuspicioussenders 2011-08-16 15:44:31 UTC
Created attachment 62873 [details]
New crash information added by DrKonqi

akonadi_maildispatcher_agent (0.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

Simply replying to an email in Kmail when akonadi is not running causes Kmail to hang.

-- Backtrace (Reduced):
#9  0x00007fd25cb602cd in ~QDebug (this=0x18063d0) at /usr/include/qt4/QtCore/qdebug.h:85
#10 Akonadi::AgentBasePrivate::delayedInit (this=0x18063d0) at ../../akonadi/agentbase.cpp:278
#11 0x00007fd25cb6147b in Akonadi::AgentBase::qt_metacall (this=0x18737d0, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0x187a170) at ./agentbase.moc:120
#12 0x0000000000409340 in _start ()
Comment 4 Christophe Marin 2011-12-10 09:17:38 UTC
*** Bug 288621 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Marin 2011-12-27 23:54:42 UTC
valid in master. I have a similar core file from the nepomuk feeder:

#3  0x00007f2ee486d98d in QDebug::~QDebug (this=0x7fff2b780e80, __in_chrg=<optimized out>) at /usr/include/QtCore/qdebug.h:85
#4  0x00007f2ee4869a6f in Akonadi::AgentBasePrivate::delayedInit (this=0x5f8170) at /kde/src/pim/kdepimlibs/akonadi/agentbase.cpp:288
#5  0x00007f2ee486cb46 in Akonadi::AgentBase::qt_static_metacall (_o=0x4dc1e0, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0x5e7f60) at /kde/build/pim/kdepimlibs/akonadi/agentbase.moc:97
#6  0x00007f2ee4469916 in QObject::event (this=0x4dc1e0, e=<optimized out>) at kernel/qobject.cpp:1204
#7  0x00007f2ee244be84 in notify_helper (e=0x60b710, receiver=0x4dc1e0, this=0x454200) at kernel/qapplication.cpp:4550
#8  QApplicationPrivate::notify_helper (this=0x454200, receiver=0x4dc1e0, e=0x60b710) at kernel/qapplication.cpp:4522
#9  0x00007f2ee2450d03 in QApplication::notify (this=0x7fff2b781900, receiver=0x4dc1e0, e=0x60b710) at kernel/qapplication.cpp:4411
#10 0x00007f2ee507752b in KApplication::notify (this=0x7fff2b781900, receiver=0x4dc1e0, event=0x60b710) at /kde/src/kdelibs/kdeui/kernel/kapplication.cpp:311
#11 0x00007f2ee445088c in QCoreApplication::notifyInternal (this=0x7fff2b781900, receiver=0x4dc1e0, event=0x60b710) at kernel/qcoreapplication.cpp:876
#12 0x00007f2ee445412a in sendEvent (event=0x60b710, receiver=0x4dc1e0) at kernel/qcoreapplication.h:231
#13 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x434670) at kernel/qcoreapplication.cpp:1500
#14 0x00007f2ee447f4b3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#15 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#16 0x00007f2edf0e358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f2edf0e3d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f2edf0e3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f2ee447f8df in QEventDispatcherGlib::processEvents (this=0x434350, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#20 0x00007f2ee24ef2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00007f2ee444f672 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f2ee444f8c7 in QEventLoop::exec (this=0x7fff2b781860, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f2ee4454425 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#24 0x00007f2ee486b771 in Akonadi::AgentBase::init (r=0x4dc1e0) at /kde/src/pim/kdepimlibs/akonadi/agentbase.cpp:564
#25 0x000000000040b17f in Akonadi::AgentBase::init<Akonadi::NepomukFeederAgent> (argc=3, argv=0x7fff2b781a58) at /kde/inst/kdepimlibs/include/akonadi/agentbase.h:342
#26 0x0000000000409d0d in main (argc=3, argv=0x7fff2b781a58) at /kde/src/pim/kdepim-runtime/agents/nepomukfeeder/nepomukfeederagent.cpp:332
Comment 6 Denis Kurz 2016-09-24 20:34:43 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 7 Denis Kurz 2017-01-07 21:59:08 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.