Bug 253675 - akonadi crashes when kmail is started
Summary: akonadi crashes when kmail is started
Status: RESOLVED DUPLICATE of bug 253674
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Nepomuk Feeder Agents (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-09 16:19 UTC by Davide Bettio
Modified: 2011-07-13 22:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Bettio 2010-10-09 16:19:47 UTC
Application: akonadi_nepomuk_contact_feeder (0.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
This crash happened while trying to start kmail while akonadi wasn't been running.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Agent (akonadi_nepomuk_contact_feeder), signal: Aborted
[KCrash Handler]
#6  0x00007f7fdf535a75 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f7fdf5395c0 in *__GI_abort () at abort.c:92
#8  0x00007f7fe07cc8e4 in qt_message_output (msgType=QtFatalMsg, buf=<value optimized out>) at global/qglobal.cpp:2259
#9  0x00007f7fe0c6ef61 in ~QDebug (this=0x2443f50) at /usr/include/qt4/QtCore/qdebug.h:85
#10 Akonadi::AgentBasePrivate::delayedInit (this=0x2443f50) at ../../akonadi/agentbase.cpp:250
#11 0x00007f7fe0c6c393 in Akonadi::AgentBase::qt_metacall (this=0x2449840, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x24551e0) at ./agentbase.moc:115
#12 0x0000000000412630 in NepomukFeederAgentBase::qt_metacall (this=0x151a, _c=5402, _id=6, _a=0xffffffffffffffff) at ./nepomukfeederagentbase.moc:83
#13 0x00007f7fe08d9e7e in QObject::event (this=0x2449840, e=0x151a) at kernel/qobject.cpp:1219
#14 0x00007f7fde7b46ec in QApplicationPrivate::notify_helper (this=0x235aa20, receiver=0x2449840, e=0x245aa40) at kernel/qapplication.cpp:4396
#15 0x00007f7fde7ba1dd in QApplication::notify (this=0x7ffff70f1730, receiver=0x2449840, e=0x245aa40) at kernel/qapplication.cpp:4277
#16 0x00007f7fe16e5536 in KApplication::notify (this=0x7ffff70f1730, receiver=0x2449840, event=0x245aa40) at ../../kdeui/kernel/kapplication.cpp:310
#17 0x00007f7fe08c80ac in QCoreApplication::notifyInternal (this=0x7ffff70f1730, receiver=0x2449840, event=0x245aa40) at kernel/qcoreapplication.cpp:732
#18 0x00007f7fe08cafd2 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x2343c90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x2343c90) at kernel/qcoreapplication.cpp:1373
#20 0x00007f7fe08f4643 in QCoreApplication::sendPostedEvents (s=0x235e440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x235e440) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f7fda7028c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f7fda706748 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f7fda7068fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f7fe08f4183 in QEventDispatcherGlib::processEvents (this=0x23433e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#26 0x00007f7fde86697e in QGuiEventDispatcherGlib::processEvents (this=0x151a, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f7fe08c6dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f7fe08c71bc in QEventLoop::exec (this=0x7ffff70f16b0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f7fe08cb26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#30 0x00007f7fe0c6bfc6 in Akonadi::AgentBase::init (r=0x2449840) at ../../akonadi/agentbase.cpp:501
#31 0x0000000000408e38 in Akonadi::AgentBase::init<Akonadi::NepomukContactFeeder> (argc=<value optimized out>, argv=<value optimized out>) at /usr/include/akonadi/agentbase.h:317
#32 main (argc=<value optimized out>, argv=<value optimized out>) at ../../../agents/nepomuk_contact_feeder/nepomukcontactfeeder.cpp:262

This bug may be a duplicate of or related to bug 253674.

Possible duplicates by query: bug 253674, bug 223761.

Reported using DrKonqi
Comment 1 Christophe Marin 2011-07-13 22:31:51 UTC

*** This bug has been marked as a duplicate of bug 253674 ***