Bug 282924 - Panel crash while trying to add widgets.
Summary: Panel crash while trying to add widgets.
Status: RESOLVED DUPLICATE of bug 263824
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-27 18:29 UTC by Rob Gillen
Modified: 2011-09-29 12:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Gillen 2011-09-27 18:29:51 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-30-generic x86_64
Distribution: Linux Mint 10 Julia

-- Information about the crash:
Tried to add World Clock to Panel, and it crashed repeatedly until I tried it in a different location.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f82edaec780 (LWP 2878))]

Thread 2 (Thread 0x7f82c7fff700 (LWP 4147)):
#0  0x00007f82ea708665 in __pthread_mutex_lock (mutex=0x7f82c801bb88) at pthread_mutex_lock.c:61
#1  0x00007f82e2078a43 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x00007f82e2078e78 in ?? () from /lib/libglib-2.0.so.0
#3  0x00007f82e207945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00007f82eaab11e6 in QEventDispatcherGlib::processEvents (this=0x1dd36d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f82eaa83a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f82eaa83dec in QEventLoop::exec (this=0x7f82c7ffed90, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f82ea98e2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f82eaa635f8 in QInotifyFileSystemWatcherEngine::run (this=0x1e4d030) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f82ea99127e in QThreadPrivate::start (arg=0x1e4d030) at thread/qthread_unix.cpp:266
#10 0x00007f82ea706971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f82ed40e92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f82edaec780 (LWP 2878)):
[KCrash Handler]
#6  QGraphicsItem::setCursor (this=<value optimized out>, cursor=...) at graphicsview/qgraphicsitem.cpp:2132
#7  0x00007f82ec2cda63 in Plasma::AbstractIcon::mouseMoveEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/libplasmagenericshell.so.4
#8  0x00007f82ea1f9fe2 in QGraphicsItem::sceneEvent (this=0x1c08a40, event=0x4a) at graphicsview/qgraphicsitem.cpp:6663
#9  0x00007f82ea211cf8 in QGraphicsScenePrivate::sendMouseEvent (this=0xbf1980, mouseEvent=0x7fff29d60b80) at graphicsview/qgraphicsscene.cpp:1285
#10 0x00007f82ea215471 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7fff29d60b80) at graphicsview/qgraphicsscene.cpp:4085
#11 0x00007f82ea22624b in QGraphicsScene::event (this=0xaf0fa0, event=0x7fff29d60b80) at graphicsview/qgraphicsscene.cpp:3437
#12 0x00007f82e9bcefdc in QApplicationPrivate::notify_helper (this=0xb04900, receiver=0xaf0fa0, e=0x7fff29d60b80) at kernel/qapplication.cpp:4396
#13 0x00007f82e9bd4aed in QApplication::notify (this=0xaf04a0, receiver=0xaf0fa0, e=0x7fff29d60b80) at kernel/qapplication.cpp:4277
#14 0x00007f82eb722586 in KApplication::notify (this=0xaf04a0, receiver=0xaf0fa0, event=0x7fff29d60b80) at ../../kdeui/kernel/kapplication.cpp:310
#15 0x00007f82eaa84cdc in QCoreApplication::notifyInternal (this=0xaf04a0, receiver=0xaf0fa0, event=0x7fff29d60b80) at kernel/qcoreapplication.cpp:732
#16 0x00007f82ea244c17 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x1bf05c0, event=0x7fff29d616e0) at graphicsview/qgraphicsview.cpp:647
#17 0x00007f82ea244e0e in QGraphicsView::mouseMoveEvent (this=0x1b7bc40, event=0x7fff29d616e0) at graphicsview/qgraphicsview.cpp:3272
#18 0x00007f82e9c24cab in QWidget::event (this=0x1b7bc40, event=0x7fff29d616e0) at kernel/qwidget.cpp:8172
#19 0x00007f82e9ff05e6 in QFrame::event (this=0x1b7bc40, e=0x7fff29d616e0) at widgets/qframe.cpp:557
#20 0x00007f82ea24287b in QGraphicsView::viewportEvent (this=0x1b7bc40, event=0x7fff29d616e0) at graphicsview/qgraphicsview.cpp:2862
#21 0x00007f82eaa84507 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1b767e0, event=0x7fff29d616e0) at kernel/qcoreapplication.cpp:847
#22 0x00007f82e9bcefac in QApplicationPrivate::notify_helper (this=0xb04900, receiver=0x1b767e0, e=0x7fff29d616e0) at kernel/qapplication.cpp:4392
#23 0x00007f82e9bd530e in QApplication::notify (this=0xaf04a0, receiver=0x1b767e0, e=0x7fff29d616e0) at kernel/qapplication.cpp:3959
#24 0x00007f82eb722586 in KApplication::notify (this=0xaf04a0, receiver=0x1b767e0, event=0x7fff29d616e0) at ../../kdeui/kernel/kapplication.cpp:310
#25 0x00007f82eaa84cdc in QCoreApplication::notifyInternal (this=0xaf04a0, receiver=0x1b767e0, event=0x7fff29d616e0) at kernel/qcoreapplication.cpp:732
#26 0x00007f82e9bd3dbe in sendEvent (receiver=0x1b767e0, event=0x7fff29d616e0, alienWidget=0x1b767e0, nativeWidget=0x1a6ba40, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 QApplicationPrivate::sendMouseEvent (receiver=0x1b767e0, event=0x7fff29d616e0, alienWidget=0x1b767e0, nativeWidget=0x1a6ba40, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#28 0x00007f82e9c57345 in QETWidget::translateMouseEvent (this=0x1a6ba40, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#29 0x00007f82e9c55c5c in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff29d62000) at kernel/qapplication_x11.cpp:3536
#30 0x00007f82e9c820e2 in x11EventSourceDispatch (s=0xb08180, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#31 0x00007f82e2075342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0x00007f82e20792a8 in ?? () from /lib/libglib-2.0.so.0
#33 0x00007f82e207945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0x00007f82eaab1193 in QEventDispatcherGlib::processEvents (this=0xad5070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#35 0x00007f82e9c81a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fff29d60150, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f82eaa83a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007f82eaa83dec in QEventLoop::exec (this=0x7fff29d62330, flags=) at kernel/qeventloop.cpp:201
#38 0x00007f82eaa87ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#39 0x00007f82ed6e5ba3 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#40 0x00007f82ed346d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff29d62708) at libc-start.c:226
#41 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 259156.

Possible duplicates by query: bug 263824, bug 260956, bug 259156, bug 253552.

Reported using DrKonqi
Comment 1 Dario Andres 2011-09-29 12:41:36 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6 . The issue was being tracked at bug 263824, merging.
Thanks

*** This bug has been marked as a duplicate of bug 263824 ***