Bug 253552 - KWin crashed after widget explorer stuck when trying to move a widget to desktop
Summary: KWin crashed after widget explorer stuck when trying to move a widget to desktop
Status: RESOLVED DUPLICATE of bug 259156
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 23:32 UTC by Ron Katzir
Modified: 2011-01-01 15:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (17.00 KB, text/plain)
2010-12-07 11:52 UTC, mossad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Katzir 2010-10-07 23:32:06 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2) "release 5"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.3-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I was trying to move blackboard widget to desktop from the widget explorer. The explorer stuck, and subsequently lwin crashed. openSUSE 11.3 with KDE 4.5.2

-- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#7  0xb69e7cf5 in QGraphicsItem::setCursor (this=0xacb79e8, cursor=...) at graphicsview/qgraphicsitem.cpp:2051
#8  0xb2c89c79 in Plasma::AbstractIcon::mouseMoveEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/libplasmagenericshell.so.4
#9  0xb69ec916 in QGraphicsItem::sceneEvent (this=0xacb79e8, event=0xbff8b1f4) at graphicsview/qgraphicsitem.cpp:6539
#10 0xb6a44856 in QGraphicsWidget::sceneEvent (this=0xacb79e0, event=0xbff8b1f4) at graphicsview/qgraphicswidget.cpp:1123
#11 0xb6a1054e in QGraphicsScenePrivate::sendEvent (this=0x8152758, item=0xacb79e8, event=0xbff8b1f4) at graphicsview/qgraphicsscene.cpp:1190
#12 0xb6a11218 in QGraphicsScenePrivate::sendMouseEvent (this=0x8152758, mouseEvent=0xbff8b1f4) at graphicsview/qgraphicsscene.cpp:1264
#13 0xb6a11d93 in QGraphicsScene::mouseMoveEvent (this=0x8150f28, mouseEvent=0xbff8b1f4) at graphicsview/qgraphicsscene.cpp:4046
#14 0xb6a25937 in QGraphicsScene::event (this=0x8150f28, event=0xbff8b1f4) at graphicsview/qgraphicsscene.cpp:3400
#15 0xb6398c64 in QApplicationPrivate::notify_helper (this=0x80a3d40, receiver=0x8150f28, e=0xbff8b1f4) at kernel/qapplication.cpp:4302
#16 0xb63a0bf7 in QApplication::notify (this=0x809abb0, receiver=0x8150f28, e=0xbff8b1f4) at kernel/qapplication.cpp:3706
#17 0xb747e911 in KApplication::notify (this=0x809abb0, receiver=0x8150f28, event=0xbff8b1f4) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#18 0xb6e5fe0e in QCoreApplication::notifyInternal (this=0x809abb0, receiver=0x8150f28, event=0xbff8b1f4) at kernel/qcoreapplication.cpp:726
#19 0xb63963bd in sendSpontaneousEvent (receiver=0x8150f28, event=0xbff8b1f4) at ../../src/corelib/kernel/qcoreapplication.h:218
#20 qt_sendSpontaneousEvent (receiver=0x8150f28, event=0xbff8b1f4) at kernel/qapplication.cpp:5281
#21 0xb6a3b482 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xad31330, event=0xbff8ba14) at graphicsview/qgraphicsview.cpp:645
#22 0xb6a3e7fe in QGraphicsView::mouseMoveEvent (this=0xab84c68, event=0xbff8ba14) at graphicsview/qgraphicsview.cpp:3197
#23 0xb63f1f3c in QWidget::event (this=0xab84c68, event=0xbff8ba14) at kernel/qwidget.cpp:8029
#24 0xb67eb765 in QFrame::event (this=0xab84c68, e=0xbff8ba14) at widgets/qframe.cpp:557
#25 0xb6879e01 in QAbstractScrollArea::viewportEvent (this=0xab84c68, e=0xbff8ba14) at widgets/qabstractscrollarea.cpp:1036
#26 0xb6a42c8c in QGraphicsView::viewportEvent (this=0xab84c68, event=0xbff8ba14) at graphicsview/qgraphicsview.cpp:2787
#27 0xb687c776 in viewportEvent (this=0xa964010, o=0xad0bde0, e=0xbff8ba14) at widgets/qabstractscrollarea_p.h:100
#28 QAbstractScrollAreaFilter::eventFilter (this=0xa964010, o=0xad0bde0, e=0xbff8ba14) at widgets/qabstractscrollarea_p.h:116
#29 0xb6e5ffa6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80a3d40, receiver=0xad0bde0, event=0xbff8ba14) at kernel/qcoreapplication.cpp:841
#30 0xb6398c34 in QApplicationPrivate::notify_helper (this=0x80a3d40, receiver=0xad0bde0, e=0xbff8ba14) at kernel/qapplication.cpp:4298
#31 0xb63a1750 in QApplication::notify (this=0xbff8b72c, receiver=0xad0bde0, e=0xbff8ba14) at kernel/qapplication.cpp:3867
#32 0xb747e911 in KApplication::notify (this=0x809abb0, receiver=0xad0bde0, event=0xbff8ba14) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#33 0xb6e5fe0e in QCoreApplication::notifyInternal (this=0x809abb0, receiver=0xad0bde0, event=0xbff8ba14) at kernel/qcoreapplication.cpp:726
#34 0xb6399c4c in sendSpontaneousEvent (receiver=0xad0bde0, event=0xbff8ba14, alienWidget=0xad0bde0, nativeWidget=0xab9eb70, buttonDown=0xb6ce3078, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:218
#35 QApplicationPrivate::sendMouseEvent (receiver=0xad0bde0, event=0xbff8ba14, alienWidget=0xad0bde0, nativeWidget=0xab9eb70, buttonDown=0xb6ce3078, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#36 0xb642158c in QETWidget::translateMouseEvent (this=0xab9eb70, event=0xbff8bf2c) at kernel/qapplication_x11.cpp:4380
#37 0xb642073e in QApplication::x11ProcessEvent (this=0x809abb0, event=0xbff8bf2c) at kernel/qapplication_x11.cpp:3391
#38 0xb6449570 in x11EventSourceDispatch (s=0x80a6ee8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0xb5be6b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#40 0xb5be7350 in ?? () from /usr/lib/libglib-2.0.so.0
#41 0xb5be760e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#42 0xb6e8bd4b in QEventDispatcherGlib::processEvents (this=0x80a3b28, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#43 0xb644919a in QGuiEventDispatcherGlib::processEvents (this=0x80a3b28, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb6e5f11d in QEventLoop::processEvents (this=0xaa0bef0, flags=...) at kernel/qeventloop.cpp:149
#45 0xb6e5f319 in QEventLoop::exec (this=0xaa0bef0, flags=...) at kernel/qeventloop.cpp:201
#46 0xb642f3ce in QDragManager::drag (this=0x93e99f0, o=0x80d51f0) at kernel/qdnd_x11.cpp:1960
#47 0xb63ab291 in QDrag::exec (this=0x80d51f0, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:282
#48 0xb63ab335 in QDrag::exec (this=0x80d51f0, supportedActions=...) at kernel/qdrag.cpp:239
#49 0xb2c89c5d in Plasma::AbstractIcon::mouseMoveEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/libplasmagenericshell.so.4
#50 0xb69ec916 in QGraphicsItem::sceneEvent (this=0xa8cdad0, event=0xbff8cb24) at graphicsview/qgraphicsitem.cpp:6539
#51 0xb6a44856 in QGraphicsWidget::sceneEvent (this=0xa8cdac8, event=0xbff8cb24) at graphicsview/qgraphicswidget.cpp:1123
#52 0xb6a1054e in QGraphicsScenePrivate::sendEvent (this=0x8152758, item=0xa8cdad0, event=0xbff8cb24) at graphicsview/qgraphicsscene.cpp:1190
#53 0xb6a11218 in QGraphicsScenePrivate::sendMouseEvent (this=0x8152758, mouseEvent=0xbff8cb24) at graphicsview/qgraphicsscene.cpp:1264
#54 0xb6a11d93 in QGraphicsScene::mouseMoveEvent (this=0x8150f28, mouseEvent=0xbff8cb24) at graphicsview/qgraphicsscene.cpp:4046
#55 0xb6a25937 in QGraphicsScene::event (this=0x8150f28, event=0xbff8cb24) at graphicsview/qgraphicsscene.cpp:3400
#56 0xb6398c64 in QApplicationPrivate::notify_helper (this=0x80a3d40, receiver=0x8150f28, e=0xbff8cb24) at kernel/qapplication.cpp:4302
#57 0xb63a0bf7 in QApplication::notify (this=0x809abb0, receiver=0x8150f28, e=0xbff8cb24) at kernel/qapplication.cpp:3706
#58 0xb747e911 in KApplication::notify (this=0x809abb0, receiver=0x8150f28, event=0xbff8cb24) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#59 0xb6e5fe0e in QCoreApplication::notifyInternal (this=0x809abb0, receiver=0x8150f28, event=0xbff8cb24) at kernel/qcoreapplication.cpp:726
#60 0xb63963bd in sendSpontaneousEvent (receiver=0x8150f28, event=0xbff8cb24) at ../../src/corelib/kernel/qcoreapplication.h:218
#61 qt_sendSpontaneousEvent (receiver=0x8150f28, event=0xbff8cb24) at kernel/qapplication.cpp:5281
#62 0xb6a3b482 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xab38f68, event=0xbff8d344) at graphicsview/qgraphicsview.cpp:645
#63 0xb6a3e7fe in QGraphicsView::mouseMoveEvent (this=0xa7e43a8, event=0xbff8d344) at graphicsview/qgraphicsview.cpp:3197
#64 0xb63f1f3c in QWidget::event (this=0xa7e43a8, event=0xbff8d344) at kernel/qwidget.cpp:8029
#65 0xb67eb765 in QFrame::event (this=0xa7e43a8, e=0xbff8d344) at widgets/qframe.cpp:557
#66 0xb6879e01 in QAbstractScrollArea::viewportEvent (this=0xa7e43a8, e=0xbff8d344) at widgets/qabstractscrollarea.cpp:1036
#67 0xb6a42c8c in QGraphicsView::viewportEvent (this=0xa7e43a8, event=0xbff8d344) at graphicsview/qgraphicsview.cpp:2787
#68 0xb687c776 in viewportEvent (this=0xab3aab0, o=0xab2d270, e=0xbff8d344) at widgets/qabstractscrollarea_p.h:100
#69 QAbstractScrollAreaFilter::eventFilter (this=0xab3aab0, o=0xab2d270, e=0xbff8d344) at widgets/qabstractscrollarea_p.h:116
#70 0xb6e5ffa6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80a3d40, receiver=0xab2d270, event=0xbff8d344) at kernel/qcoreapplication.cpp:841
#71 0xb6398c34 in QApplicationPrivate::notify_helper (this=0x80a3d40, receiver=0xab2d270, e=0xbff8d344) at kernel/qapplication.cpp:4298
#72 0xb63a1750 in QApplication::notify (this=0xbff8d05c, receiver=0xab2d270, e=0xbff8d344) at kernel/qapplication.cpp:3867
#73 0xb747e911 in KApplication::notify (this=0x809abb0, receiver=0xab2d270, event=0xbff8d344) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#74 0xb6e5fe0e in QCoreApplication::notifyInternal (this=0x809abb0, receiver=0xab2d270, event=0xbff8d344) at kernel/qcoreapplication.cpp:726
#75 0xb6399c4c in sendSpontaneousEvent (receiver=0xab2d270, event=0xbff8d344, alienWidget=0xab2d270, nativeWidget=0x91ba6d0, buttonDown=0xb6ce3078, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:218
#76 QApplicationPrivate::sendMouseEvent (receiver=0xab2d270, event=0xbff8d344, alienWidget=0xab2d270, nativeWidget=0x91ba6d0, buttonDown=0xb6ce3078, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#77 0xb642158c in QETWidget::translateMouseEvent (this=0x91ba6d0, event=0xbff8d85c) at kernel/qapplication_x11.cpp:4380
#78 0xb642073e in QApplication::x11ProcessEvent (this=0x809abb0, event=0xbff8d85c) at kernel/qapplication_x11.cpp:3391
#79 0xb6449570 in x11EventSourceDispatch (s=0x80a6ee8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#80 0xb5be6b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#81 0xb5be7350 in ?? () from /usr/lib/libglib-2.0.so.0
#82 0xb5be760e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#83 0xb6e8bd4b in QEventDispatcherGlib::processEvents (this=0x80a3b28, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#84 0xb644919a in QGuiEventDispatcherGlib::processEvents (this=0x80a3b28, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#85 0xb6e5f11d in QEventLoop::processEvents (this=0xbff8db14, flags=...) at kernel/qeventloop.cpp:149
#86 0xb6e5f319 in QEventLoop::exec (this=0xbff8db14, flags=...) at kernel/qeventloop.cpp:201
#87 0xb6e63c70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#88 0xb6396164 in QApplication::exec () at kernel/qapplication.cpp:3581
#89 0xb2d725ed in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#90 0x0804e3f1 in _start ()

Reported using DrKonqi
Comment 1 mossad 2010-12-07 11:52:10 UTC
Created attachment 54235 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.5.80 (4.6 Beta1) using Qt 4.7.0

Few seconds after moving "Easy SSH widget" to the desktop Plasma just crashed.

-- Backtrace (Reduced):
#7  0x018e35bf in QGraphicsItem::setCursor (this=0xb0b29b8, cursor=...) at graphicsview/qgraphicsitem.cpp:2132
#8  0x006b6303 in Plasma::AbstractIcon::mouseMoveEvent(QGraphicsSceneMouseEvent*) () from /usr/lib/libplasmagenericshell.so.4
#9  0x018f0210 in QGraphicsItem::sceneEvent (this=0xb0b29b8, event=0xbfc44d04) at graphicsview/qgraphicsitem.cpp:6663
#10 0x019474d7 in QGraphicsWidget::sceneEvent (this=0xb0b29b0, event=0xbfc44d04) at graphicsview/qgraphicswidget.cpp:1173
#11 0x01908569 in QGraphicsScenePrivate::sendEvent (this=0x9686818, item=0xb0b29b8, event=0xbfc44d04) at graphicsview/qgraphicsscene.cpp:1211
Comment 2 Dario Andres 2011-01-01 15:43:24 UTC
[Comment from a bug triager]
This issue is now being tracked at bug 259156. Merging. Thanks

*** This bug has been marked as a duplicate of bug 259156 ***