Bug 259156 - Crash when adding a widget to the desktop/panel (d&d) [Qt, QGraphicsItem::setCursor, Plasma::AbstractIcon::mouseMoveEvent, QGraphicsItem::sceneEvent, (from Plasma::AbstractIcon::mouseMoveEvent drag event loop)]
Summary: Crash when adding a widget to the desktop/panel (d&d) [Qt, QGraphicsItem::set...
Status: RESOLVED DUPLICATE of bug 263824
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 253552 260956 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-07 19:12 UTC by eric.maniscalco
Modified: 2011-09-29 12:41 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eric.maniscalco 2010-12-07 19:12:37 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.9-64.fc14.i686 i686

-- Information about the crash:
Try to install plasmoïdes to my second tool bar. KDE crash and restart after few seconds.

-- Backtrace:
Application: Espace de travail Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78309b0 (LWP 1562))]

Thread 2 (Thread 0xaefffb70 (LWP 2244)):
#0  0x00fe2416 in __kernel_vsyscall ()
#1  0x008af98b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x06b5e057 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib/libQtWebKit.so.4
#3  0x008aaf19 in start_thread () from /lib/libpthread.so.0
#4  0x007e4c5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb78309b0 (LWP 1562)):
[KCrash Handler]
#7  size (this=0x972f190, cursor=...) at ../../src/corelib/tools/qlist.h:94
#8  size (this=0x972f190, cursor=...) at ../../src/corelib/tools/qlist.h:124
#9  setExtra (this=0x972f190, cursor=...) at graphicsview/qgraphicsitem_p.h:339
#10 QGraphicsItem::setCursor (this=0x972f190, cursor=...) at graphicsview/qgraphicsitem.cpp:2156
#11 0x04907905 in Plasma::AbstractIcon::mouseMoveEvent (this=0x972f188, event=0xbfc76254) at /usr/src/debug/kdebase-workspace-4.5.3/libs/plasmagenericshell/abstracticon.cpp:142
#12 0x03280d26 in QGraphicsItem::sceneEvent (this=0x972f190, event=0xbfc76254) at graphicsview/qgraphicsitem.cpp:6695
#13 0x032dd608 in QGraphicsWidget::sceneEvent (this=0x972f188, event=0xbfc76254) at graphicsview/qgraphicswidget.cpp:1175
#14 0x032aa810 in QGraphicsScenePrivate::sendEvent (this=0x88de3a8, item=0x972f190, event=0xbfc76254) at graphicsview/qgraphicsscene.cpp:1207
#15 0x032ab49d in QGraphicsScenePrivate::sendMouseEvent (this=0x88de3a8, mouseEvent=0xbfc76254) at graphicsview/qgraphicsscene.cpp:1281
#16 0x032ac09e in QGraphicsScene::mouseMoveEvent (this=0x8840600, mouseEvent=0xbfc76254) at graphicsview/qgraphicsscene.cpp:4081
#17 0x032be895 in QGraphicsScene::event (this=0x8840600, event=0xbfc76254) at graphicsview/qgraphicsscene.cpp:3433
#18 0x02c3026c in QApplicationPrivate::notify_helper (this=0x884a388, receiver=0x8840600, e=0xbfc76254) at kernel/qapplication.cpp:4445
#19 0x02c34ed2 in QApplication::notify (this=0x883e6a0, receiver=0x8840600, e=0xbfc76254) at kernel/qapplication.cpp:3845
#20 0x0376ee3b in KApplication::notify (this=0x883e6a0, receiver=0x8840600, event=0xbfc76254) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#21 0x025cd333 in QCoreApplication::notifyInternal (this=0x883e6a0, receiver=0x8840600, event=0xbfc76254) at kernel/qcoreapplication.cpp:732
#22 0x02c2e2cf in sendSpontaneousEvent (receiver=0x8840600, event=0xbfc76254) at ../../src/corelib/kernel/qcoreapplication.h:218
#23 qt_sendSpontaneousEvent (receiver=0x8840600, event=0xbfc76254) at kernel/qapplication.cpp:5439
#24 0x032d733a in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x934ef98, event=0xbfc76aa4) at graphicsview/qgraphicsview.cpp:647
#25 0x032d7577 in QGraphicsView::mouseMoveEvent (this=0x970d508, event=0xbfc76aa4) at graphicsview/qgraphicsview.cpp:3274
#26 0x02c89893 in QWidget::event (this=0x970d508, event=0xbfc76aa4) at kernel/qwidget.cpp:8185
#27 0x030870d4 in QFrame::event (this=0x970d508, e=0xbfc76aa4) at widgets/qframe.cpp:557
#28 0x03116f93 in QAbstractScrollArea::viewportEvent (this=0x970d508, e=0xbfc76aa4) at widgets/qabstractscrollarea.cpp:1043
#29 0x032dbd47 in QGraphicsView::viewportEvent (this=0x970d508, event=0xbfc76aa4) at graphicsview/qgraphicsview.cpp:2864
#30 0x03119905 in viewportEvent (this=0x9852a50, o=0x9852450, e=0xbfc76aa4) at widgets/qabstractscrollarea_p.h:100
#31 QAbstractScrollAreaFilter::eventFilter (this=0x9852a50, o=0x9852450, e=0xbfc76aa4) at widgets/qabstractscrollarea_p.h:116
#32 0x025cd4ea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x884a388, receiver=0x9852450, event=0xbfc76aa4) at kernel/qcoreapplication.cpp:847
#33 0x02c30241 in QApplicationPrivate::notify_helper (this=0x884a388, receiver=0x9852450, e=0xbfc76aa4) at kernel/qapplication.cpp:4441
#34 0x02c3588d in QApplication::notify (this=0x883e6a0, receiver=0x9852450, e=0xbfc76aa4) at kernel/qapplication.cpp:4006
#35 0x0376ee3b in KApplication::notify (this=0x883e6a0, receiver=0x9852450, event=0xbfc76aa4) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#36 0x025cd333 in QCoreApplication::notifyInternal (this=0x883e6a0, receiver=0x9852450, event=0xbfc76aa4) at kernel/qcoreapplication.cpp:732
#37 0x02c311f8 in sendSpontaneousEvent (receiver=0x9852450, event=0xbfc76aa4, alienWidget=0x9852450, nativeWidget=0x968d2c0, buttonDown=0x358ec80, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QApplicationPrivate::sendMouseEvent (receiver=0x9852450, event=0xbfc76aa4, alienWidget=0x9852450, nativeWidget=0x968d2c0, buttonDown=0x358ec80, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#39 0x02cba524 in QETWidget::translateMouseEvent (this=0x968d2c0, event=0xbfc76fcc) at kernel/qapplication_x11.cpp:4438
#40 0x02cb8957 in QApplication::x11ProcessEvent (this=0x883e6a0, event=0xbfc76fcc) at kernel/qapplication_x11.cpp:3564
#41 0x02ce3832 in x11EventSourceDispatch (s=0x884d568, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#42 0x009ae192 in g_main_dispatch (context=0x884c690) at gmain.c:2149
#43 g_main_context_dispatch (context=0x884c690) at gmain.c:2702
#44 0x009ae978 in g_main_context_iterate (context=0x884c690, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#45 0x009aec35 in g_main_context_iteration (context=0x884c690, may_block=1) at gmain.c:2843
#46 0x025fb02d in QEventDispatcherGlib::processEvents (this=0x88289d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#47 0x02ce3406 in QGuiEventDispatcherGlib::processEvents (this=0x88289d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x025cc4ca in QEventLoop::processEvents (this=0xbfc772a4, flags=...) at kernel/qeventloop.cpp:149
#49 0x025cc77a in QEventLoop::exec (this=0xbfc772a4, flags=...) at kernel/qeventloop.cpp:201
#50 0x025d1327 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#51 0x02c2e078 in QApplication::exec () at kernel/qapplication.cpp:3719
#52 0x04829dc1 in kdemain (argc=1, argv=0xbfc774c4) at /usr/src/debug/kdebase-workspace-4.5.3/plasma/desktop/shell/main.cpp:118
#53 0x080487cc in main (argc=1, argv=0xbfc774c4) at /usr/src/debug/kdebase-workspace-4.5.3/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Beat Wolf 2010-12-25 12:53:49 UTC
*** Bug 260956 has been marked as a duplicate of this bug. ***
Comment 2 OsamaK 2010-12-25 15:17:04 UTC
It seems that this bug is still isn't fixed in whatever upstream it is in. Where should I report it?
Comment 3 Dario Andres 2011-01-01 15:43:17 UTC
[Comment from a bug triager]
From bug 253552:
-- Information about the crash:
I was trying to move blackboard widget to desktop from the widget explorer. The
explorer stuck, and subsequently lwin crashed. openSUSE 11.3 with KDE 4.5.2

From bug 253552 comment 1:
-- Information about the crash:
Few seconds after moving "Easy SSH widget" to the desktop Plasma just crashed.
Comment 4 Dario Andres 2011-01-01 15:43:24 UTC
*** Bug 253552 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2011-01-01 15:44:25 UTC
[Comment from a bug triager]
The upstream Qt bugs can be reported at http://bugreports.qt.nokia.com/secure/Dashboard.jspa ; however they won't accept reports without simple testcases (without Plasma code)
Comment 6 Dario Andres 2011-09-29 12:41:34 UTC
[Comment from a bug report cleaner]
It seems this was fixed on the KDE side: bug 263824 (fixed for KDE SC 4.6.x). Merging now

*** This bug has been marked as a duplicate of bug 263824 ***