Bug 260956 - Crash on adding System Tray
Summary: Crash on adding System Tray
Status: RESOLVED DUPLICATE of bug 259156
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-22 11:50 UTC by OsamaK
Modified: 2010-12-25 12:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OsamaK 2010-12-22 11:50:22 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.9-libre.64.fc14.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: This crash happened when I tried to readd the System Tray widget shortly after startup.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb789e9b0 (LWP 1741))]

Thread 2 (Thread 0xb04a4b70 (LWP 1745)):
#0  0x00c72416 in __kernel_vsyscall ()
#1  0x005bf7a1 in select () from /lib/libc.so.6
#2  0x0509d2e2 in QProcessManager::run (this=0x51fadb0) at io/qprocess_unix.cpp:245
#3  0x04fc5e6a in QThreadPrivate::start (arg=0x51fadb0) at thread/qthread_unix.cpp:285
#4  0x0068df19 in start_thread () from /lib/libpthread.so.0
#5  0x005c7c4e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb789e9b0 (LWP 1741)):
[KCrash Handler]
#7  size (this=0x9c67200, cursor=...) at ../../src/corelib/tools/qlist.h:94
#8  size (this=0x9c67200, cursor=...) at ../../src/corelib/tools/qlist.h:124
#9  setExtra (this=0x9c67200, cursor=...) at graphicsview/qgraphicsitem_p.h:339
#10 QGraphicsItem::setCursor (this=0x9c67200, cursor=...) at graphicsview/qgraphicsitem.cpp:2156
#11 0x074b6905 in Plasma::AbstractIcon::mouseMoveEvent (this=0x9c671f8, event=0xbf85a124) at /usr/src/debug/kdebase-workspace-4.5.4/libs/plasmagenericshell/abstracticon.cpp:142
#12 0x05ebfdf6 in QGraphicsItem::sceneEvent (this=0x9c67200, event=0xbf85a124) at graphicsview/qgraphicsitem.cpp:6695
#13 0x05f1c6d8 in QGraphicsWidget::sceneEvent (this=0x9c671f8, event=0xbf85a124) at graphicsview/qgraphicswidget.cpp:1175
#14 0x05ee98e0 in QGraphicsScenePrivate::sendEvent (this=0x9866d98, item=0x9c67200, event=0xbf85a124) at graphicsview/qgraphicsscene.cpp:1207
#15 0x05eea56d in QGraphicsScenePrivate::sendMouseEvent (this=0x9866d98, mouseEvent=0xbf85a124) at graphicsview/qgraphicsscene.cpp:1281
#16 0x05eeb16e in QGraphicsScene::mouseMoveEvent (this=0x9861200, mouseEvent=0xbf85a124) at graphicsview/qgraphicsscene.cpp:4081
#17 0x05efd965 in QGraphicsScene::event (this=0x9861200, event=0xbf85a124) at graphicsview/qgraphicsscene.cpp:3433
#18 0x0586f26c in QApplicationPrivate::notify_helper (this=0x97c9550, receiver=0x9861200, e=0xbf85a124) at kernel/qapplication.cpp:4445
#19 0x05873ed2 in QApplication::notify (this=0x97bd2e8, receiver=0x9861200, e=0xbf85a124) at kernel/qapplication.cpp:3845
#20 0x063adf7b in KApplication::notify (this=0x97bd2e8, receiver=0x9861200, event=0xbf85a124) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#21 0x050bd333 in QCoreApplication::notifyInternal (this=0x97bd2e8, receiver=0x9861200, event=0xbf85a124) at kernel/qcoreapplication.cpp:732
#22 0x0586d2cf in sendSpontaneousEvent (receiver=0x9861200, event=0xbf85a124) at ../../src/corelib/kernel/qcoreapplication.h:218
#23 qt_sendSpontaneousEvent (receiver=0x9861200, event=0xbf85a124) at kernel/qapplication.cpp:5439
#24 0x05f1640a in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xa151450, event=0xbf85a974) at graphicsview/qgraphicsview.cpp:647
#25 0x05f16647 in QGraphicsView::mouseMoveEvent (this=0x9bdeef0, event=0xbf85a974) at graphicsview/qgraphicsview.cpp:3274
#26 0x058c8893 in QWidget::event (this=0x9bdeef0, event=0xbf85a974) at kernel/qwidget.cpp:8185
#27 0x05cc61a4 in QFrame::event (this=0x9bdeef0, e=0xbf85a974) at widgets/qframe.cpp:557
#28 0x05d56063 in QAbstractScrollArea::viewportEvent (this=0x9bdeef0, e=0xbf85a974) at widgets/qabstractscrollarea.cpp:1043
#29 0x05f1ae17 in QGraphicsView::viewportEvent (this=0x9bdeef0, event=0xbf85a974) at graphicsview/qgraphicsview.cpp:2864
#30 0x05d589d5 in viewportEvent (this=0xa450ef8, o=0x9b919a0, e=0xbf85a974) at widgets/qabstractscrollarea_p.h:100
#31 QAbstractScrollAreaFilter::eventFilter (this=0xa450ef8, o=0x9b919a0, e=0xbf85a974) at widgets/qabstractscrollarea_p.h:116
#32 0x050bd4ea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97c9550, receiver=0x9b919a0, event=0xbf85a974) at kernel/qcoreapplication.cpp:847
#33 0x0586f241 in QApplicationPrivate::notify_helper (this=0x97c9550, receiver=0x9b919a0, e=0xbf85a974) at kernel/qapplication.cpp:4441
#34 0x0587488d in QApplication::notify (this=0x97bd2e8, receiver=0x9b919a0, e=0xbf85a974) at kernel/qapplication.cpp:4006
#35 0x063adf7b in KApplication::notify (this=0x97bd2e8, receiver=0x9b919a0, event=0xbf85a974) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#36 0x050bd333 in QCoreApplication::notifyInternal (this=0x97bd2e8, receiver=0x9b919a0, event=0xbf85a974) at kernel/qcoreapplication.cpp:732
#37 0x058701f8 in sendSpontaneousEvent (receiver=0x9b919a0, event=0xbf85a974, alienWidget=0x9b919a0, nativeWidget=0xa434b88, buttonDown=0x61cdc80, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#38 QApplicationPrivate::sendMouseEvent (receiver=0x9b919a0, event=0xbf85a974, alienWidget=0x9b919a0, nativeWidget=0xa434b88, buttonDown=0x61cdc80, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#39 0x058f9524 in QETWidget::translateMouseEvent (this=0xa434b88, event=0xbf85aeac) at kernel/qapplication_x11.cpp:4438
#40 0x058f7957 in QApplication::x11ProcessEvent (this=0x97bd2e8, event=0xbf85aeac) at kernel/qapplication_x11.cpp:3564
#41 0x05922790 in x11EventSourceDispatch (s=0x97cc740, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#42 0x00e3d192 in g_main_dispatch (context=0x97cb890) at gmain.c:2149
#43 g_main_context_dispatch (context=0x97cb890) at gmain.c:2702
#44 0x00e3d978 in g_main_context_iterate (context=0x97cb890, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#45 0x00e3dc35 in g_main_context_iteration (context=0x97cb890, may_block=1) at gmain.c:2843
#46 0x050eb02d in QEventDispatcherGlib::processEvents (this=0x97a7a78, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#47 0x05922406 in QGuiEventDispatcherGlib::processEvents (this=0x97a7a78, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#48 0x050bc4ca in QEventLoop::processEvents (this=0x9a5aa50, flags=...) at kernel/qeventloop.cpp:149
#49 0x050bc77a in QEventLoop::exec (this=0x9a5aa50, flags=...) at kernel/qeventloop.cpp:201
#50 0x059085e9 in QDragManager::drag (this=0xa245f70, o=0x9bb9b50) at kernel/qdnd_x11.cpp:1981
#51 0x0588268f in QDrag::exec (this=0x9bb9b50, supportedActions=..., defaultDropAction=Qt::IgnoreAction) at kernel/qdrag.cpp:284
#52 0x05882745 in QDrag::exec (this=0x9bb9b50, supportedActions=...) at kernel/qdrag.cpp:239
#53 0x074b68e9 in Plasma::AbstractIcon::mouseMoveEvent (this=0x9d200c0, event=0xbf85bb14) at /usr/src/debug/kdebase-workspace-4.5.4/libs/plasmagenericshell/abstracticon.cpp:140
#54 0x05ebfdf6 in QGraphicsItem::sceneEvent (this=0x9d200c8, event=0xbf85bb14) at graphicsview/qgraphicsitem.cpp:6695
#55 0x05f1c6d8 in QGraphicsWidget::sceneEvent (this=0x9d200c0, event=0xbf85bb14) at graphicsview/qgraphicswidget.cpp:1175
#56 0x05ee98e0 in QGraphicsScenePrivate::sendEvent (this=0x9866d98, item=0x9d200c8, event=0xbf85bb14) at graphicsview/qgraphicsscene.cpp:1207
#57 0x05eea56d in QGraphicsScenePrivate::sendMouseEvent (this=0x9866d98, mouseEvent=0xbf85bb14) at graphicsview/qgraphicsscene.cpp:1281
#58 0x05eeb16e in QGraphicsScene::mouseMoveEvent (this=0x9861200, mouseEvent=0xbf85bb14) at graphicsview/qgraphicsscene.cpp:4081
#59 0x05efd965 in QGraphicsScene::event (this=0x9861200, event=0xbf85bb14) at graphicsview/qgraphicsscene.cpp:3433
#60 0x0586f26c in QApplicationPrivate::notify_helper (this=0x97c9550, receiver=0x9861200, e=0xbf85bb14) at kernel/qapplication.cpp:4445
#61 0x05873ed2 in QApplication::notify (this=0x97bd2e8, receiver=0x9861200, e=0xbf85bb14) at kernel/qapplication.cpp:3845
#62 0x063adf7b in KApplication::notify (this=0x97bd2e8, receiver=0x9861200, event=0xbf85bb14) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#63 0x050bd333 in QCoreApplication::notifyInternal (this=0x97bd2e8, receiver=0x9861200, event=0xbf85bb14) at kernel/qcoreapplication.cpp:732
#64 0x0586d2cf in sendSpontaneousEvent (receiver=0x9861200, event=0xbf85bb14) at ../../src/corelib/kernel/qcoreapplication.h:218
#65 qt_sendSpontaneousEvent (receiver=0x9861200, event=0xbf85bb14) at kernel/qapplication.cpp:5439
#66 0x05f1640a in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9a236f8, event=0xbf85c364) at graphicsview/qgraphicsview.cpp:647
#67 0x05f16647 in QGraphicsView::mouseMoveEvent (this=0x9a1b630, event=0xbf85c364) at graphicsview/qgraphicsview.cpp:3274
#68 0x058c8893 in QWidget::event (this=0x9a1b630, event=0xbf85c364) at kernel/qwidget.cpp:8185
#69 0x05cc61a4 in QFrame::event (this=0x9a1b630, e=0xbf85c364) at widgets/qframe.cpp:557
#70 0x05d56063 in QAbstractScrollArea::viewportEvent (this=0x9a1b630, e=0xbf85c364) at widgets/qabstractscrollarea.cpp:1043
#71 0x05f1ae17 in QGraphicsView::viewportEvent (this=0x9a1b630, event=0xbf85c364) at graphicsview/qgraphicsview.cpp:2864
#72 0x05d589d5 in viewportEvent (this=0x9b230b0, o=0x9c90728, e=0xbf85c364) at widgets/qabstractscrollarea_p.h:100
#73 QAbstractScrollAreaFilter::eventFilter (this=0x9b230b0, o=0x9c90728, e=0xbf85c364) at widgets/qabstractscrollarea_p.h:116
#74 0x050bd4ea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97c9550, receiver=0x9c90728, event=0xbf85c364) at kernel/qcoreapplication.cpp:847
#75 0x0586f241 in QApplicationPrivate::notify_helper (this=0x97c9550, receiver=0x9c90728, e=0xbf85c364) at kernel/qapplication.cpp:4441
#76 0x0587488d in QApplication::notify (this=0x97bd2e8, receiver=0x9c90728, e=0xbf85c364) at kernel/qapplication.cpp:4006
#77 0x063adf7b in KApplication::notify (this=0x97bd2e8, receiver=0x9c90728, event=0xbf85c364) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#78 0x050bd333 in QCoreApplication::notifyInternal (this=0x97bd2e8, receiver=0x9c90728, event=0xbf85c364) at kernel/qcoreapplication.cpp:732
#79 0x058701f8 in sendSpontaneousEvent (receiver=0x9c90728, event=0xbf85c364, alienWidget=0x9c90728, nativeWidget=0x9be7e90, buttonDown=0x61cdc80, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#80 QApplicationPrivate::sendMouseEvent (receiver=0x9c90728, event=0xbf85c364, alienWidget=0x9c90728, nativeWidget=0x9be7e90, buttonDown=0x61cdc80, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#81 0x058f9524 in QETWidget::translateMouseEvent (this=0x9be7e90, event=0xbf85c89c) at kernel/qapplication_x11.cpp:4438
#82 0x058f7957 in QApplication::x11ProcessEvent (this=0x97bd2e8, event=0xbf85c89c) at kernel/qapplication_x11.cpp:3564
#83 0x05922790 in x11EventSourceDispatch (s=0x97cc740, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#84 0x00e3d192 in g_main_dispatch (context=0x97cb890) at gmain.c:2149
#85 g_main_context_dispatch (context=0x97cb890) at gmain.c:2702
#86 0x00e3d978 in g_main_context_iterate (context=0x97cb890, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#87 0x00e3dc35 in g_main_context_iteration (context=0x97cb890, may_block=1) at gmain.c:2843
#88 0x050eb02d in QEventDispatcherGlib::processEvents (this=0x97a7a78, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#89 0x05922406 in QGuiEventDispatcherGlib::processEvents (this=0x97a7a78, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#90 0x050bc4ca in QEventLoop::processEvents (this=0xbf85cb74, flags=...) at kernel/qeventloop.cpp:149
#91 0x050bc77a in QEventLoop::exec (this=0xbf85cb74, flags=...) at kernel/qeventloop.cpp:201
#92 0x050c1327 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#93 0x0586d078 in QApplication::exec () at kernel/qapplication.cpp:3719
#94 0x07523e21 in kdemain (argc=1, argv=0xbf85cd94) at /usr/src/debug/kdebase-workspace-4.5.4/plasma/desktop/shell/main.cpp:118
#95 0x080487cc in main (argc=1, argv=0xbf85cd94) at /usr/src/debug/kdebase-workspace-4.5.4/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 259156.

Possible duplicates by query: bug 259156.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-12-25 12:53:49 UTC

*** This bug has been marked as a duplicate of bug 259156 ***