Bug 263824 - Adding lots of widgets in an empty panel [QGraphicsItem::setCursor, Plasma::AbstractIcon::mouseMoveEvent]
Summary: Adding lots of widgets in an empty panel [QGraphicsItem::setCursor, Plasma::A...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 259156 282924 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-21 08:49 UTC by vikram goyal
Modified: 2011-09-29 12:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6


Attachments
tarred bzip of dot kde dir (78.33 KB, application/x-bzip-compressed-tar)
2011-01-21 09:04 UTC, vikram goyal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vikram goyal 2011-01-21 08:49:11 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.10-74.fc14.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
I added lots of widgets in an empty panel. Last one was XBar.  
I will add my kde setting as an attachment

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77339b0 (LWP 2391))]

Thread 4 (Thread 0xae6ffb70 (LWP 2786)):
#0  0x007db416 in __kernel_vsyscall ()
#1  0x00c00b06 in poll () from /lib/libc.so.6
#2  0x00151dac in g_poll (fds=0xadd01b00, nfds=1, timeout=-1) at gpoll.c:132
#3  0x001418b7 in g_main_context_poll (context=0xadd01800, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3093
#4  g_main_context_iterate (context=0xadd01800, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
#5  0x00141c35 in g_main_context_iteration (context=0xadd01800, may_block=1) at gmain.c:2843
#6  0x05443067 in QEventDispatcherGlib::processEvents (this=0xadd02688, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x054144ca in QEventLoop::processEvents (this=0xae6ff220, flags=...) at kernel/qeventloop.cpp:149
#8  0x0541477a in QEventLoop::exec (this=0xae6ff220, flags=...) at kernel/qeventloop.cpp:201
#9  0x0531b36b in QThread::exec (this=0xb1bdde8) at thread/qthread.cpp:490
#10 0x053f5b4c in QInotifyFileSystemWatcherEngine::run (this=0xb1bdde8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0531de6a in QThreadPrivate::start (arg=0xb1bdde8) at thread/qthread_unix.cpp:285
#12 0x00cd1f19 in start_thread () from /lib/libpthread.so.0
#13 0x00c0bc4e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xad222b70 (LWP 2795)):
#0  0x007db416 in __kernel_vsyscall ()
#1  0x00c00b06 in poll () from /lib/libc.so.6
#2  0x00151dac in g_poll (fds=0xac900ae8, nfds=1, timeout=-1) at gpoll.c:132
#3  0x001418b7 in g_main_context_poll (context=0xac900478, block=1, dispatch=1, self=<value optimized out>) at gmain.c:3093
#4  g_main_context_iterate (context=0xac900478, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2775
#5  0x00141c35 in g_main_context_iteration (context=0xac900478, may_block=1) at gmain.c:2843
#6  0x05443067 in QEventDispatcherGlib::processEvents (this=0xac900468, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#7  0x054144ca in QEventLoop::processEvents (this=0xad222220, flags=...) at kernel/qeventloop.cpp:149
#8  0x0541477a in QEventLoop::exec (this=0xad222220, flags=...) at kernel/qeventloop.cpp:201
#9  0x0531b36b in QThread::exec (this=0xb759db8) at thread/qthread.cpp:490
#10 0x053f5b4c in QInotifyFileSystemWatcherEngine::run (this=0xb759db8) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0531de6a in QThreadPrivate::start (arg=0xb759db8) at thread/qthread_unix.cpp:285
#12 0x00cd1f19 in start_thread () from /lib/libpthread.so.0
#13 0x00c0bc4e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xac8ffb70 (LWP 4801)):
#0  0x007db416 in __kernel_vsyscall ()
#1  0x00cd698b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x07c8c927 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7da0f60) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0x07c8c972 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7da0f60) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x00cd1f19 in start_thread () from /lib/libpthread.so.0
#5  0x00c0bc4e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77339b0 (LWP 2391)):
[KCrash Handler]
#7  0x03ece460 in QGraphicsItem::setCursor (this=0xbc76d08, cursor=...) at graphicsview/qgraphicsitem.cpp:2155
#8  0x07902905 in Plasma::AbstractIcon::mouseMoveEvent (this=0xbc76d00, event=0xbfc722b4) at /usr/src/debug/kdebase-workspace-4.5.5/libs/plasmagenericshell/abstracticon.cpp:142
#9  0x03ec6e06 in QGraphicsItem::sceneEvent (this=0xbc76d08, event=0xbfc722b4) at graphicsview/qgraphicsitem.cpp:6695
#10 0x03f236e8 in QGraphicsWidget::sceneEvent (this=0xbc76d00, event=0xbfc722b4) at graphicsview/qgraphicswidget.cpp:1175
#11 0x03ef08f0 in QGraphicsScenePrivate::sendEvent (this=0xa00be18, item=0xbc76d08, event=0xbfc722b4) at graphicsview/qgraphicsscene.cpp:1207
#12 0x03ef157d in QGraphicsScenePrivate::sendMouseEvent (this=0xa00be18, mouseEvent=0xbfc722b4) at graphicsview/qgraphicsscene.cpp:1281
#13 0x03ef217e in QGraphicsScene::mouseMoveEvent (this=0x9f6fdc0, mouseEvent=0xbfc722b4) at graphicsview/qgraphicsscene.cpp:4081
#14 0x03f04975 in QGraphicsScene::event (this=0x9f6fdc0, event=0xbfc722b4) at graphicsview/qgraphicsscene.cpp:3433
#15 0x0387626c in QApplicationPrivate::notify_helper (this=0x9f725b0, receiver=0x9f6fdc0, e=0xbfc722b4) at kernel/qapplication.cpp:4445
#16 0x0387aed2 in QApplication::notify (this=0x9f662d0, receiver=0x9f6fdc0, e=0xbfc722b4) at kernel/qapplication.cpp:3845
#17 0x026d5f7b in KApplication::notify (this=0x9f662d0, receiver=0x9f6fdc0, event=0xbfc722b4) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#18 0x05415333 in QCoreApplication::notifyInternal (this=0x9f662d0, receiver=0x9f6fdc0, event=0xbfc722b4) at kernel/qcoreapplication.cpp:732
#19 0x038742cf in sendSpontaneousEvent (receiver=0x9f6fdc0, event=0xbfc722b4) at ../../src/corelib/kernel/qcoreapplication.h:218
#20 qt_sendSpontaneousEvent (receiver=0x9f6fdc0, event=0xbfc722b4) at kernel/qapplication.cpp:5439
#21 0x03f1d41a in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xb6aa560, event=0xbfc72b04) at graphicsview/qgraphicsview.cpp:647
#22 0x03f1d657 in QGraphicsView::mouseMoveEvent (this=0xb830d48, event=0xbfc72b04) at graphicsview/qgraphicsview.cpp:3274
#23 0x038cf893 in QWidget::event (this=0xb830d48, event=0xbfc72b04) at kernel/qwidget.cpp:8185
#24 0x03ccd1a4 in QFrame::event (this=0xb830d48, e=0xbfc72b04) at widgets/qframe.cpp:557
#25 0x03d5d063 in QAbstractScrollArea::viewportEvent (this=0xb830d48, e=0xbfc72b04) at widgets/qabstractscrollarea.cpp:1043
#26 0x03f21e27 in QGraphicsView::viewportEvent (this=0xb830d48, event=0xbfc72b04) at graphicsview/qgraphicsview.cpp:2864
#27 0x03d5f9d5 in viewportEvent (this=0xc0d6130, o=0xc0dd220, e=0xbfc72b04) at widgets/qabstractscrollarea_p.h:100
#28 QAbstractScrollAreaFilter::eventFilter (this=0xc0d6130, o=0xc0dd220, e=0xbfc72b04) at widgets/qabstractscrollarea_p.h:116
#29 0x054154ea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9f725b0, receiver=0xc0dd220, event=0xbfc72b04) at kernel/qcoreapplication.cpp:847
#30 0x03876241 in QApplicationPrivate::notify_helper (this=0x9f725b0, receiver=0xc0dd220, e=0xbfc72b04) at kernel/qapplication.cpp:4441
#31 0x0387b88d in QApplication::notify (this=0x9f662d0, receiver=0xc0dd220, e=0xbfc72b04) at kernel/qapplication.cpp:4006
#32 0x026d5f7b in KApplication::notify (this=0x9f662d0, receiver=0xc0dd220, event=0xbfc72b04) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#33 0x05415333 in QCoreApplication::notifyInternal (this=0x9f662d0, receiver=0xc0dd220, event=0xbfc72b04) at kernel/qcoreapplication.cpp:732
#34 0x038771f8 in sendSpontaneousEvent (receiver=0xc0dd220, event=0xbfc72b04, alienWidget=0xc0dd220, nativeWidget=0xb8180b0, buttonDown=0x41d4c80, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#35 QApplicationPrivate::sendMouseEvent (receiver=0xc0dd220, event=0xbfc72b04, alienWidget=0xc0dd220, nativeWidget=0xb8180b0, buttonDown=0x41d4c80, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#36 0x03900524 in QETWidget::translateMouseEvent (this=0xb8180b0, event=0xbfc7303c) at kernel/qapplication_x11.cpp:4438
#37 0x038fe957 in QApplication::x11ProcessEvent (this=0x9f662d0, event=0xbfc7303c) at kernel/qapplication_x11.cpp:3564
#38 0x03929790 in x11EventSourceDispatch (s=0x9f757a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#39 0x00141192 in g_main_dispatch (context=0x9f74890) at gmain.c:2149
#40 g_main_context_dispatch (context=0x9f74890) at gmain.c:2702
#41 0x00141978 in g_main_context_iterate (context=0x9f74890, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#42 0x00141c35 in g_main_context_iteration (context=0x9f74890, may_block=1) at gmain.c:2843
#43 0x0544302d in QEventDispatcherGlib::processEvents (this=0x9f50a48, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0x03929406 in QGuiEventDispatcherGlib::processEvents (this=0x9f50a48, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#45 0x054144ca in QEventLoop::processEvents (this=0xbfc73314, flags=...) at kernel/qeventloop.cpp:149
#46 0x0541477a in QEventLoop::exec (this=0xbfc73314, flags=...) at kernel/qeventloop.cpp:201
#47 0x05419327 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0x03874078 in QApplication::exec () at kernel/qapplication.cpp:3719
#49 0x07845e21 in kdemain (argc=1, argv=0xbfc73534) at /usr/src/debug/kdebase-workspace-4.5.5/plasma/desktop/shell/main.cpp:118
#50 0x080487cc in main (argc=1, argv=0xbfc73534) at /usr/src/debug/kdebase-workspace-4.5.5/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 260956, bug 259156, bug 257366, bug 253552.

Reported using DrKonqi
Comment 1 vikram goyal 2011-01-21 09:04:34 UTC
Created attachment 56268 [details]
tarred bzip of dot kde dir

Dot KDE dir. May help debug.
Comment 2 Aaron J. Seigo 2011-01-21 16:39:08 UTC
SVN commit 1216149 by aseigo:

always reset the cursor, and do so before the drag
BUG:263824


 M  +1 -2      abstracticon.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216149
Comment 3 Aaron J. Seigo 2011-01-21 16:46:03 UTC
SVN commit 1216150 by aseigo:

always reset the cursor, and do so before the drag
BUG:263824


 M  +1 -2      abstracticon.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216150
Comment 4 Dario Andres 2011-09-29 12:41:34 UTC
*** Bug 259156 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2011-09-29 12:41:36 UTC
*** Bug 282924 has been marked as a duplicate of this bug. ***