Bug 281500 - Kaffeine crashed while watching DVB-S with a Nexus-S
Summary: Kaffeine crashed while watching DVB-S with a Nexus-S
Status: RESOLVED DUPLICATE of bug 263943
Alias: None
Product: kaffeine
Classification: Applications
Component: general (show other bugs)
Version: 1.x
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-06 21:06 UTC by Robert Meintrup
Modified: 2017-10-04 09:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Meintrup 2011-09-06 21:06:10 UTC
Application: kaffeine (1.1)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
Surfing with die firefox 6.01 on ebay. No macromedia no flash 7 Tabs were open

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f431040d780 (LWP 4491))]

Thread 4 (Thread 0x7f42ff1ea700 (LWP 4492)):
#0  0x00007f430ca5b143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f430e079501 in QProcessManager::run (this=0x7f430e3cbf60) at io/qprocess_unix.cpp:245
#2  0x00007f430dfb1175 in QThreadPrivate::start (arg=0x7f430e3cbf60) at thread/qthread_unix.cpp:320
#3  0x00007f4309b85d8c in start_thread (arg=0x7f42ff1ea700) at pthread_create.c:304
#4  0x00007f430ca6304d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f42fe991700 (LWP 4494)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f42fe990ae0 in ?? ()
#2  0x00007fffe8bff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f42fcc72700 (LWP 4505)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f42fcc71ae0 in ?? ()
#2  0x00007fffe8bff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f431040d780 (LWP 4491)):
[KCrash Handler]
#6  0x000000000048e884 in toUnicode (text=<value optimized out>) at /usr/include/qt4/QtCore/qtextcodec.h:116
#7  DvbSiText::convertText (text=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:473
#8  0x000000000046eb90 in eventName (this=0x1d89950, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.h:426
#9  DvbEitFilter::processSection (this=0x1d89950, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbepg.cpp:535
#10 0x000000000048e16b in DvbSectionFilter::processSections (this=0x1d89950, force=true) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:130
#11 0x000000000048e5ac in DvbSectionFilter::processData (this=0x1d89950, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:87
#12 0x0000000000465c31 in DvbDevice::customEvent (this=0x28ff7d0) at /build/buildd/kaffeine-1.1/src/dvb/dvbdevice.cpp:742
#13 0x00007f430e0ac4fc in QObject::event (this=0x28ff7d0, e=<value optimized out>) at kernel/qobject.cpp:1257
#14 0x00007f430d4559f4 in QApplicationPrivate::notify_helper (this=0x1a67300, receiver=0x28ff7d0, e=0x7f42f8006440) at kernel/qapplication.cpp:4462
#15 0x00007f430d45a3ba in QApplication::notify (this=<value optimized out>, receiver=0x28ff7d0, e=0x7f42f8006440) at kernel/qapplication.cpp:4341
#16 0x00007f430ed50866 in KApplication::notify (this=0x7fffe8b52950, receiver=0x28ff7d0, event=0x7f42f8006440) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f430e09849c in QCoreApplication::notifyInternal (this=0x7fffe8b52950, receiver=0x28ff7d0, event=0x7f42f8006440) at kernel/qcoreapplication.cpp:731
#18 0x00007f430e09bc25 in sendEvent (receiver=0x0, event_type=0, data=0x1a10b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a10b60) at kernel/qcoreapplication.cpp:1372
#20 0x00007f430e0c3253 in sendPostedEvents (s=0x1a69d60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x1a69d60) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f430907dbcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f430907e3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f430907e639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f430e0c33ef in QEventDispatcherGlib::processEvents (this=0x1a10340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#26 0x00007f430d4ff4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f430e097882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f430e097abc in QEventLoop::exec (this=0x7fffe8b528e0, flags=...) at kernel/qeventloop.cpp:201
#29 0x00007f430e09becb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#30 0x0000000000437f15 in main (argc=1, argv=0x7fffe8b52c58) at /build/buildd/kaffeine-1.1/src/main.cpp:93

Possible duplicates by query: bug 280496, bug 255763, bug 254190.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-09-07 11:47:14 UTC

*** This bug has been marked as a duplicate of bug 263943 ***