Bug 280496 - Kaffeine crashes
Summary: Kaffeine crashes
Status: RESOLVED DUPLICATE of bug 263943
Alias: None
Product: kaffeine
Classification: Applications
Component: general (show other bugs)
Version: 1.x
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-21 03:02 UTC by wochenende
Modified: 2017-10-04 09:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wochenende 2011-08-21 03:02:08 UTC
Application: kaffeine (1.1)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
I started Kaffeine to record my scheduled tv program. Kaffeine crashed before the first record.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f32f8d4e780 (LWP 2305))]

Thread 3 (Thread 0x7f32ecfdc700 (LWP 2306)):
#0  0x00007f32f5392f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f32f19bad94 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f32f19bb682 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f32ed93bb24 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f32f19e2076 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f32f24c2d8c in start_thread (arg=0x7f32ecfdc700) at pthread_create.c:304
#6  0x00007f32f53a004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f32d584b700 (LWP 2312)):
#0  0x00007f32f5392f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f32f19bad94 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f32f19bb2c9 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f32f6a00446 in QEventDispatcherGlib::processEvents (this=0x18d1dd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f32f69d4882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f32f69d4abc in QEventLoop::exec (this=0x7f32d584add0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f32f68eb924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f32f69b6c2f in QInotifyFileSystemWatcherEngine::run (this=0x18cf830) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f32f68ee175 in QThreadPrivate::start (arg=0x18cf830) at thread/qthread_unix.cpp:320
#9  0x00007f32f24c2d8c in start_thread (arg=0x7f32d584b700) at pthread_create.c:304
#10 0x00007f32f53a004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f32f8d4e780 (LWP 2305)):
[KCrash Handler]
#6  0x000000000048e884 in toUnicode (text=<value optimized out>) at /usr/include/qt4/QtCore/qtextcodec.h:116
#7  DvbSiText::convertText (text=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:473
#8  0x000000000046eb90 in eventName (this=0x18ce910, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.h:426
#9  DvbEitFilter::processSection (this=0x18ce910, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbepg.cpp:535
#10 0x000000000048e16b in DvbSectionFilter::processSections (this=0x18ce910, force=true) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:130
#11 0x000000000048e5ac in DvbSectionFilter::processData (this=0x18ce910, data=<value optimized out>) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:87
#12 0x0000000000465c31 in DvbDevice::customEvent (this=0x1a45830) at /build/buildd/kaffeine-1.1/src/dvb/dvbdevice.cpp:742
#13 0x00007f32f69e94fc in QObject::event (this=0x1a45830, e=<value optimized out>) at kernel/qobject.cpp:1257
#14 0x00007f32f5d929f4 in QApplicationPrivate::notify_helper (this=0x155c750, receiver=0x1a45830, e=0x7f32dc002b50) at kernel/qapplication.cpp:4462
#15 0x00007f32f5d973ba in QApplication::notify (this=<value optimized out>, receiver=0x1a45830, e=0x7f32dc002b50) at kernel/qapplication.cpp:4341
#16 0x00007f32f768d866 in KApplication::notify (this=0x7fffe14a5750, receiver=0x1a45830, event=0x7f32dc002b50) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f32f69d549c in QCoreApplication::notifyInternal (this=0x7fffe14a5750, receiver=0x1a45830, event=0x7f32dc002b50) at kernel/qcoreapplication.cpp:731
#18 0x00007f32f69d8c25 in sendEvent (receiver=0x0, event_type=0, data=0x1507b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1507b60) at kernel/qcoreapplication.cpp:1372
#20 0x00007f32f6a00253 in sendPostedEvents (s=0x155f150) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x155f150) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f32f19ba85d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f32f19bb038 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f32f19bb2c9 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f32f6a003ef in QEventDispatcherGlib::processEvents (this=0x1507340, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#26 0x00007f32f5e3c4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f32f69d4882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f32f69d4abc in QEventLoop::exec (this=0x7fffe14a56e0, flags=...) at kernel/qeventloop.cpp:201
#29 0x00007f32f69d8ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#30 0x0000000000437f15 in main (argc=1, argv=0x7fffe14a5a58) at /build/buildd/kaffeine-1.1/src/main.cpp:93

Possible duplicates by query: bug 255763, bug 254190.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-21 14:31:52 UTC

*** This bug has been marked as a duplicate of bug 263943 ***