Bug 263943 - dvb crash with poor reception
Summary: dvb crash with poor reception
Status: RESOLVED FIXED
Alias: None
Product: kaffeine
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
: 254190 280496 281500 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-22 09:13 UTC by hdixon
Modified: 2017-12-01 20:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hdixon 2011-01-22 09:13:04 UTC
Application: kaffeine (1.1)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.36.2-server-2mnb i686
Distribution: "Mandriva Linux 2010.1"

-- Information about the crash:
watching digital tv in adelaide, australia.  The channel being watched has poor reception and the picture was erratic.

Current Mandriva (2010.2)

 -- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[KCrash Handler]
#6  0x080f6ec6 in toUnicode (text=...) at /usr/lib/qt4/include/QtCore/qtextcodec.h:119
#7  DvbSiText::convertText (text=...) at /usr/src/debug/kaffeine-1.1/src/dvb/dvbsi.cpp:473
#8  0x080d11af in text (this=0x8920fc0, data=...) at /usr/src/debug/kaffeine-1.1/src/dvb/dvbsi.h:431
#9  DvbEitFilter::processSection (this=0x8920fc0, data=...) at /usr/src/debug/kaffeine-1.1/src/dvb/dvbepg.cpp:536
#10 0x080f7f71 in DvbSectionFilter::processSections (this=0x8920fc0, force=true) at /usr/src/debug/kaffeine-1.1/src/dvb/dvbsi.cpp:138
#11 0x080fc5ff in DvbSectionFilter::processData (this=0x8920fc0, data=0x90862dc "G@\022\024") at /usr/src/debug/kaffeine-1.1/src/dvb/dvbsi.cpp:87
#12 0x080c448b in DvbDevice::customEvent (this=0x8d21878) at /usr/src/debug/kaffeine-1.1/src/dvb/dvbdevice.cpp:742
#13 0xb6b0f98c in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0xb6013f1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb601ad58 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb70f24a1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb6afea9e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb6b014a3 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0xb6b015fc in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#20 0xb6b2badd in ?? () from /usr/lib/libQtCore.so.4
#21 0xb57cccbe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb57d09f8 in ?? () from /usr/lib/libglib-2.0.so.0
#23 0xb57d0b9e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#24 0xb6b2b5c1 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0xb60d4bda in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6afd0fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0xb6afd549 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0xb6b016d0 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0xb6013fc4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0x0807f16c in main (argc=1, argv=0xbfa58254) at /usr/src/debug/kaffeine-1.1/src/main.cpp:79

Possible duplicates by query: bug 255763, bug 254190.

Reported using DrKonqi
Comment 1 Christoph Pfister 2011-01-22 14:24:53 UTC
SVN commit 1216289 by pfister:

fix text encoding bug
iso/iec 8859-12 doesn't exist, therefore no codec can be created.
thanks for the report!
BUG: 263943


 M  +0 -3      dvbsi.cpp  
 M  +7 -9      dvbsi.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216289
Comment 2 Christoph Pfister 2011-01-22 14:33:18 UTC
*** Bug 254190 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2011-08-21 14:31:52 UTC
*** Bug 280496 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Feck 2011-09-07 11:47:14 UTC
*** Bug 281500 has been marked as a duplicate of this bug. ***