Bug 254190 - Kaffeine Crash
Summary: Kaffeine Crash
Status: RESOLVED DUPLICATE of bug 263943
Alias: None
Product: kaffeine
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
: 255763 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-14 21:04 UTC by Dr. Hans Wolf
Modified: 2011-01-22 14:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Hans Wolf 2010-10-14 21:04:55 UTC
Application: kaffeine (1.0-svn3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic-pae i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Druring watching TV (DVB-S) Kaffeine crashed. I use kaffeine under Ubuntu 10.4. 

 -- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[KCrash Handler]
#6  0x080de36e in QTextCodec::toUnicode (text=...) at /usr/include/qt4/QtCore/qtextcodec.h:119
#7  DvbSiText::convertText (text=...) at /build/buildd/kaffeine-1.0~pre3/src/dvb/dvbsi.cpp:439
#8  0x080bbf06 in DvbShortEventDescriptor::eventName (this=0xa031420, data=...) at /build/buildd/kaffeine-1.0~pre3/src/dvb/dvbsi.h:425
#9  DvbEitFilter::processSection (this=0xa031420, data=...) at /build/buildd/kaffeine-1.0~pre3/src/dvb/dvbepg.cpp:376
#10 0x080e3575 in DvbSectionFilter::processData (this=0xa031420, data=0xb2414614 "G@\022\037\066\002\004deuZweikanalT\016\200") at /build/buildd/kaffeine-1.0~pre3/src/dvb/dvbsi.cpp:91
#11 0x080b6086 in DvbDevice::customEvent (this=0xa4ce618) at /build/buildd/kaffeine-1.0~pre3/src/dvb/dvbdevice.cpp:706
#12 0xb6b7245c in QObject::event (this=0xa4ce618, e=0xd) at kernel/qobject.cpp:1279
#13 0xb60994dc in QApplicationPrivate::notify_helper (this=0x9c79cc0, receiver=0xa4ce618, e=0xb2400588) at kernel/qapplication.cpp:4300
#14 0xb60a005e in QApplication::notify (this=0xbff0944c, receiver=0xa4ce618, e=0xb2400588) at kernel/qapplication.cpp:3704
#15 0xb7184f2a in KApplication::notify (this=0xbff0944c, receiver=0xa4ce618, event=0xb2400588) at ../../kdeui/kernel/kapplication.cpp:302
#16 0xb6b61a3b in QCoreApplication::notifyInternal (this=0xbff0944c, receiver=0xa4ce618, event=0xb2400588) at kernel/qcoreapplication.cpp:704
#17 0xb6b64473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9c5bfd8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9c5bfd8) at kernel/qcoreapplication.cpp:1345
#19 0xb6b645dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#20 0xb6b8dadf in QCoreApplication::sendPostedEvents (s=0x9c7bf10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=0x9c7bf10) at kernel/qeventdispatcher_glib.cpp:276
#22 0xb59db5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0xb59df2d8 in ?? () from /lib/libglib-2.0.so.0
#24 0xb59df4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0xb6b8d5d5 in QEventDispatcherGlib::processEvents (this=0x9c5bb70, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#26 0xb6159135 in QGuiEventDispatcherGlib::processEvents (this=0x9c5bb70, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb6b60059 in QEventLoop::processEvents (this=0xbff093a4, flags=) at kernel/qeventloop.cpp:149
#28 0xb6b604aa in QEventLoop::exec (this=0xbff093a4, flags=...) at kernel/qeventloop.cpp:201
#29 0xb6b6469f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0xb6099577 in QApplication::exec () at kernel/qapplication.cpp:3579
#31 0x0807be78 in main (argc=1, argv=0xbff095b4) at /build/buildd/kaffeine-1.0~pre3/src/main.cpp:91

Reported using DrKonqi
Comment 1 foobar23 2010-11-06 22:15:36 UTC
*** Bug 255763 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Pfister 2011-01-22 14:33:18 UTC

*** This bug has been marked as a duplicate of bug 263943 ***