Bug 255763 - Kaffeine crashes while watching TV (DVB-T)
Summary: Kaffeine crashes while watching TV (DVB-T)
Status: RESOLVED DUPLICATE of bug 254190
Alias: None
Product: kaffeine
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-31 20:40 UTC by foobar23
Modified: 2011-01-06 12:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.28 KB, text/plain)
2011-01-06 12:58 UTC, Rainer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description foobar23 2010-10-31 20:40:41 UTC
Application: kaffeine (1.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
I was just looking a film on TV (ARD (Germany) via DVB-T) when Kaffeine crashes with the following backtrace.

-- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[Current thread is 1 (Thread 0xb774a710 (LWP 19706))]

Thread 3 (Thread 0xb73d6b70 (LWP 19707)):
#0  0x008c4416 in __kernel_vsyscall ()
#1  0x00986de6 in poll () from /lib/libc.so.6
#2  0x086bfa1b in g_poll (fds=0x8b7efc8, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.26.0/glib/gpoll.c:132
#3  0x086b243c in g_main_context_poll (context=0x8b7e530, block=<value optimized out>, dispatch=1, self=0x8b7e5c0) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:3093
#4  g_main_context_iterate (context=0x8b7e530, block=<value optimized out>, dispatch=1, self=0x8b7e5c0) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2775
#5  0x086b2ba7 in g_main_loop_run (loop=0x8b7e5b0) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2988
#6  0x01e8e6b4 in gdbus_shared_thread_func (data=0x0) at /build/buildd/glib2.0-2.26.0/gio/gdbusprivate.c:277
#7  0x086d948f in g_thread_create_proxy (data=0x8b7e5c0) at /build/buildd/glib2.0-2.26.0/glib/gthread.c:1897
#8  0x00115cc9 in start_thread () from /lib/libpthread.so.0
#9  0x009956ae in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb3127b70 (LWP 19720)):
#0  0x06504e36 in clock_gettime () from /lib/librt.so.1
#1  0x0268f50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x027666e5 in QTimerInfoList::updateCurrentTime (this=0x8faabb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0276672a in QTimerInfoList::timerWait (this=0x8faabb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x027647a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb31270bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0276483d in timerSourcePrepare (source=0x0, timeout=0x6508ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x086b1e6a in g_main_context_prepare (context=0x8fac598, priority=0xb312713c) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2469
#8  0x086b2279 in g_main_context_iterate (context=0x8fac598, block=<value optimized out>, dispatch=1, self=0x8fa9c60) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2760
#9  0x086b2848 in g_main_context_iteration (context=0x8fac598, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#10 0x0276459f in QEventDispatcherGlib::processEvents (this=0x8f10550, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x02734609 in QEventLoop::processEvents (this=0xb3127290, flags=) at kernel/qeventloop.cpp:149
#12 0x02734a8a in QEventLoop::exec (this=0xb3127290, flags=...) at kernel/qeventloop.cpp:201
#13 0x02630b7e in QThread::exec (this=0x8ec4d08) at thread/qthread.cpp:490
#14 0x0271335b in QInotifyFileSystemWatcherEngine::run (this=0x8ec4d08) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x02633df9 in QThreadPrivate::start (arg=0x8ec4d08) at thread/qthread_unix.cpp:266
#16 0x00115cc9 in start_thread () from /lib/libpthread.so.0
#17 0x009956ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb774a710 (LWP 19706)):
[KCrash Handler]
#7  0x080f6596 in toUnicode (text=...) at /usr/include/qt4/QtCore/qtextcodec.h:116
#8  DvbSiText::convertText (text=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:473
#9  0x080cfc9e in eventName (this=0x8d8a8d0, data=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.h:426
#10 DvbEitFilter::processSection (this=0x8d8a8d0, data=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbepg.cpp:535
#11 0x080f7517 in DvbSectionFilter::processSections (this=0x8d8a8d0, force=false) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:130
#12 0x080fb748 in DvbSectionFilter::processData (this=0x8d8a8d0, data=0xb6a04778 "G") at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:102
#13 0x080c32b6 in DvbDevice::customEvent (this=0x8e643d0) at /build/buildd/kaffeine-1.1/src/dvb/dvbdevice.cpp:742
#14 0x027486fc in QObject::event (this=0x8e643d0, e=0x7) at kernel/qobject.cpp:1250
#15 0x0144bfdc in QApplicationPrivate::notify_helper (this=0x8b4ba38, receiver=0x8e643d0, e=0xb6a02f18) at kernel/qapplication.cpp:4396
#16 0x0145204e in QApplication::notify (this=0xbf9ad2cc, receiver=0x8e643d0, e=0xb6a02f18) at kernel/qapplication.cpp:3798
#17 0x00fd568a in KApplication::notify (this=0xbf9ad2cc, receiver=0x8e643d0, event=0xb6a02f18) at ../../kdeui/kernel/kapplication.cpp:310
#18 0x02735b3b in QCoreApplication::notifyInternal (this=0xbf9ad2cc, receiver=0x8e643d0, event=0xb6a02f18) at kernel/qcoreapplication.cpp:732
#19 0x02738d8b in sendEvent (receiver=0x0, event_type=0, data=0x8b2c860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8b2c860) at kernel/qcoreapplication.cpp:1373
#21 0x02738f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#22 0x02764a74 in sendPostedEvents (s=0x8b4df10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0x8b4df10) at kernel/qeventdispatcher_glib.cpp:277
#24 0x086ae855 in g_main_dispatch (context=0x8b4de90) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#25 g_main_context_dispatch (context=0x8b4de90) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#26 0x086b2668 in g_main_context_iterate (context=0x8b4de90, block=<value optimized out>, dispatch=1, self=0x8b4b9c8) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#27 0x086b2848 in g_main_context_iteration (context=0x8b4de90, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#28 0x02764565 in QEventDispatcherGlib::processEvents (this=0x8b2c310, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#29 0x0150dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x8b2c310, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x02734609 in QEventLoop::processEvents (this=0xbf9ad224, flags=) at kernel/qeventloop.cpp:149
#31 0x02734a8a in QEventLoop::exec (this=0xbf9ad224, flags=...) at kernel/qeventloop.cpp:201
#32 0x0273900f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#33 0x0144ae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#34 0x0807e3fd in main (argc=1, argv=0xbf9ad434) at /build/buildd/kaffeine-1.1/src/main.cpp:93

Possible duplicates by query: bug 254190.

Reported using DrKonqi
Comment 1 foobar23 2010-11-06 22:15:36 UTC

*** This bug has been marked as a duplicate of bug 254190 ***
Comment 2 Rainer 2011-01-06 12:58:52 UTC
Created attachment 55641 [details]
New crash information added by DrKonqi

kaffeine (1.1) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed:
Allways if I using Mobile Broadband Kaffeine DVB-T crashs. The DVB-T receiver is a a external USB CINERGY-T device and is located in about 1m difference to the Mobile Broadcast adapter and antenna. The DVB-T antenna is about 1,5m away.

I known that I can get pixel because of high frequency interferences. But theare is no reason to crash. This problemem occurs after going from Ubuntu 10.4 to 10.10. With Ubuntu 10.4 I had no kaffeine crashes.

-- Backtrace (Reduced):
#7  0x080f6596 in toUnicode (text=...) at /usr/include/qt4/QtCore/qtextcodec.h:116
#8  DvbSiText::convertText (text=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:473
#9  0x080cfd40 in text (this=0x98e39a8, data=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.h:431
#10 DvbEitFilter::processSection (this=0x98e39a8, data=...) at /build/buildd/kaffeine-1.1/src/dvb/dvbepg.cpp:536
#11 0x080f7587 in DvbSectionFilter::processSections (this=0x98e39a8, force=true) at /build/buildd/kaffeine-1.1/src/dvb/dvbsi.cpp:138