Bug 275478 - Kwin crash when exiting fullscreen mode in XBMC
Summary: Kwin crash when exiting fullscreen mode in XBMC
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-12 16:17 UTC by dittoo
Modified: 2011-06-12 16:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dittoo 2011-06-12 16:17:34 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
'AltGr' + '\' -> exit fullscreen mode from xbmc

- Unusual behavior I noticed:
Saw ubuntu (and not kubuntu) background appearing, and after a while kubuntu desktop reappeared.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f306f4ce7a0 (LWP 2309))]

Thread 3 (Thread 0x7f3053fbf700 (LWP 2319)):
#0  0x00007f306ed1d143 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f306b0fb32c in qt_safe_select (nfds=17, fdread=0x2636d40, fdwrite=0x2636fd8, fdexcept=0x2637270, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f306b1003d0 in QEventDispatcherUNIXPrivate::doSelect (this=0x2636b80, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f306b10104a in QEventDispatcherUNIX::processEvents (this=0x26fcb40, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f306b0d2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f306b0d2abc in QEventLoop::exec (this=0x7f3053fbedb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f306afe9924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f306b0b4c2f in QInotifyFileSystemWatcherEngine::run (this=0x26fb360) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f306afec175 in QThreadPrivate::start (arg=0x26fb360) at thread/qthread_unix.cpp:320
#9  0x00007f30656dfd8c in start_thread (arg=0x7f3053fbf700) at pthread_create.c:304
#10 0x00007f306ed2504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f30537be700 (LWP 2320)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f306db842a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f306de9d180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f306db842d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f306deab254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f30656dfd8c in start_thread (arg=0x7f30537be700) at pthread_create.c:304
#4  0x00007f306ed2504d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f306f4ce7a0 (LWP 2309)):
[KCrash Handler]
#6  0x00007f3056d340a0 in intel_region_buffer () from /usr/lib/dri/i965_dri.so
#7  0x00007f3056d276c2 in intelClearWithBlit () from /usr/lib/dri/i965_dri.so
#8  0x00007f3056d29d2a in ?? () from /usr/lib/dri/i965_dri.so
#9  0x00007f306f09bce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f306f09388f in KWin::Scene::paintGenericScreen (this=0x120f400, orig_mask=32) at ../../kwin/scene.cpp:188
#11 0x00007f306f090c7a in KWin::Scene::finalPaintScreen (this=0x120f400, mask=32, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f306f0aef19 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f3055d505a6 in KWin::StartupFeedbackEffect::paintScreen (this=0x276fd40, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f3055cf744d in KWin::LogoutEffect::paintScreen (this=0x2605d40, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f3055d1257b in KWin::ShadowEffect::paintScreen (this=0x2453350, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f3055d24e68 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f3055cfbfbd in KWin::PresentWindowsEffect::paintScreen (this=0x279bc00, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f3055ce3365 in KWin::DesktopGridEffect::paintScreen (this=0x24370e0, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f3055d18b8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f3055cdcbad in KWin::BoxSwitchEffect::paintScreen (this=0x25f61a0, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f3055d33256 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f3055d2bd86 in KWin::CoverSwitchEffect::paintScreen (this=0x25ddef0, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f306d16ea18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=0, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f3055d2239b in KWin::ZoomEffect::paintScreen (this=0x261baf0, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#54 0x00007f306f0aefa3 in KWin::EffectsHandlerImpl::paintScreen (this=0x23d5710, mask=0, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f306f0930af in KWin::Scene::paintScreen (this=0x120f400, mask=0x7fff820ed3cc, region=0x7fff820ed490) at ../../kwin/scene.cpp:137
#56 0x00007f306f0a6ef3 in KWin::SceneOpenGL::paint (this=0x120f400, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#57 0x00007f306f08e396 in KWin::Workspace::performCompositing (this=0x15cbaf0) at ../../kwin/composite.cpp:448
#58 0x00007f306b0e71c9 in QObject::event (this=0x15cbaf0, e=<value optimized out>) at kernel/qobject.cpp:1190
#59 0x00007f306a4949e4 in QApplicationPrivate::notify_helper (this=0x1176b40, receiver=0x15cbaf0, e=0x7fff820edc20) at kernel/qapplication.cpp:4462
#60 0x00007f306a4993aa in QApplication::notify (this=<value optimized out>, receiver=0x15cbaf0, e=0x7fff820edc20) at kernel/qapplication.cpp:4341
#61 0x00007f306e820866 in KApplication::notify (this=0x7fff820ee020, receiver=0x15cbaf0, event=0x7fff820edc20) at ../../kdeui/kernel/kapplication.cpp:311
#62 0x00007f306b0d349c in QCoreApplication::notifyInternal (this=0x7fff820ee020, receiver=0x15cbaf0, event=0x7fff820edc20) at kernel/qcoreapplication.cpp:731
#63 0x00007f306b100f12 in sendEvent (this=0x11791f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x11791f0) at kernel/qeventdispatcher_unix.cpp:604
#65 0x00007f306b10105b in QEventDispatcherUNIX::processEvents (this=0x111b340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#66 0x00007f306a53cc0c in QEventDispatcherX11::processEvents (this=0x111b340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0x00007f306b0d2882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#68 0x00007f306b0d2abc in QEventLoop::exec (this=0x7fff820edf60, flags=...) at kernel/qeventloop.cpp:201
#69 0x00007f306b0d6ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#70 0x00007f306f02c1ec in kdemain (argc=<value optimized out>, argv=0x7fff820ee6b8) at ../../kwin/main.cpp:542
#71 0x00007f306ec5deff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff820ee6b8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff820ee6a8) at libc-start.c:226
#72 0x0000000000400669 in _start ()

Possible duplicates by query: bug 275202, bug 275176, bug 274967, bug 273989, bug 273601.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-06-12 16:20:07 UTC
driver bug - see duplicate for workaround

*** This bug has been marked as a duplicate of bug 252817 ***