Bug 272083 - crash during zoom2
Summary: crash during zoom2
Status: RESOLVED DUPLICATE of bug 272082
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 19:44 UTC by csylvain
Modified: 2011-05-01 22:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description csylvain 2011-04-30 19:44:24 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
same as described before, only this time counting the number of zooms.  14 zooms then boom!

The crash can be reproduced every time.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3786710 (LWP 4103))]

Thread 5 (Thread 0xb12e2b70 (LWP 4104)):
#0  0xb577afcd in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb5a47d04 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb3e20a9f in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0xb3e218e2 in ?? () from /lib/libglib-2.0.so.0
#4  0xb3e21fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb69277b7 in QEventDispatcherGlib::processEvents (this=0x823bc78, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb68f82bd in QEventLoop::processEvents (this=0xb12e22b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb68f84e9 in QEventLoop::exec (this=0xb12e22b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb67f97b9 in QThread::exec (this=0x8252f88) at thread/qthread.cpp:490
#9  0xb68d823d in QInotifyFileSystemWatcherEngine::run (this=0x8252f88) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb67fc3aa in QThreadPrivate::start (arg=0x8252f88) at thread/qthread_unix.cpp:285
#11 0xb5778b05 in start_thread () from /lib/libpthread.so.0
#12 0xb5a39d5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb08cbb70 (LWP 4105)):
#0  0xb3ed722b in clock_gettime () from /lib/librt.so.1
#1  0xb6855ae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6928726 in updateCurrentTime (this=0x8340434, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x8340434, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6926f6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb08cb11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb692700d in timerSourcePrepare (source=0x8340400, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb3e20a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb3e218e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb3e21fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb69277b7 in QEventDispatcherGlib::processEvents (this=0x8331870, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb68f82bd in QEventLoop::processEvents (this=0xb08cb2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb68f84e9 in QEventLoop::exec (this=0xb08cb2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb67f97b9 in QThread::exec (this=0x81ff620) at thread/qthread.cpp:490
#14 0xb68d823d in QInotifyFileSystemWatcherEngine::run (this=0x81ff620) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb67fc3aa in QThreadPrivate::start (arg=0x81ff620) at thread/qthread_unix.cpp:285
#16 0xb5778b05 in start_thread () from /lib/libpthread.so.0
#17 0xb5a39d5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb00cab70 (LWP 4106)):
#0  0xb3e211a4 in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0xb3e21ac8 in ?? () from /lib/libglib-2.0.so.0
#2  0xb3e21fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0xb69277b7 in QEventDispatcherGlib::processEvents (this=0x83390e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0xb68f82bd in QEventLoop::processEvents (this=0xb00ca2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0xb68f84e9 in QEventLoop::exec (this=0xb00ca2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0xb67f97b9 in QThread::exec (this=0x8240be0) at thread/qthread.cpp:490
#7  0xb68d823d in QInotifyFileSystemWatcherEngine::run (this=0x8240be0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb67fc3aa in QThreadPrivate::start (arg=0x8240be0) at thread/qthread_unix.cpp:285
#9  0xb5778b05 in start_thread () from /lib/libpthread.so.0
#10 0xb5a39d5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xad8c5b70 (LWP 4113)):
#0  0xb577aff3 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb5a47d04 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb3e21a4d in ?? () from /lib/libglib-2.0.so.0
#3  0xb3e21fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0xb69277b7 in QEventDispatcherGlib::processEvents (this=0x84434a8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb68f82bd in QEventLoop::processEvents (this=0xad8c5280, flags=...) at kernel/qeventloop.cpp:149
#6  0xb68f84e9 in QEventLoop::exec (this=0xad8c5280, flags=...) at kernel/qeventloop.cpp:201
#7  0xb67f97b9 in QThread::exec (this=0x822fd38) at thread/qthread.cpp:490
#8  0xb7525090 in Marble::FileStorageWatcher::run (this=0x822fd38) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/FileStorageWatcher.cpp:401
#9  0xb67fc3aa in QThreadPrivate::start (arg=0x822fd38) at thread/qthread_unix.cpp:285
#10 0xb5778b05 in start_thread () from /lib/libpthread.so.0
#11 0xb5a39d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb3786710 (LWP 4103)):
[KCrash Handler]
#7  0xb751869b in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x8380f40, lon=-1.4241858085906332, lat=0.75058245805743862, scanLine=0xac825008) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/AbstractScanlineTextureMapper.cpp:130
#8  0xb75199ca in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8380f40, viewParams=0x81ec87c, texColorizer=0x8398ca0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#9  0xb7519cbd in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8380f40, painter=0xbfe7f62c, viewParams=0x81ec87c, dirtyRect=..., texColorizer=0x8398ca0) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0xb750ee49 in Marble::TextureLayer::paintGlobe (this=0x81ec89c, painter=0xbfe7f62c, viewParams=0x81ec87c, dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/TextureLayer.cpp:161
#11 0xb7481b1d in Marble::MarbleMapPrivate::paintGround (this=0x81ec870, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleMap.cpp:188
#12 0xb7471456 in Marble::MarbleWidget::paintEvent (this=0x81f9e20, evt=0xbfe7fbe4) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:805
#13 0xb5e7c60a in QWidget::event (this=0x81f9e20, event=0xbfe7fbe4) at kernel/qwidget.cpp:8346
#14 0xb5e21414 in QApplicationPrivate::notify_helper (this=0x80e7ca0, receiver=0x81f9e20, e=0xbfe7fbe4) at kernel/qapplication.cpp:4445
#15 0xb5e2a174 in QApplication::notify (this=0xbfe81a44, receiver=0x81f9e20, e=0xbfe7fbe4) at kernel/qapplication.cpp:4324
#16 0xb6e161f1 in KApplication::notify (this=0xbfe81a44, receiver=0x81f9e20, event=0xbfe7fbe4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#17 0xb68f8fde in QCoreApplication::notifyInternal (this=0xbfe81a44, receiver=0x81f9e20, event=0xbfe7fbe4) at kernel/qcoreapplication.cpp:732
#18 0xb5e792a2 in sendSpontaneousEvent (this=0x8224bf0, pdev=0x835d4cc, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x835bc08) at ../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x8224bf0, pdev=0x835d4cc, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x835bc08) at kernel/qwidget.cpp:5433
#20 0xb6067627 in QWidgetBackingStore::sync (this=0x835bc08) at painting/qbackingstore.cpp:1325
#21 0xb5e6e03b in QWidgetPrivate::syncBackingStore (this=0x81cd320) at kernel/qwidget.cpp:1816
#22 0xb5e7d0da in QWidget::event (this=0x81d8e28, event=0xbfe80704) at kernel/qwidget.cpp:8493
#23 0xb62a829c in QMainWindow::event (this=0x81d8e28, event=0xbfe80704) at widgets/qmainwindow.cpp:1478
#24 0xb6ed9ae4 in KMainWindow::event (this=0x81d8e28, ev=0xbfe80704) at /usr/src/debug/kdelibs-4.6.0/kdeui/widgets/kmainwindow.cpp:1100
#25 0xb6ed9d82 in KXmlGuiWindow::event (this=0x81d8e28, ev=0xbfe80704) at /usr/src/debug/kdelibs-4.6.0/kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0xb5e21414 in QApplicationPrivate::notify_helper (this=0x80e7ca0, receiver=0x81d8e28, e=0xbfe80704) at kernel/qapplication.cpp:4445
#27 0xb5e2a174 in QApplication::notify (this=0xbfe81a44, receiver=0x81d8e28, e=0xbfe80704) at kernel/qapplication.cpp:4324
#28 0xb6e161f1 in KApplication::notify (this=0xbfe81a44, receiver=0x81d8e28, event=0xbfe80704) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#29 0xb68f8fde in QCoreApplication::notifyInternal (this=0xbfe81a44, receiver=0x81d8e28, event=0xbfe80704) at kernel/qcoreapplication.cpp:732
#30 0xb6063be9 in sendEvent (this=0x835bc08, rect=..., widget=0x81f9e20, updateImmediately=true, invalidateBuffer=false) at ../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (this=0x835bc08, rect=..., widget=0x81f9e20, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#32 QWidgetBackingStore::markDirty (this=0x835bc08, rect=..., widget=0x81f9e20, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0xb5e6d782 in QWidget::repaint (this=0x81f9e20, rect=...) at kernel/qwidget.cpp:10250
#34 0xb5e6d8a1 in QWidget::repaint (this=0x81f9e20) at kernel/qwidget.cpp:10206
#35 0xb7474c6c in repaint (this=0x81f9e20, newZoom=1608, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::zoomView (this=0x81f9e20, newZoom=1608, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:539
#37 0xb7474d0a in Marble::MarbleWidget::zoomViewBy (this=0x81f9e20, zoomStep=40, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:552
#38 0xb7474d8d in Marble::MarbleWidget::zoomIn (this=0x81f9e20, mode=Marble::Automatic) at /usr/src/debug/kdeedu-4.6.0/marble/src/lib/MarbleWidget.cpp:558
#39 0xb7476bbc in Marble::MarbleWidget::qt_metacall (this=0x81f9e20, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfe8094c) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/MarbleWidget.moc:310
#40 0xb68ff8cd in QMetaObject::metacall (object=0x81f9e20, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfe8094c) at kernel/qmetaobject.cpp:237
#41 0xb690fa2c in QMetaObject::activate (sender=0x8193350, m=0xb762a550, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3272
#42 0xb7486675 in Marble::NavigationWidget::zoomIn (this=0x8193350) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:136
#43 0xb74869a4 in Marble::NavigationWidget::qt_metacall (this=0x8193350, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe80aa8) at /usr/src/debug/kdeedu-4.6.0/build/marble/src/lib/NavigationWidget.moc:102
#44 0xb68ff8cd in QMetaObject::metacall (object=0x8193350, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbfe80aa8) at kernel/qmetaobject.cpp:237
#45 0xb690fa2c in QMetaObject::activate (sender=0x8252600, m=0xb678a824, local_signal_index=2, argv=0xbfe80aa8) at kernel/qobject.cpp:3272
#46 0xb65436cd in QAbstractButton::clicked (this=0x8252600, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#47 0xb623e5ad in QAbstractButtonPrivate::emitClicked (this=0x8270a48) at widgets/qabstractbutton.cpp:546
#48 0xb623fe8b in QAbstractButtonPrivate::click (this=0x8270a48) at widgets/qabstractbutton.cpp:539
#49 0xb6240146 in QAbstractButton::mouseReleaseEvent (this=0x8252600, e=0xbfe811d4) at widgets/qabstractbutton.cpp:1121
#50 0xb631754d in QToolButton::mouseReleaseEvent (this=0x8252600, e=0xbfe811d4) at widgets/qtoolbutton.cpp:721
#51 0xb5e7c5b0 in QWidget::event (this=0x8252600, event=0xbfe811d4) at kernel/qwidget.cpp:8200
#52 0xb623f160 in QAbstractButton::event (this=0x8252600, e=0xbfe811d4) at widgets/qabstractbutton.cpp:1080
#53 0xb6318cbc in QToolButton::event (this=0x8252600, event=0xbfe811d4) at widgets/qtoolbutton.cpp:1163
#54 0xb5e21414 in QApplicationPrivate::notify_helper (this=0x80e7ca0, receiver=0x8252600, e=0xbfe811d4) at kernel/qapplication.cpp:4445
#55 0xb5e2ac20 in QApplication::notify (this=0xbfe80eec, receiver=0x8252600, e=0xbfe811d4) at kernel/qapplication.cpp:4006
#56 0xb6e161f1 in KApplication::notify (this=0xbfe81a44, receiver=0x8252600, event=0xbfe811d4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#57 0xb68f8fde in QCoreApplication::notifyInternal (this=0xbfe81a44, receiver=0x8252600, event=0xbfe811d4) at kernel/qcoreapplication.cpp:732
#58 0xb5e2245c in sendSpontaneousEvent (receiver=0x8252600, event=0xbfe811d4, alienWidget=0x8252600, nativeWidget=0x81d8e28, buttonDown=0xb6793c00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#59 QApplicationPrivate::sendMouseEvent (receiver=0x8252600, event=0xbfe811d4, alienWidget=0x8252600, nativeWidget=0x81d8e28, buttonDown=0xb6793c00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#60 0xb5eae030 in QETWidget::translateMouseEvent (this=0x81d8e28, event=0xbfe816ec) at kernel/qapplication_x11.cpp:4438
#61 0xb5ead13e in QApplication::x11ProcessEvent (this=0xbfe81a44, event=0xbfe816ec) at kernel/qapplication_x11.cpp:3442
#62 0xb5ed7960 in x11EventSourceDispatch (s=0x80e7b58, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#63 0xb3e21509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#64 0xb3e21d10 in ?? () from /lib/libglib-2.0.so.0
#65 0xb3e21fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#66 0xb692776b in QEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#67 0xb5ed755a in QGuiEventDispatcherGlib::processEvents (this=0x80d1298, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#68 0xb68f82bd in QEventLoop::processEvents (this=0xbfe819a4, flags=...) at kernel/qeventloop.cpp:149
#69 0xb68f84e9 in QEventLoop::exec (this=0xbfe819a4, flags=...) at kernel/qeventloop.cpp:201
#70 0xb68fcf90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#71 0xb5e1f104 in QApplication::exec () at kernel/qapplication.cpp:3719
#72 0x08065935 in main (argc=) at /usr/src/debug/kdeedu-4.6.0/marble/src/kdemain.cpp:351

Possible duplicates by query: bug 272082, bug 269181.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-05-01 22:25:51 UTC

*** This bug has been marked as a duplicate of bug 272082 ***