Bug 273273 - Marble crashed when run the first time
Summary: Marble crashed when run the first time
Status: RESOLVED DUPLICATE of bug 275819
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 1.1.0
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-14 17:03 UTC by josepramon
Modified: 2011-08-19 20:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description josepramon 2011-05-14 17:03:13 UTC
Application: marble (1.0.2 (Stable Release))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic-pae i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: the first time I opened d'application after the installation. I'm not restart the pc

-- Backtrace:
Application: El globus terraqüi virtual Marble (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3867970 (LWP 1937))]

Thread 6 (Thread 0xb10ebb70 (LWP 1938)):
#0  0xb42c738a in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb5cfe616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb4215009 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4215e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb6b97577 in QEventDispatcherGlib::processEvents (this=0x932fc48, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6b69289 in QEventLoop::processEvents (this=0xb10eb290, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6b69522 in QEventLoop::exec (this=0xb10eb290, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6a732a0 in QThread::exec (this=0x932f820) at thread/qthread.cpp:492
#9  0xb6b4afdb in QInotifyFileSystemWatcherEngine::run (this=0x932f820) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6a75da2 in QThreadPrivate::start (arg=0x932f820) at thread/qthread_unix.cpp:320
#11 0xb42c4e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5cf073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xb05c2b70 (LWP 1939)):
#0  0xb42afd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6acbdd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6b984f2 in updateCurrentTime (this=0x940464c, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x940464c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6b96d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb05c20dc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6b96dcd in timerSourcePrepare (source=0x9404618, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb4214fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb4215e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6b97577 in QEventDispatcherGlib::processEvents (this=0x9404008, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b69289 in QEventLoop::processEvents (this=0xb05c2290, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b69522 in QEventLoop::exec (this=0xb05c2290, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6a732a0 in QThread::exec (this=0x92f6c80) at thread/qthread.cpp:492
#14 0xb6b4afdb in QInotifyFileSystemWatcherEngine::run (this=0x92f6c80) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6a75da2 in QThreadPrivate::start (arg=0x92f6c80) at thread/qthread_unix.cpp:320
#16 0xb42c4e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5cf073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xafdc1b70 (LWP 1940)):
#0  0xb4215010 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4215e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb6b97577 in QEventDispatcherGlib::processEvents (this=0x94d7eb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0xb6b69289 in QEventLoop::processEvents (this=0xafdc1290, flags=...) at kernel/qeventloop.cpp:149
#5  0xb6b69522 in QEventLoop::exec (this=0xafdc1290, flags=...) at kernel/qeventloop.cpp:201
#6  0xb6a732a0 in QThread::exec (this=0x9325530) at thread/qthread.cpp:492
#7  0xb6b4afdb in QInotifyFileSystemWatcherEngine::run (this=0x9325530) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb6a75da2 in QThreadPrivate::start (arg=0x9325530) at thread/qthread_unix.cpp:320
#9  0xb42c4e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0xb5cf073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xadbfeb70 (LWP 1947)):
#0  0xb42afd41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6acbdd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6b984f2 in updateCurrentTime (this=0xae445434, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xae445434, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6b96d32 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xadbfe0cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6b96dcd in timerSourcePrepare (source=0xae445400, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb4214fd4 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb4215e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb6b97577 in QEventDispatcherGlib::processEvents (this=0x9550c08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b69289 in QEventLoop::processEvents (this=0xadbfe280, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b69522 in QEventLoop::exec (this=0xadbfe280, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6a732a0 in QThread::exec (this=0xb0701918) at thread/qthread.cpp:492
#14 0xb76baef8 in Marble::FileStorageWatcher::run (this=0xb0701918) at ../../../../marble/src/lib/FileStorageWatcher.cpp:401
#15 0xb6a75da2 in QThreadPrivate::start (arg=0xb0701918) at thread/qthread_unix.cpp:320
#16 0xb42c4e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5cf073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xaf5c0b70 (LWP 1949)):
#0  0xb5cfe656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0xb4214fc2 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4215e63 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb6b97577 in QEventDispatcherGlib::processEvents (this=0x95829e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0xb6b69289 in QEventLoop::processEvents (this=0xaf5c0290, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6b69522 in QEventLoop::exec (this=0xaf5c0290, flags=...) at kernel/qeventloop.cpp:201
#7  0xb6a732a0 in QThread::exec (this=0x91237c0) at thread/qthread.cpp:492
#8  0xb6b4afdb in QInotifyFileSystemWatcherEngine::run (this=0x91237c0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb6a75da2 in QThreadPrivate::start (arg=0x91237c0) at thread/qthread_unix.cpp:320
#10 0xb42c4e99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb5cf073e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb3867970 (LWP 1937)):
[KCrash Handler]
#7  0xb76bde3c in Marble::AbstractTile::setUsed (this=0x90fece0, used=true) at ../../../../marble/src/lib/AbstractTile.cpp:62
#8  0xb76aec5e in Marble::AbstractScanlineTextureMapper::nextTile (this=0xb070bfc0, posX=@0xbfc44208, posY=@0xbfc44200) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:536
#9  0xb76aed6e in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0xb070bfc0, lon=-2.8531724910653531, lat=0.63309782186937769, scanLine=0xab9bfda8) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:127
#10 0xb76aff8f in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xb070bfc0, viewParams=0x9335f64, texColorizer=0x950aab0) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:233
#11 0xb76b0263 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0xb070bfc0, painter=0xbfc4461c, viewParams=0x9335f64, dirtyRect=..., texColorizer=0x950aab0) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#12 0xb76a58b6 in Marble::TextureLayer::paintGlobe (this=0x9335f84, painter=0xbfc4461c, viewParams=0x9335f64, dirtyRect=...) at ../../../../marble/src/lib/TextureLayer.cpp:161
#13 0xb761c5d2 in Marble::MarbleMapPrivate::paintGround (this=0x9335f58, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#14 0xb760c458 in Marble::MarbleWidget::paintEvent (this=0x92fe518, evt=0xbfc44be4) at ../../../../marble/src/lib/MarbleWidget.cpp:805
#15 0xb611d18e in QWidget::event (this=0x92fe518, event=0xbfc44be4) at kernel/qwidget.cpp:8405
#16 0xb60c4d24 in QApplicationPrivate::notify_helper (this=0x90a52f0, receiver=0x92fe518, e=0xbfc44be4) at kernel/qapplication.cpp:4462
#17 0xb60c997b in QApplication::notify (this=0xbfc46614, receiver=0x92fe518, e=0xbfc44be4) at kernel/qapplication.cpp:4427
#18 0xb70fa3ca in KApplication::notify (this=0xbfc46614, receiver=0x92fe518, event=0xbfc44be4) at ../../kdeui/kernel/kapplication.cpp:311
#19 0xb6b6a0bb in QCoreApplication::notifyInternal (this=0xbfc46614, receiver=0x92fe518, event=0xbfc44be4) at kernel/qcoreapplication.cpp:731
#20 0xb6119f0c in sendSpontaneousEvent (this=0x932eef0, pdev=0x94f072c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#21 QWidgetPrivate::drawWidget (this=0x932eef0, pdev=0x94f072c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5492
#22 0xb611ab7c in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9810, pdev=0x94f072c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5699
#23 0xb611aa42 in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9810, pdev=0x94f072c, siblings=..., index=0, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5686
#24 0xb611aa42 in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9810, pdev=0x94f072c, siblings=..., index=2, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5686
#25 0xb6119c80 in QWidgetPrivate::drawWidget (this=0x91b9810, pdev=0x94f072c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5545
#26 0xb611ab7c in QWidgetPrivate::paintSiblingsRecursive (this=0x91b82f8, pdev=0x94f072c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5699
#27 0xb6119c80 in QWidgetPrivate::drawWidget (this=0x91b82f8, pdev=0x94f072c, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5545
#28 0xb611ab7c in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9450, pdev=0x94f072c, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5699
#29 0xb611aa42 in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9450, pdev=0x94f072c, siblings=..., index=6, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5686
#30 0xb611aa42 in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9450, pdev=0x94f072c, siblings=..., index=9, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5686
#31 0xb611aa42 in QWidgetPrivate::paintSiblingsRecursive (this=0x91b9450, pdev=0x94f072c, siblings=..., index=17, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5686
#32 0xb6119c80 in QWidgetPrivate::drawWidget (this=0x91b9450, pdev=0x94f072c, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x94eee10) at kernel/qwidget.cpp:5545
#33 0xb62f5908 in QWidgetBackingStore::sync (this=0x94eee10) at painting/qbackingstore.cpp:1333
#34 0xb62f5cca in QWidgetBackingStore::sync (this=0x94eee10, exposedWidget=0x9161b68, exposedRegion=...) at painting/qbackingstore.cpp:1130
#35 0xb610f782 in QWidgetPrivate::syncBackingStore (this=0x91b9450, region=...) at kernel/qwidget.cpp:1857
#36 0xb614ca16 in QETWidget::translatePaintEvent (this=0x9161b68, event=0xbfc462ac) at kernel/qapplication_x11.cpp:5448
#37 0xb614da5d in QApplication::x11ProcessEvent (this=0xbfc46614, event=0xbfc462ac) at kernel/qapplication_x11.cpp:3578
#38 0xb6178b84 in x11EventSourceDispatch (s=0x90a5d68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#39 0xb4215aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb4216270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0xb4216524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#42 0xb6b9753c in QEventDispatcherGlib::processEvents (this=0x9071b60, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#43 0xb6178775 in QGuiEventDispatcherGlib::processEvents (this=0x9071b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0xb6b69289 in QEventLoop::processEvents (this=0xbfc46574, flags=...) at kernel/qeventloop.cpp:149
#45 0xb6b69522 in QEventLoop::exec (this=0xbfc46574, flags=...) at kernel/qeventloop.cpp:201
#46 0xb6b6decc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#47 0xb60c28e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#48 0x08064055 in main (argc=0, argv=0x0) at ../../../marble/src/kdemain.cpp:351

Reported using DrKonqi
Comment 1 Bernhard Beschow 2011-08-19 20:27:00 UTC

*** This bug has been marked as a duplicate of bug 275819 ***