Bug 272838 - nepomuk crashes afer startup
Summary: nepomuk crashes afer startup
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-09 10:59 UTC by José Filipe
Modified: 2011-08-07 20:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Filipe 2011-05-09 10:59:57 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.5 (KDE 4.5.5) (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.8-68.fc13.i686.PAE i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
i had Fedora 13 and KDE 4.5.5 and this happens a little minutes after kde startup

The crash can be reproduced some of the time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7782780 (LWP 2522))]

Thread 2 (Thread 0xb53ddb70 (LWP 2800)):
[KCrash Handler]
#7  0x063cefca in QMutex::lock (this=0x9e13a74) at thread/qmutex.cpp:150
#8  0x079c31e3 in Soprano::Error::ErrorCache::clearError() const () from /usr/lib/libsoprano.so.4
#9  0x079c3468 in Soprano::Error::ErrorCache::setError(Soprano::Error::Error const&) const () from /usr/lib/libsoprano.so.4
#10 0x0060b56f in Soprano::Client::DBusModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsopranoclient.so.1
#11 0x0221b1e4 in Nepomuk::MainModel::executeQuery (this=0x9e50108, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x079cfbbb in Soprano::FilterModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsoprano.so.4
#13 0x0220f469 in Nepomuk::ResourceData::determineUri (this=0xb488e1d0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcedata.cpp:580
#14 0x0221f8d4 in Nepomuk::Resource::determineFinalResourceData (this=0xb53dcde0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:885
#15 0x02221b30 in Nepomuk::Resource::resourceUri (this=0xb53dcde0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:165
#16 0x00905cdf in FileMetaData (this=0xb481cea8, idx=0xb53dd04c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:190
#17 Strigi::NepomukIndexWriter::startAnalysis (this=0xb481cea8, idx=0xb53dd04c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:373
#18 0x0218261b in Strigi::AnalysisResult::AnalysisResult (this=0xb53dd04c, path="/home/jfilipe/Desktop/Quanta Plus.desktop", mt=1252519781, w=..., indexer=..., parentpath="/home/jfilipe/Desktop")
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:178
#19 0x00eaa0ca in Nepomuk::IndexScheduler::analyzeFile (this=0x9e52590, file=..., analyzer=0xb53dd27c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:443
#20 0x00eab99f in Nepomuk::IndexScheduler::updateDir (this=0x9e52590, dir=..., analyzer=0xb53dd27c, flags=...) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:413
#21 0x00eae17b in Nepomuk::IndexScheduler::run (this=0x9e52590) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:314
#22 0x063d368f in QThreadPrivate::start (arg=0x9e52590) at thread/qthread_unix.cpp:248
#23 0x00994919 in start_thread (arg=0xb53ddb70) at pthread_create.c:301
#24 0x00b3cd4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb7782780 (LWP 2522)):
#0  0x00803424 in __kernel_vsyscall ()
#1  0x00b31f56 in __poll (fds=0xbfdd6124, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x02cfdf1c in ?? () from /lib/libdbus-1.so.3
#3  0x02cf5c7f in ?? () from /lib/libdbus-1.so.3
#4  0x02cf3dec in ?? () from /lib/libdbus-1.so.3
#5  0x02cddfa3 in ?? () from /lib/libdbus-1.so.3
#6  0x02cde878 in ?? () from /lib/libdbus-1.so.3
#7  0x02ce064f in ?? () from /lib/libdbus-1.so.3
#8  0x02cee4c2 in dbus_pending_call_block () from /lib/libdbus-1.so.3
#9  0x02cdfc5c in dbus_connection_send_with_reply_and_block () from /lib/libdbus-1.so.3
#10 0x00852f1d in q_dbus_connection_send_with_reply_and_block (this=0x9e11948, message=..., sendMode=1, timeout=-1) at qdbus_symbols_p.h:133
#11 QDBusConnectionPrivate::sendWithReply (this=0x9e11948, message=..., sendMode=1, timeout=-1) at qdbusintegrator.cpp:1828
#12 0x0083ee9b in QDBusConnection::call (this=0x9e506d8, message=..., mode=QDBus::Block, timeout=-1) at qdbusconnection.cpp:522
#13 0x0085cc7b in QDBusAbstractInterface::callWithArgumentList (this=0x9e50678, mode=QDBus::Block, method=..., args=...) at qdbusabstractinterface.cpp:440
#14 0x00607ea3 in ?? () from /usr/lib/libsopranoclient.so.1
#15 0x00608bb6 in Soprano::Client::DBusClient::createModel(QString const&, QList<Soprano::BackendSetting> const&) () from /usr/lib/libsopranoclient.so.1
#16 0x0221a0fd in (anonymous namespace)::GlobalModelContainer::init (this=0x9e4ffb8, forced=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:92
#17 0x0221dc46 in Nepomuk::MainModel::init (this=0x9e50108) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:176
#18 0x02213c86 in Nepomuk::ResourceManager::init (this=0x9e7f860) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:329
#19 0x0221612b in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x9e4f038, success=true) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:220
#20 0x02216243 in Nepomuk::ResourceManager::qt_metacall (this=0x9e7f860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfdd695c)
    at /usr/src/debug/kdelibs-4.5.5/i686-redhat-linux-gnu/nepomuk/resourcemanager.moc:90
#21 0x0084d77c in QDBusConnectionPrivate::deliverCall (this=0x9e11948, object=0x9e7f860, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:904
#22 0x00858418 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9f6a008, object=0x9e7f860) at qdbusintegrator_p.h:101
#23 0x064d443e in QObject::event (this=0x9e7f860, e=0x9f6a008) at kernel/qobject.cpp:1248
#24 0x04b3f74c in QApplicationPrivate::notify_helper (this=0x9d7b6f8, receiver=0x9e7f860, e=0x9f6a008) at kernel/qapplication.cpp:4306
#25 0x04b461a6 in QApplication::notify (this=0xbfdd72f8, receiver=0x9e7f860, e=0x9f6a008) at kernel/qapplication.cpp:3710
#26 0x03569a5b in KApplication::notify (this=0xbfdd72f8, receiver=0x9e7f860, event=0x9f6a008) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#27 0x064c4563 in QCoreApplication::notifyInternal (this=0xbfdd72f8, receiver=0x9e7f860, event=0x9f6a008) at kernel/qcoreapplication.cpp:726
#28 0x064c69ec in sendEvent (receiver=0x0, event_type=0, data=0x9d67690) at kernel/qcoreapplication.h:215
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9d67690) at kernel/qcoreapplication.cpp:1367
#30 0x064c6b6e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#31 0x064ecc30 in sendPostedEvents (s=0x9d7d390) at kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=0x9d7d390) at kernel/qeventdispatcher_glib.cpp:276
#33 0x00c26525 in g_main_dispatch (context=0x9d7d310) at gmain.c:1960
#34 IA__g_main_context_dispatch (context=0x9d7d310) at gmain.c:2513
#35 0x00c2a268 in g_main_context_iterate (context=0x997490, block=1, dispatch=1, self=0x9d7b650) at gmain.c:2591
#36 0x00c2a449 in IA__g_main_context_iteration (context=0x9d7d310, may_block=1) at gmain.c:2654
#37 0x064ec726 in QEventDispatcherGlib::processEvents (this=0x9d67140, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#38 0x04bedb56 in QGuiEventDispatcherGlib::processEvents (this=0x9d67140, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#39 0x064c2c3a in QEventLoop::processEvents (this=0xbfdd7184, flags=...) at kernel/qeventloop.cpp:149
#40 0x064c2f7a in QEventLoop::exec (this=0xbfdd7184, flags=...) at kernel/qeventloop.cpp:201
#41 0x064c6c37 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#42 0x04b3f7f8 in QApplication::exec () at kernel/qapplication.cpp:3585
#43 0x0804b07e in main (argc=) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 245266.

Possible duplicates by query: bug 271343, bug 270300, bug 268808, bug 263663, bug 256895.

Reported using DrKonqi
Comment 1 Dario Andres 2011-08-07 20:11:59 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.x. The issue was being tracked at bug 245266,
merging.
Thanks

*** This bug has been marked as a duplicate of bug 245266 ***