Bug 268808 - nepomuk crash in somme minutes after startup
Summary: nepomuk crash in somme minutes after startup
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-18 10:40 UTC by José Filipe
Modified: 2011-03-18 10:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Filipe 2011-03-18 10:40:43 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.5 (KDE 4.5.5) (Compiled from sources)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.8-68.fc13.i686.PAE i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
it occurrs so very, very times ! 
When i start kde after a little minutes nepomuk crashes !
I had Fedora 13 and KDE 4.5.5

The crash can be reproduced some of the time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77ff780 (LWP 2530))]

Thread 2 (Thread 0xb5463b70 (LWP 2676)):
[KCrash Handler]
#7  0x063cefca in QMutex::lock (this=0x85d483c) at thread/qmutex.cpp:150
#8  0x079c31e3 in Soprano::Error::ErrorCache::clearError() const () from /usr/lib/libsoprano.so.4
#9  0x079c3468 in Soprano::Error::ErrorCache::setError(Soprano::Error::Error const&) const () from /usr/lib/libsoprano.so.4
#10 0x0681556f in Soprano::Client::DBusModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsopranoclient.so.1
#11 0x067861e4 in Nepomuk::MainModel::executeQuery (this=0x8611750, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x079cfbbb in Soprano::FilterModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsoprano.so.4
#13 0x0677a469 in Nepomuk::ResourceData::determineUri (this=0xb49850e0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcedata.cpp:580
#14 0x0678a8d4 in Nepomuk::Resource::determineFinalResourceData (this=0xb5462de0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:885
#15 0x0678cb30 in Nepomuk::Resource::resourceUri (this=0xb5462de0) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:165
#16 0x00218cdf in FileMetaData (this=0xb491bb38, idx=0xb546304c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:190
#17 Strigi::NepomukIndexWriter::startAnalysis (this=0xb491bb38, idx=0xb546304c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/strigibackend/nepomukindexwriter.cpp:373
#18 0x07dff61b in Strigi::AnalysisResult::AnalysisResult (this=0xb546304c, path="/home/jfilipe/Desktop/Amaya.desktop", mt=1252518125, w=..., indexer=..., parentpath="/home/jfilipe/Desktop")
    at /usr/src/debug/strigi-0.7.2/src/streamanalyzer/analysisresult.cpp:178
#19 0x00e930ca in Nepomuk::IndexScheduler::analyzeFile (this=0x8613e60, file=..., analyzer=0xb546327c) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:443
#20 0x00e9499f in Nepomuk::IndexScheduler::updateDir (this=0x8613e60, dir=..., analyzer=0xb546327c, flags=...) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:413
#21 0x00e9717b in Nepomuk::IndexScheduler::run (this=0x8613e60) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/services/strigi/indexscheduler.cpp:314
#22 0x063d368f in QThreadPrivate::start (arg=0x8613e60) at thread/qthread_unix.cpp:248
#23 0x00994919 in start_thread (arg=0xb5463b70) at pthread_create.c:301
#24 0x00b3cd4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb77ff780 (LWP 2530)):
#0  0x001c9424 in __kernel_vsyscall ()
#1  0x00b31f56 in __poll (fds=0xbfeb3164, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x0042defc in ?? () from /lib/libdbus-1.so.3
#3  0x00425c2f in ?? () from /lib/libdbus-1.so.3
#4  0x00423d9c in ?? () from /lib/libdbus-1.so.3
#5  0x0040dfa3 in ?? () from /lib/libdbus-1.so.3
#6  0x0040e878 in ?? () from /lib/libdbus-1.so.3
#7  0x0041064f in ?? () from /lib/libdbus-1.so.3
#8  0x0041e472 in dbus_pending_call_block () from /lib/libdbus-1.so.3
#9  0x0040fc5c in dbus_connection_send_with_reply_and_block () from /lib/libdbus-1.so.3
#10 0x00852f1d in q_dbus_connection_send_with_reply_and_block (this=0x85d26c8, message=..., sendMode=1, timeout=-1) at qdbus_symbols_p.h:133
#11 QDBusConnectionPrivate::sendWithReply (this=0x85d26c8, message=..., sendMode=1, timeout=-1) at qdbusintegrator.cpp:1828
#12 0x0083ee9b in QDBusConnection::call (this=0x8611cb8, message=..., mode=QDBus::Block, timeout=-1) at qdbusconnection.cpp:522
#13 0x0085cc7b in QDBusAbstractInterface::callWithArgumentList (this=0x8611c58, mode=QDBus::Block, method=..., args=...) at qdbusabstractinterface.cpp:440
#14 0x06811ea3 in ?? () from /usr/lib/libsopranoclient.so.1
#15 0x06812bb6 in Soprano::Client::DBusClient::createModel(QString const&, QList<Soprano::BackendSetting> const&) () from /usr/lib/libsopranoclient.so.1
#16 0x067850fd in (anonymous namespace)::GlobalModelContainer::init (this=0x86115a8, forced=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:92
#17 0x06788c46 in Nepomuk::MainModel::init (this=0x8611750) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:176
#18 0x0677ec86 in Nepomuk::ResourceManager::init (this=0x85ea128) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:329
#19 0x0678112b in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x860fec8, success=true) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:220
#20 0x06781243 in Nepomuk::ResourceManager::qt_metacall (this=0x85ea128, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfeb399c)
    at /usr/src/debug/kdelibs-4.5.5/i686-redhat-linux-gnu/nepomuk/resourcemanager.moc:90
#21 0x0084d77c in QDBusConnectionPrivate::deliverCall (this=0x85d26c8, object=0x85ea128, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:904
#22 0x00858418 in QDBusCallDeliveryEvent::placeMetaCall (this=0x8670648, object=0x85ea128) at qdbusintegrator_p.h:101
#23 0x064d443e in QObject::event (this=0x85ea128, e=0x8670648) at kernel/qobject.cpp:1248
#24 0x06c7874c in QApplicationPrivate::notify_helper (this=0x85436f8, receiver=0x85ea128, e=0x8670648) at kernel/qapplication.cpp:4306
#25 0x06c7f1a6 in QApplication::notify (this=0xbfeb4338, receiver=0x85ea128, e=0x8670648) at kernel/qapplication.cpp:3710
#26 0x0775aa5b in KApplication::notify (this=0xbfeb4338, receiver=0x85ea128, event=0x8670648) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#27 0x064c4563 in QCoreApplication::notifyInternal (this=0xbfeb4338, receiver=0x85ea128, event=0x8670648) at kernel/qcoreapplication.cpp:726
#28 0x064c69ec in sendEvent (receiver=0x0, event_type=0, data=0x852f690) at kernel/qcoreapplication.h:215
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x852f690) at kernel/qcoreapplication.cpp:1367
#30 0x064c6b6e in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#31 0x064ecc30 in sendPostedEvents (s=0x8545390) at kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=0x8545390) at kernel/qeventdispatcher_glib.cpp:276
#33 0x00c26525 in g_main_dispatch (context=0x8545310) at gmain.c:1960
#34 IA__g_main_context_dispatch (context=0x8545310) at gmain.c:2513
#35 0x00c2a268 in g_main_context_iterate (context=0x997490, block=1, dispatch=1, self=0x8543650) at gmain.c:2591
#36 0x00c2a449 in IA__g_main_context_iteration (context=0x8545310, may_block=1) at gmain.c:2654
#37 0x064ec726 in QEventDispatcherGlib::processEvents (this=0x852f140, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#38 0x06d26b56 in QGuiEventDispatcherGlib::processEvents (this=0x852f140, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#39 0x064c2c3a in QEventLoop::processEvents (this=0xbfeb41c4, flags=...) at kernel/qeventloop.cpp:149
#40 0x064c2f7a in QEventLoop::exec (this=0xbfeb41c4, flags=...) at kernel/qeventloop.cpp:201
#41 0x064c6c37 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#42 0x06c787f8 in QApplication::exec () at kernel/qapplication.cpp:3585
#43 0x0804b07e in main (argc=) at /usr/src/debug/kdebase-runtime-4.5.5/nepomuk/servicestub/main.cpp:165

This bug may be a duplicate of or related to bug 245266.

Possible duplicates by query: bug 263663, bug 256895, bug 255649, bug 252767, bug 251375.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-03-18 10:50:23 UTC

*** This bug has been marked as a duplicate of bug 245266 ***