Bug 271343 - Nepomuk crashes when logging in
Summary: Nepomuk crashes when logging in
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 12:36 UTC by write.tom.moore
Modified: 2011-05-01 16:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description write.tom.moore 2011-04-20 12:36:43 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.8-68.fc13.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
just booted and logged on to the system when Nepomuk crashed.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
61	      LLL_MUTEX_LOCK (mutex);
[Current thread is 1 (Thread 0x7f1fd5b01820 (LWP 2794))]

Thread 2 (Thread 0x7f1fc9f47700 (LWP 2864)):
[KCrash Handler]
#6  0x0000003741a6cf3c in QMutex::lock() () from /usr/lib64/libQtCore.so.4
#7  0x0000003745c501d1 in relock (this=0x7f1fc4078d80) at /usr/include/QtCore/qmutex.h:120
#8  QMutexLocker (this=0x7f1fc4078d80) at /usr/include/QtCore/qmutex.h:102
#9  Soprano::Error::ErrorCache::clearError (this=0x7f1fc4078d80) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:238
#10 0x0000003745c50420 in Soprano::Error::ErrorCache::setError (this=0x7f1fc4078d80, error=...) at /usr/src/debug/soprano-2.5.2/soprano/error.cpp:225
#11 0x0000003b6b031cda in Soprano::Client::DBusModel::executeQuery (this=0x7f1fc4078d70, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.2/client/dbus/dbusmodel.cpp:108
#12 0x0000003b6b83e17a in Nepomuk::MainModel::executeQuery (this=0x26fb000, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:212
#13 0x0000003745c5b4cc in Soprano::FilterModel::executeQuery (this=0x26f9e90, query=<value optimized out>, language=<value optimized out>, userQueryLanguage=<value optimized out>)
    at /usr/src/debug/soprano-2.5.2/soprano/filtermodel.cpp:164
#14 0x0000003b6b833502 in Nepomuk::ResourceData::determineUri (this=0x7f1fc4090770) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcedata.cpp:580
#15 0x0000003b6b8421ca in Nepomuk::Resource::determineFinalResourceData (this=0x7f1fc9f46a90) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:885
#16 0x0000003b6b8424c9 in Nepomuk::Resource::exists (this=0x7f1fc9f46a90) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resource.cpp:328
#17 0x00007f1fca7d13b5 in ?? () from /usr/lib64/kde4/nepomukstrigiservice.so
#18 0x00007f1fca7d4045 in ?? () from /usr/lib64/kde4/nepomukstrigiservice.so
#19 0x0000003741a71155 in ?? () from /usr/lib64/libQtCore.so.4
#20 0x0000003d00e07761 in start_thread (arg=0x7f1fc9f47700) at pthread_create.c:301
#21 0x0000003d002e098d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f1fd5b01820 (LWP 2794)):
#0  0x0000003d00e09191 in __pthread_mutex_lock (mutex=0x2666810) at pthread_mutex_lock.c:61
#1  0x0000003b6782aa18 in _dbus_pthread_mutex_lock (mutex=0x2666810) at dbus-sysdeps-pthread.c:141
#2  0x0000003b6780e6f9 in _dbus_connection_acquire_io_path (connection=0x26666c0, timeout_milliseconds=-1) at dbus-connection.c:1031
#3  0x0000003b6780eb87 in _dbus_connection_do_iteration_unlocked (connection=0x26666c0, flags=7, timeout_milliseconds=-1) at dbus-connection.c:1158
#4  0x0000003b6780f362 in _dbus_connection_flush_unlocked (connection=0x26666c0) at dbus-connection.c:3405
#5  0x0000003b67810eb1 in _dbus_connection_block_pending_call (pending=0x27e7a70) at dbus-connection.c:2302
#6  0x0000003b67810586 in dbus_connection_send_with_reply_and_block (connection=0x26666c0, message=0x299a960, timeout_milliseconds=-1, error=0x7fff3053cc00) at dbus-connection.c:3361
#7  0x0000003b68027085 in ?? () from /usr/lib64/libQtDBus.so.4
#8  0x0000003b68013ab3 in QDBusConnection::call(QDBusMessage const&, QDBus::CallMode, int) const () from /usr/lib64/libQtDBus.so.4
#9  0x0000003b68030352 in QDBusAbstractInterface::callWithArgumentList(QDBus::CallMode, QString const&, QList<QVariant> const&) () from /usr/lib64/libQtDBus.so.4
#10 0x0000003b6b02ece4 in Soprano::Client::DBusServerInterface::createModel (this=0x26fba70, name=<value optimized out>) at /usr/src/debug/soprano-2.5.2/client/dbus/dbusserverinterface.h:57
#11 0x0000003b6b02f8cd in Soprano::Client::DBusClient::createModel (this=0x26fb810, name=<value optimized out>, settings=<value optimized out>)
    at /usr/src/debug/soprano-2.5.2/client/dbus/dbusclient.cpp:73
#12 0x0000003b6b83d1a0 in (anonymous namespace)::GlobalModelContainer::init (this=0x26fb810, forced=<value optimized out>) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:92
#13 0x0000003b6b8409ba in Nepomuk::MainModel::init (this=0x26fb000) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/nepomukmainmodel.cpp:176
#14 0x0000003b6b83762e in Nepomuk::ResourceManager::init (this=0x26f8240) at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:329
#15 0x0000003b6b839815 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x26f9d30, success=<value optimized out>)
    at /usr/src/debug/kdelibs-4.5.5/nepomuk/core/resourcemanager.cpp:220
#16 0x0000003b6b839905 in Nepomuk::ResourceManager::qt_metacall (this=0x26f8240, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3053d5c0)
    at /usr/src/debug/kdelibs-4.5.5/x86_64-redhat-linux-gnu/nepomuk/resourcemanager.moc:90
#17 0x0000003b68021eb6 in ?? () from /usr/lib64/libQtDBus.so.4
#18 0x0000003b6802c19f in ?? () from /usr/lib64/libQtDBus.so.4
#19 0x0000003741b62c01 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#20 0x0000003b68bab39c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x0000003b68bb165b in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x0000003b6aa1d186 in KApplication::notify (this=0x7fff3053e1d0, receiver=0x26f8240, event=0x273ab60) at /usr/src/debug/kdelibs-4.5.5/kdeui/kernel/kapplication.cpp:310
#23 0x0000003741b53adc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#24 0x0000003741b55bd4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#25 0x0000003741b799c3 in ?? () from /usr/lib64/libQtCore.so.4
#26 0x0000003d02e3bd02 in g_main_dispatch (context=0x25d5df0) at gmain.c:1960
#27 IA__g_main_context_dispatch (context=0x25d5df0) at gmain.c:2513
#28 0x0000003d02e3fae8 in g_main_context_iterate (context=0x25d5df0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#29 0x0000003d02e3fc9c in IA__g_main_context_iteration (context=0x25d5df0, may_block=1) at gmain.c:2654
#30 0x0000003741b79503 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#31 0x0000003b68c4a73e in ?? () from /usr/lib64/libQtGui.so.4
#32 0x0000003741b52522 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#33 0x0000003741b527ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#34 0x0000003741b55ebb in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#35 0x0000000000403b94 in _start ()

This bug may be a duplicate of or related to bug 245266.

Possible duplicates by query: bug 258235, bug 256895, bug 255649, bug 252766, bug 252062.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-01 16:47:01 UTC
[Comment from a bug triager]
The bug is fixed since KDE SC 4.6.x. The issue was being tracked at bug 245266, merging.
Thanks

*** This bug has been marked as a duplicate of bug 245266 ***