Bug 271891 - Plasma Desktop crashed
Summary: Plasma Desktop crashed
Status: RESOLVED DUPLICATE of bug 271889
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-28 03:21 UTC by rflazaro
Modified: 2011-04-28 10:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rflazaro 2011-04-28 03:21:48 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39-rc4-12-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running BleachBit to clean out unnecessary files on my machine

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Bus error
[Current thread is 1 (Thread 0x7fd5ec3aa760 (LWP 3151))]

Thread 2 (Thread 0x7fd5c8361700 (LWP 3167)):
#0  0x00007fd5e9aa9503 in poll () from /lib64/libc.so.6
#1  0x00007fd5e691b114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fd5eb09a976 in QEventDispatcherGlib::processEvents (this=0x10ad7c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fd5c8360d20, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd5eaf841e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007fd5eb050968 in QInotifyFileSystemWatcherEngine::run (this=0xfc7360) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd5eaf86a5e in QThreadPrivate::start (arg=0xfc7360) at thread/qthread_unix.cpp:285
#9  0x00007fd5de4d9853 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007fd5eacf7a3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fd5e9ab267d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd5ec3aa760 (LWP 3151)):
[KCrash Handler]
#6  0x00007fd5eb5accdd in lock (this=0x7fff98adfac0, _d=0xef6e90) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1098
#7  cautiousLock (this=0x7fff98adfac0, _d=0xef6e90) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1121
#8  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff98adfac0, _d=0xef6e90) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1146
#9  0x00007fd5eb502d60 in KSharedDataCache::find (this=0xef7390, key=..., destination=0x7fff98adfb00) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1462
#10 0x00007fd5ebe47b6f in KImageCache::findPixmap (this=0xef7390, key=..., destination=0x7fff98adfb60) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kimagecache.cpp:150
#11 0x00007fd5e1e69a73 in Plasma::Theme::findInCache (this=0x754260, key=..., pix=...) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:906
#12 0x00007fd5e1e07d63 in Plasma::FrameSvgPrivate::generateBackground (this=0xda5040, frame=0x17e1720) at /usr/src/debug/kdelibs-4.6.0/plasma/framesvg.cpp:671
#13 0x00007fd5e1e08b1b in Plasma::FrameSvg::framePixmap (this=0xda4b90) at /usr/src/debug/kdelibs-4.6.0/plasma/framesvg.cpp:503
#14 0x00007fd5d008da6e in AbstractTaskItem::drawBackground (this=0x892020, painter=0x7fff98ae26d0, option=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/abstracttaskitem.cpp:621
#15 0x00007fd5d008b74a in AbstractTaskItem::paint (this=0x892020, painter=0x7fff98ae26d0, option=0x7a4e48, widget=0x12e7650) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/applets/tasks/abstracttaskitem.cpp:520
#16 0x00007fd5ea80341d in _q_paintItem (item=<value optimized out>, painter=0x7fff98ae26d0, option=0x7a4e48, widget=0x12e7650, useWindowOpacity=<value optimized out>, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0x00007fd5ea815d64 in QGraphicsScenePrivate::drawItemHelper (this=0x7a4c20, item=0x892030, painter=0x7fff98ae26d0, option=0x7a4e48, widget=0x12e7650, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4427
#18 0x00007fd5ea817ec1 in QGraphicsScenePrivate::draw (this=0x7a4c20, item=0x892030, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, transformPtr=0x7fff98ae0e40, exposedRegion=0x139cfc0, widget=0x12e7650, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4931
#19 0x00007fd5ea818ac7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7a4c20, item=0x892030, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, exposedRegion=0x139cfc0, widget=0x12e7650, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#20 0x00007fd5ea817f58 in QGraphicsScenePrivate::draw (this=0x7a4c20, item=0xda2500, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, transformPtr=0x7fff98ae13f0, exposedRegion=0x139cfc0, widget=0x12e7650, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#21 0x00007fd5ea818ac7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7a4c20, item=0xda2500, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, exposedRegion=0x139cfc0, widget=0x12e7650, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#22 0x00007fd5ea817f58 in QGraphicsScenePrivate::draw (this=0x7a4c20, item=0xb11ba0, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, transformPtr=0x7fff98ae19a0, exposedRegion=0x139cfc0, widget=0x12e7650, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#23 0x00007fd5ea818ac7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7a4c20, item=0xb11ba0, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, exposedRegion=0x139cfc0, widget=0x12e7650, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#24 0x00007fd5ea817f58 in QGraphicsScenePrivate::draw (this=0x7a4c20, item=0x96cbe0, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, transformPtr=0x7fff98ae1f50, exposedRegion=0x139cfc0, widget=0x12e7650, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4945
#25 0x00007fd5ea818ac7 in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x7a4c20, item=0x96cbe0, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, exposedRegion=0x139cfc0, widget=0x12e7650, parentOpacity=<value optimized out>, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#26 0x00007fd5ea81933c in QGraphicsScenePrivate::drawItems (this=0x7a4c20, painter=0x7fff98ae26d0, viewTransform=0x7fff98ae2460, exposedRegion=0x139cfc0, widget=0x12e7650) at graphicsview/qgraphicsscene.cpp:4735
#27 0x00007fd5ea83662c in QGraphicsView::paintEvent (this=0x1101ca0, event=<value optimized out>) at graphicsview/qgraphicsview.cpp:3469
#28 0x00007fd5ea2704ea in QWidget::event (this=0x1101ca0, event=0x7fff98ae3020) at kernel/qwidget.cpp:8346
#29 0x00007fd5ea614906 in QFrame::event (this=0x1101ca0, e=0x7fff98ae3020) at widgets/qframe.cpp:557
#30 0x00007fd5ea8378bb in QGraphicsView::viewportEvent (this=0x1101ca0, event=0x7fff98ae3020) at graphicsview/qgraphicsview.cpp:2864
#31 0x00007fd5eb06fd87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x12e7650, event=0x7fff98ae3020) at kernel/qcoreapplication.cpp:847
#32 0x00007fd5ea21ece1 in QApplicationPrivate::notify_helper (this=0x6f8840, receiver=0x12e7650, e=0x7fff98ae3020) at kernel/qapplication.cpp:4441
#33 0x00007fd5ea22722a in QApplication::notify (this=<value optimized out>, receiver=0x12e7650, e=0x7fff98ae3020) at kernel/qapplication.cpp:4324
#34 0x00007fd5ebd139e6 in KApplication::notify (this=0x6ee830, receiver=0x12e7650, event=0x7fff98ae3020) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#35 0x00007fd5eb06fbfc in QCoreApplication::notifyInternal (this=0x6ee830, receiver=0x12e7650, event=0x7fff98ae3020) at kernel/qcoreapplication.cpp:732
#36 0x00007fd5ea26d3b2 in sendSpontaneousEvent (this=0x140e370, pdev=0x13419e8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x133fc80) at ../../src/corelib/kernel/qcoreapplication.h:218
#37 QWidgetPrivate::drawWidget (this=0x140e370, pdev=0x13419e8, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x133fc80) at kernel/qwidget.cpp:5433
#38 0x00007fd5ea26df7f in QWidgetPrivate::paintSiblingsRecursive (this=0x139cb30, pdev=0x13419e8, siblings=<value optimized out>, index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x133fc80) at kernel/qwidget.cpp:5640
#39 0x00007fd5ea26d11a in QWidgetPrivate::drawWidget (this=0x139cb30, pdev=0x13419e8, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x133fc80) at kernel/qwidget.cpp:5486
#40 0x00007fd5ea430191 in QWidgetBackingStore::sync (this=0x133fc80) at painting/qbackingstore.cpp:1333
#41 0x00007fd5ea263170 in QWidgetPrivate::syncBackingStore (this=0x139cb30) at kernel/qwidget.cpp:1816
#42 0x00007fd5ea2709f2 in QWidget::event (this=0x1101ca0, event=0x8272f0) at kernel/qwidget.cpp:8493
#43 0x00007fd5ea614906 in QFrame::event (this=0x1101ca0, e=0x8272f0) at widgets/qframe.cpp:557
#44 0x00007fd5ea6959ab in QAbstractScrollArea::event (this=0x1101ca0, e=0x8272f0) at widgets/qabstractscrollarea.cpp:996
#45 0x00007fd5d9df72b0 in PanelView::event (this=0x1101ca0, event=0x8272f0) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/panelview.cpp:1503
#46 0x00007fd5ea21ed14 in QApplicationPrivate::notify_helper (this=0x6f8840, receiver=0x1101ca0, e=0x8272f0) at kernel/qapplication.cpp:4445
#47 0x00007fd5ea22722a in QApplication::notify (this=<value optimized out>, receiver=0x1101ca0, e=0x8272f0) at kernel/qapplication.cpp:4324
#48 0x00007fd5ebd139e6 in KApplication::notify (this=0x6ee830, receiver=0x1101ca0, event=0x8272f0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#49 0x00007fd5eb06fbfc in QCoreApplication::notifyInternal (this=0x6ee830, receiver=0x1101ca0, event=0x8272f0) at kernel/qcoreapplication.cpp:732
#50 0x00007fd5eb0733f5 in sendEvent (receiver=0x1101ca0, event_type=77, data=0x6103e0) at kernel/qcoreapplication.h:215
#51 QCoreApplicationPrivate::sendPostedEvents (receiver=0x1101ca0, event_type=77, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#52 0x00007fd5ea80ff7a in dispatchPendingUpdateRequests (this=0x7a4c20) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#53 QGraphicsScenePrivate::_q_processDirtyItems (this=0x7a4c20) at graphicsview/qgraphicsscene.cpp:510
#54 0x00007fd5ea81037a in QGraphicsScene::qt_metacall (this=0x7e4f80, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x85c370) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#55 0x00007fd5e1ddc125 in Plasma::Corona::qt_metacall (this=0x7e4f80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x85c370) at /usr/src/debug/kdelibs-4.6.0/build/plasma/corona.moc:109
#56 0x00007fd5d9deb2e5 in DesktopCorona::qt_metacall (this=0x7e4f80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x85c370) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/desktop/shell/desktopcorona.moc:101
#57 0x00007fd5eb083a6a in QObject::event (this=0x7e4f80, e=<value optimized out>) at kernel/qobject.cpp:1211
#58 0x00007fd5ea81cc80 in QGraphicsScene::event (this=0x7e4f80, event=0x1822950) at graphicsview/qgraphicsscene.cpp:3544
#59 0x00007fd5ea21ed14 in QApplicationPrivate::notify_helper (this=0x6f8840, receiver=0x7e4f80, e=0x1822950) at kernel/qapplication.cpp:4445
#60 0x00007fd5ea22722a in QApplication::notify (this=<value optimized out>, receiver=0x7e4f80, e=0x1822950) at kernel/qapplication.cpp:4324
#61 0x00007fd5ebd139e6 in KApplication::notify (this=0x6ee830, receiver=0x7e4f80, event=0x1822950) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#62 0x00007fd5eb06fbfc in QCoreApplication::notifyInternal (this=0x6ee830, receiver=0x7e4f80, event=0x1822950) at kernel/qcoreapplication.cpp:732
#63 0x00007fd5eb0733f5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#64 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#65 0x00007fd5eb09a783 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#66 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#67 0x00007fd5e691abd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#68 0x00007fd5e691b3b0 in ?? () from /lib64/libglib-2.0.so.0
#69 0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#70 0x00007fd5eb09a91f in QEventDispatcherGlib::processEvents (this=0x6ef270, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#71 0x00007fd5ea2c3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#72 0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#73 0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fff98ae50a0, flags=...) at kernel/qeventloop.cpp:201
#74 0x00007fd5eb0736ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#75 0x00007fd5d9df1da8 in kdemain (argc=1, argv=0x6b2f60) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#76 0x00000000004075e9 in _start ()

This bug may be a duplicate of or related to bug 271890.

Possible duplicates by query: bug 271890, bug 271480.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-04-28 10:10:28 UTC

*** This bug has been marked as a duplicate of bug 271889 ***